Author Topic: -Wall forced in compile command  (Read 2935 times)

Offline c.panel

  • Multiple posting newcomer
  • *
  • Posts: 16
    • TopoCad
-Wall forced in compile command
« on: April 16, 2013, 12:14:48 pm »
I found no way to disable the -Wall compile option which seems to be inserted in compile command line. Is it a bug ?
this bug exists too when I change compiler and throw an error.
I'm using Codeblocks 12.11 on WindowsXP

thanks for any answer... 

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: -Wall forced in compile command
« Reply #1 on: April 16, 2013, 12:26:51 pm »
If it is not set in the projects (or targets) build-options, it must be set in global compiler settings.
Please check all these places.

C::B does not add it itself (except for the settings of wizard-created projects).

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6538
    • My Best Post
Re: -Wall forced in compile command
« Reply #2 on: April 16, 2013, 05:21:14 pm »
I found no way to disable the -Wall compile option which seems to be inserted in compile command line. Is it a bug ?
this bug exists too when I change compiler and throw an error.

Warning when changing compilers in projects the options NOT valid for new Compiler tend to move to the other settings for Linker and Compiler options.

Where to look for Compiler Other Options

Project -> Build Options
NOTE: Remember Select each target one by one to check each one for the options.
Tab "Compiler Settings"
Sub-Tab "Other Options"

Tim S.
« Last Edit: April 16, 2013, 05:26:42 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org