Author Topic: How to change target type ??  (Read 5651 times)

Offline grofaz

  • Single posting newcomer
  • *
  • Posts: 6
How to change target type ??
« on: December 28, 2005, 10:53:05 pm »
Hi,

When I build a project the output is an ".exe" file. How do I set the compiler to output an "a.out" type file ?

When I try to run the ".exe" file I get a can't load dynamic library error and I think it's because I'm outputing ".exe" files.

Thanks for any help.

Regards...

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: How to change target type ??
« Reply #1 on: December 28, 2005, 11:09:04 pm »
Hi,

When I build a project the output is an ".exe" file. How do I set the compiler to output an "a.out" type file ?

When I try to run the ".exe" file I get a can't load dynamic library error and I think it's because I'm outputing ".exe" files.

The actual name of the file has no impact at all when running it. You could rename it to "something.dat" and you could still execute it. That's not your problem. The problem is that a library your project is linked against dynamically, can't be found at runtime.
Btw, when you 're getting errors and asking for help, it would be a good idea to post the exact error...
Be patient!
This bug will be fixed soon...

Offline grofaz

  • Single posting newcomer
  • *
  • Posts: 6
Re: How to change target type ??
« Reply #2 on: December 28, 2005, 11:24:52 pm »
Well,

How do I change the default terminal from XTerm to Gnome Terminal ? What is the correct procedure and syntacs ?

Then perhaps I can post some error messages.

Thanks for you swift reply btw.

grofaz

Offline grofaz

  • Single posting newcomer
  • *
  • Posts: 6
Re: How to change target type ??
« Reply #3 on: December 28, 2005, 11:29:07 pm »
As for the missing library, I can't figure that out. All the necessary libraries are in /usr/local/lib and /usr/local/lib/OGRE.
My ld.so.conf file has /usr/local/lib appended and I have run ldconfig so paths shouldn't be an issue but obviously is. SDL and GLFW projects are working correctly, OGRE is the ogre. :)

Thanks again,
grofaz

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: How to change target type ??
« Reply #4 on: December 29, 2005, 01:25:54 am »
How do I change the default terminal from XTerm to Gnome Terminal ? What is the correct procedure and syntacs ?

"Settings->Compiler->Other->Terminal to run console programs". The syntax depends on the terminal you 'll be using. The default command uses xterm.
Be patient!
This bug will be fixed soon...

Offline grofaz

  • Single posting newcomer
  • *
  • Posts: 6
Re: How to change target type ??
« Reply #5 on: December 29, 2005, 04:11:48 am »
Where would I find the command syntacs ? I want to use the gnome-terminal.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: How to change target type ??
« Reply #6 on: December 29, 2005, 09:43:56 am »
Where would I find the command syntacs ? I want to use the gnome-terminal.

man gnome-terminal ??
Be patient!
This bug will be fixed soon...