Author Topic: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?  (Read 6908 times)

Offline freepro

  • Multiple posting newcomer
  • *
  • Posts: 31
CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« on: March 06, 2013, 01:00:56 pm »
I installed wxWidgets-2.9.4 and wx-config --version also is 2.9.4, but the CodeBlocks-12.11 use wx-2.8 to compile wxWidgets program.
What happened? How i should to do?
Thank you!

PS:
bill@freepro:~$ wx-config --cflags
-I/usr/local/lib/wx/include/gtk2-unicode-2.9 -I/usr/local/include/wx-2.9 -D_FILE_OFFSET_BITS=64 -DWXUSINGDLL -D__WXGTK__ -pthread
bill@freepro:~$ wx-config --libs
-L/usr/local/lib -pthread   -lwx_gtk2u_xrc-2.9 -lwx_gtk2u_html-2.9 -lwx_gtk2u_qa-2.9 -lwx_gtk2u_adv-2.9 -lwx_gtk2u_core-2.9 -lwx_baseu_xml-2.9 -lwx_baseu_net-2.9 -lwx_baseu-2.9

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #1 on: March 06, 2013, 01:07:33 pm »
How and where do you call in C::B.

Was C::B while installng wx2.9.4 ? The result of calling a backticked expression is cached as long as C::B is open.

Offline freepro

  • Multiple posting newcomer
  • *
  • Posts: 31
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #2 on: March 06, 2013, 01:14:18 pm »
How and where do you call in C::B.

Was C::B while installng wx2.9.4 ? The result of calling a backticked expression is cached as long as C::B is open.

I'm so sorry, my english is poor.
I use CodeBlocks-12.11 to write wxWidgets program . and my Linux installed wxWidgets-2.9.4, but CodeBlocks use wx-2.8 to compile program.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #3 on: March 06, 2013, 01:39:24 pm »
Was C::B opened while installing wx2.9.4 ?

Sorry my fault, I missed a word in my previous post.

Can you attach the project file you use, or send it via mail to me?

jens at codeblocks dot org

Offline freepro

  • Multiple posting newcomer
  • *
  • Posts: 31
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #4 on: March 06, 2013, 01:49:52 pm »
Was C::B opened while installing wx2.9.4 ?

Sorry my fault, I missed a word in my previous post.

Can you attach the project file you use, or send it via mail to me?

jens at codeblocks dot org
I'v send email to you.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #5 on: March 06, 2013, 02:04:16 pm »
The file looks good.

Again my question:
Was C::B opened while installing wx2.9.4 ?

If wx-config for 2.9 is used from console, it should also be used from inside C::B.

You can try to add --version=2.8 to the calls of wx-config in the build-options.

Offline freepro

  • Multiple posting newcomer
  • *
  • Posts: 31
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #6 on: March 06, 2013, 02:19:09 pm »
The file looks good.

Again my question:
Was C::B opened while installing wx2.9.4 ?

If wx-config for 2.9 is used from console, it should also be used from inside C::B.

You can try to add --version=2.8 to the calls of wx-config in the build-options.
Can you tell me how to do?

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #7 on: March 06, 2013, 03:22:03 pm »
The file looks good.

Again my question:
Was C::B opened while installing wx2.9.4 ?

If wx-config for 2.9 is used from console, it should also be used from inside C::B.

You can try to add --version=2.8 to the calls of wx-config in the build-options.
Can you tell me how to do?

Not before you answer the question, I asked three times now !

Offline freepro

  • Multiple posting newcomer
  • *
  • Posts: 31
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #8 on: March 06, 2013, 03:33:00 pm »
The file looks good.

Again my question:
Was C::B opened while installing wx2.9.4 ?

If wx-config for 2.9 is used from console, it should also be used from inside C::B.

You can try to add --version=2.8 to the calls of wx-config in the build-options.
Can you tell me how to do?

Not before you answer the question, I asked three times now !

I'm so sorry, i forgot!
I first installed the C::B, and then installed wx.
I 'm using ./confiure make make install ldconfig to install wx.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #9 on: March 06, 2013, 04:06:21 pm »
Still not answered !

Was C::B opened while installing wx2.9.4 ?

If yes close and reopen it, if not, what's the output of wx-config --list ?

Offline freepro

  • Multiple posting newcomer
  • *
  • Posts: 31
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #10 on: March 07, 2013, 01:31:52 am »
Still not answered !

Was C::B opened while installing wx2.9.4 ?

If yes close and reopen it, if not, what's the output of wx-config --list ?

Sorry did not understand what you mean before.
Now, i understand it.
the C::B was closed when installing wx-2.9.4.

this is wx-config --list output:
bill@freepro:~$ wx-config --list

    Default config is gtk2-unicode-2.9

  Default config will be used for output

Offline freepro

  • Multiple posting newcomer
  • *
  • Posts: 31
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #11 on: March 07, 2013, 12:52:43 pm »
I need help, please! :'(

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #12 on: March 07, 2013, 01:53:38 pm »
I need help, please! :'(
You can try a complete rebuild.
And you can also put wx-config --list in the prebuild steps of the project (right-click the project, chose "Build options -> Pre/Post build steps -> Pre-build steps" and put it there) to see what is used by C::B when you build the project.

Offline freepro

  • Multiple posting newcomer
  • *
  • Posts: 31
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #13 on: March 07, 2013, 02:31:35 pm »
I need help, please! :'(
You can try a complete rebuild.
And you can also put wx-config --list in the prebuild steps of the project (right-click the project, chose "Build options -> Pre/Post build steps -> Pre-build steps" and put it there) to see what is used by C::B when you build the project.


This is output:

Offline freepro

  • Multiple posting newcomer
  • *
  • Posts: 31
Re: CodeBlocks 12.11 cann't use wxWidgets-2.9.4?
« Reply #14 on: March 07, 2013, 02:45:16 pm »
I'm about to collapse!
What happened? :'(