Author Topic: [SOLVED] Code::Blocks SVN 8599 - Typing '{' does not put cursor on next line  (Read 3537 times)

Offline Linux_dWiebe

  • Multiple posting newcomer
  • *
  • Posts: 17
Is this an aspect of CB from now on? Or is it customizable via a setting?

Description of problem:
Editing a .c file....
Type '{' and CB automatically makes this '{|}' with the cursor where the '|' is.

What I like it to do is this:
Type '{' and it goes to this:
{
     |
}

with the '|' being the cursor.

Any help would be appreciated.
« Last Edit: December 14, 2012, 01:58:52 am by Linux_dWiebe »

Offline Alpha

  • Developer
  • Lives here!
  • *****
  • Posts: 1513
Re: Code::Blocks SVN 8599 - Typing '{' does not put cursor on next line
« Reply #1 on: December 13, 2012, 11:57:48 pm »
Do you have the SmartIndent plugins installed and enabled?

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5147
Re: Code::Blocks SVN 8599 - Typing '{' does not put cursor on next line
« Reply #2 on: December 14, 2012, 12:08:10 am »
what you described, used to be like that for sure for a c++ file, but last 24 hours some commits occurred, not sure if they influenced this ?

Offline Linux_dWiebe

  • Multiple posting newcomer
  • *
  • Posts: 17
Re: Code::Blocks SVN 8599 - Typing '{' does not put cursor on next line
« Reply #3 on: December 14, 2012, 01:58:34 am »
Do you have the SmartIndent plugins installed and enabled?
I didn't, but I do now. I installed codeblocks-contrib and made sure SmartIndent was enabled and it works now. Thanks a lot!

Offline pokemon

  • Single posting newcomer
  • *
  • Posts: 2
Where can I plug Smartident? I installed codeblocks-contrib taken from "deb http://apt.jenslody.de/testing testing main". I write in C. In the list of plugins Smartiden not.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Where can I plug Smartident? I installed codeblocks-contrib taken from "deb http://apt.jenslody.de/testing testing main". I write in C. In the list of plugins Smartiden not.
The plugin libs have been renamed, you might need to run
Code: [Select]
sudo dpkg-reconfigure codeblocks-contrib and make sure that the SmartIndent-plugins (and probably others) you need are checked.

Offline pokemon

  • Single posting newcomer
  • *
  • Posts: 2
Thank you. Plugin SmartIdent really been disabled.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
I just committed a change to the debconf-config files, that make sure the question which plugins should be loaded is asked again, if the plugins list has changed.