Author Topic: The 12.11 RC2 (23 November 2012 build 8598) is out.  (Read 228475 times)

Offline kipade

  • Multiple posting newcomer
  • *
  • Posts: 38
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #30 on: November 26, 2012, 05:37:01 am »
Its was the first try of CodeBlocks under MS Windows with mingw, but, I found it could not load a UTF-8 encoded text file(including *.c and *.cpp source file)
Works for me. Can you send a sample file which does not work? And: Is it really UTF-8?
Yes, its really UTF-8 encoded, Im sure. So, I have to reinstall old version svn8401, it works for me. Because Im Chinese, I usually use Chinese label in my source files, like wxMessageBox(wxT("消息")); if the file encoded in ANSI, gcc will refuse to compile, so I have to convert it into UTF-8 encoded, however, CB can's display it, so that I can't use it to debugging.
Btw, I also have the same problem under linux.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5241
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #31 on: November 26, 2012, 05:55:14 am »
if the file encoded in ANSI, gcc will refuse to compile, so I have to convert it into UTF-8 encoded....
I this case, you can either compile this ansi file with gcc option like
Code: [Select]
-finput-charset=GBK, or convert the file to UTF8 format. So, there are two ways.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline carra

  • Multiple posting newcomer
  • *
  • Posts: 114
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #32 on: November 26, 2012, 10:09:30 am »
I have installed RC2, and it seems to work pretty fine in general. Points I have noticed are:

(1) The Editor Settings and Environment Settings dialogs seem to appear faster now. Which is a welcome improvement! When you are trying configurations you have to open them many times.

(2) I also have problems with UTF-8 encoded sources. I have attached a header that I actually created and edited with previous versions of C::B, by manually selecting the encoding mode as UTF-8.

I have verified through a hex editor that this file does not have BOM, however it displayed (and compiled) correctly in earlier C::B versions. Current version shows garbage for the non-ansii strings it contains.

[attachment deleted by admin]

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #33 on: November 26, 2012, 10:34:15 am »
(2) I also have problems with UTF-8 encoded sources. I have attached a header that I actually created and edited with previous versions of C::B, by manually selecting the encoding mode as UTF-8.
It has already been fixed - see post somewhere else in the forums.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline Randajad

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #34 on: November 26, 2012, 12:24:07 pm »
Have another problem with UTF-8.
Why i need to enable Edit->File encoding->Save BOM by my hands? MSVC and ICC makes invalid result on strings if there is no BOM. I think it's neccessary to add UTF-8(with BOM) to Editor->Other Settings->Encoding.

Also sometimes(can't understand when) CB can't hightlight first line when using UTF-8 with bom.

Offline goral

  • Single posting newcomer
  • *
  • Posts: 6
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #35 on: November 26, 2012, 03:45:01 pm »
[Fedora 17 x64 on VirtualBox, build 8599 (Jens), tested on CMake based project]

1.
When recompile my project, I see a lot of stuff in Build log (and this is OK). The first line is
[100.0% Running command: (blablabla)/Makefile" VERBOSE=1

But when I change:
Settings->Compiler->Other settings->Compiler logging: Task description
there is only one line during whole recompilation:
[100.0%] Using makefile: Makefile

Old version 10.05 works as expected:
[  1%] Building...
[  2%] Building...
etc.

2.
It is not easy to break compilation process.

3.
Codeblocks stops responding during debugging quite often.
Debug/Continue and then Break debugger - program stops but then codeblocks freezes.
UPDATE:
It freezes just when source file is loaded into editor.

4.
How to select and copy text from Debugger log? Selection disappears immediately.
« Last Edit: November 26, 2012, 05:07:37 pm by goral »

Offline SC

  • Single posting newcomer
  • *
  • Posts: 5
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #36 on: November 26, 2012, 05:07:23 pm »
Hi, I just updated to RC2. When using the "Project-> Set programs' argument" menu, modifications in program arguments are lost when clicking on another target. One apparently has to click on "OK" after setting up the argument for a given target, and come back to "Project-> Set programs' argument" to modify the arguments for the next one.
SC
Hello, does anyone have an idea on this one?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12090
    • Travis build status
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #37 on: November 26, 2012, 05:53:16 pm »
Hello, does anyone have an idea on this one?
Known issue... should be fixed someday...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #38 on: November 26, 2012, 10:14:04 pm »
1.
When recompile my project, I see a lot of stuff in Build log (and this is OK). The first line is
[100.0% Running command: (blablabla)/Makefile" VERBOSE=1

But when I change:
Settings->Compiler->Other settings->Compiler logging: Task description
there is only one line during whole recompilation:
[100.0%] Using makefile: Makefile

Old version 10.05 works as expected:
[  1%] Building...
[  2%] Building...
etc.
Are you sure it worked with makefile based (as cmake projects are)?
I can't believe it, because C::B does not (and can not) scan makefiles, and is therefore not able to know wich percentage of the build-process is done.

It works as you have described with C::B's native projects.

About the 3rd point: sometimes need time before the break work, at least if multiple parallel build processes are used.

Offline goral

  • Single posting newcomer
  • *
  • Posts: 6
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #39 on: November 27, 2012, 11:35:04 am »
1.
When recompile my project, I see a lot of stuff in Build log (and this is OK). The first line is
[100.0% Running command: (blablabla)/Makefile" VERBOSE=1
Are you sure it worked with makefile based (as cmake projects are)?
I can't believe it, because C::B does not (and can not) scan makefiles, and is therefore not able to know wich percentage of the build-process is done.

It works as you have described with C::B's native projects.

About the 3rd point: sometimes need time before the break work, at least if multiple parallel build processes are used.

You are right, I mean: CMake generated C::B native project. 10.05 version works as expected (and I am used to it since I work with it for more than year)
So I wonder it is a problem with CMake project generator or with new release of C::B.

But the most important is why C::B freezes when loads a source file. I have just removed codeblocks-contrib and it did not help.

I am testing it on virtual machine (Fedora 17 on Fedora 17) because I do not know how to install nigty builds beside oficial release (where I work on my projects), but I hope this virtualization does not casuse such problems.

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #40 on: November 27, 2012, 12:09:31 pm »
But the most important is why C::B freezes when loads a source file. I have just removed codeblocks-contrib and it did not help.
What file? Samples please, otherwise we cannot reproduce and cannot do anything about it.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline goral

  • Single posting newcomer
  • *
  • Posts: 6
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #41 on: November 27, 2012, 12:48:51 pm »
But the most important is why C::B freezes when loads a source file. I have just removed codeblocks-contrib and it did not help.
What file? Samples please, otherwise we cannot reproduce and cannot do anything about it.

I know.
But it is quite strange. Loading sqlite3.h file (original version 3.7.13) to C::B with no worspace succeedes, but when I load my .cbp project and then open sqlite3.h the C::B freezes. I will try to prepare a minimal test case.
« Last Edit: November 27, 2012, 01:00:05 pm by goral »

Offline ptolomey

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #42 on: November 27, 2012, 07:45:32 pm »
The Source formatter doesn't work for me on Code::Blocks 12.11 RC2 (23 November 2012 build 8598)
I use Ubuntu 12.04, 32 bit.
The Code::Blocks repository for Ubuntu linux is ppa: https://launchpad.net/~pasgui/+archive/ppa/

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #43 on: November 27, 2012, 08:01:17 pm »
The Source formatter doesn't work for me on Code::Blocks 12.11 RC2 (23 November 2012 build 8598)
I use Ubuntu 12.04, 32 bit.
What exactly does not work? Steps to reproduce? It works fine here.

Just saying that "something does not work" is not really helpful you know...
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

stefanos_

  • Guest
Re: The 12.11 RC2 (23 November 2012 build 8598) is out.
« Reply #44 on: November 28, 2012, 01:46:46 pm »
Guys, upon moving buttons from wxBoxSizer1 to wxBoxSizer2 it crashed twice up to now. I will try to reproduce it and write down the steps.

It happened under Windows XP, svn-8587, TDM's GCC 4.7.1-2 [32-bit], wxMSW-2.8.12