Author Topic: The 02 November 2012 build (8500) is out.  (Read 139639 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5193
The 02 November 2012 build (8500) is out.
« on: November 02, 2012, 01:34:21 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

Before you use a nightly make sure you understand how it works.

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw28u_gcc_cb_wx2812_gcc471-TDM.7z

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10_gcc471-TDM.7z

The 02 November 2012 build is out.
  - Windows :
   http://prdownload.berlios.de/codeblocks/CB_20121102_rev8500_win32.7z
  - Linux :
   none

Resolved Fixed:

  • fixed inability to work with files on UNC path's in project
  • fixed partial file corruption in project tree (not project file) when "saving as" the project under another drive
  • fixed bugs related to "save as" a project under a sub-folder on a different drive without layout
  • fixed a crash when compiling a single file as described here: http://forums.codeblocks.org/index.php/topic,17033.msg116227.html#msg116227 (on behalf of Jens)

Regressions/Confirmed/Annoying/Common bugs:



    Offline march1993

    • Single posting newcomer
    • *
    • Posts: 3
    Re: The 02 November 2012 build (8500) is out.
    « Reply #1 on: November 02, 2012, 03:22:59 pm »
    It seems that code completion doesn’t work properly with SDCC 3.2.0.

    Offline MortenMacFly

    • Administrator
    • Lives here!
    • *****
    • Posts: 9508
    Re: The 02 November 2012 build (8500) is out.
    « Reply #2 on: November 02, 2012, 04:31:33 pm »
    It seems that code completion doesn’t work properly with SDCC 3.2.0.
    What do you think shall we make out of this sentence, please? What does when not work with what versions - details, steps to reproduce etc... please.
    Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
    C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
    C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

    Offline jens

    • Administrator
    • Lives here!
    • *****
    • Posts: 7265
      • Jens' unofficial debian-repository for the Code::Blocks - IDE
    Re: The 02 November 2012 build (8500) is out.
    « Reply #3 on: November 02, 2012, 09:15:29 pm »
    As usual:
    Debian packages (binaries and sources) for 32-bit and 64-bit systems can be found in my debian-repo.
    Fedora packages (binaries and sources) for 32-bit and 64-bit systems (fc16, fc17 and fc18) can be found in my rpm-repo .
    Packages for CentOS/RedHat 5 and 6 will follow. can be found there too.

    Offline march1993

    • Single posting newcomer
    • *
    • Posts: 3
    Re: The 02 November 2012 build (8500) is out.
    « Reply #4 on: November 03, 2012, 02:53:31 am »
    It seems that code completion doesn’t work properly with SDCC 3.2.0.
    What do you think shall we make out of this sentence, please? What does when not work with what versions - details, steps to reproduce etc... please.

    install SDCC 3.2.0 and code::blocks 8500, then create a default MCS51 project, open main.c, input "INT", the code completion should pop up with "INT0" or "INT1". but code::blocks does nothing.

    Offline march1993

    • Single posting newcomer
    • *
    • Posts: 3
    Re: The 02 November 2012 build (8500) is out.
    « Reply #5 on: November 03, 2012, 02:54:25 am »
    It seems that code completion doesn’t work properly with SDCC 3.2.0.
    What do you think shall we make out of this sentence, please? What does when not work with what versions - details, steps to reproduce etc... please.

    install SDCC 3.2.0 and code::blocks 8500, then create a default MCS51 project, open main.c, input "INT", the code completion should pop up with "INT0" or "INT1". but code::blocks does nothing.

    It seems that code::blocks works properly with an older version of SDCC.

    Offline ollydbg

    • Developer
    • Lives here!
    • *****
    • Posts: 5247
    • OpenCV and Robotics
      • Chinese OpenCV forum moderator
    Re: The 02 November 2012 build (8500) is out.
    « Reply #6 on: November 03, 2012, 02:35:34 pm »
    I see a wired bug, When I try to use this nightly build version to build the cb, I have such build error:

    Code: [Select]
    -------------- Build: tinyXML in Code::Blocks wx2.8.x (compiler: GNU GCC Compiler)---------------

    Target is up to date.

    -------------- Build: AutoRevision in Code::Blocks wx2.8.x (compiler: GNU GCC Compiler)---------------

    Target is up to date.

    -------------- Build: ConsoleRunner in Code::Blocks wx2.8.x (compiler: GNU GCC Compiler)---------------

    Target is up to date.

    -------------- Build: Squirrel in Code::Blocks wx2.8.x (compiler: GNU GCC Compiler)---------------

    Target is up to date.

    -------------- Build: Squirrel std lib in Code::Blocks wx2.8.x (compiler: GNU GCC Compiler)---------------

    Target is up to date.

    -------------- Build: SqPlus in Code::Blocks wx2.8.x (compiler: GNU GCC Compiler)---------------

    Target is up to date.

    -------------- Build: scintilla in Code::Blocks wx2.8.x (compiler: GNU GCC Compiler)---------------

    Target is up to date.

    -------------- Build: wxpropgrid in Code::Blocks wx2.8.x (compiler: GNU GCC Compiler)---------------

    Target is up to date.
    [100.0%] Running target pre-build steps
    build_tools/autorevision/autorevision +wx +int +t . include/autorevision.h
    'svn' is not recognized as an internal or external command,
    operable program or batch file.
    'git' is not recognized as an internal or external command,
    operable program or batch file.
    'svn' is not recognized as an internal or external command,
    operable program or batch file.

    -------------- Build: sdk in Code::Blocks wx2.8.x (compiler: GNU GCC Compiler)---------------

    Target is up to date.
    [ 33.3%] Running target post-build steps
    [ 66.7%] cmd /c if not exist devel\share\CodeBlocks mkdir devel\share\CodeBlocks
    [100.0%] zip -jq9 devel\share\CodeBlocks\manager_resources.zip sdk\resources\*.xrc
    cmd /c "cd sdk\resources & zip -0 -q ..\..\devel\share\CodeBlocks\manager_resources.zip images\*.png images\12x12\*.png images\16x16\*.png"
    'zip' is not recognized as an internal or external command,
    operable program or batch file.
    Process terminated with status 1 (0 minutes, 4 seconds)
    0 errors, 0 warnings (0 minutes, 4 seconds)


    But I have "zip" and "svn" command in my PATH, see the log:
    Code: [Select]

    C:\>which svn
    C:\Program Files\SlikSvn\bin\svn.EXE

    C:\>which zip
    E:\code\common_bin\zip.EXE

    C:\>


    So, I suspect the PATH variable was sometimes changed by compiler plugin? I will check an old nightly build version.
    If some piece of memory should be reused, turn them to variables (or const variables).
    If some piece of operations should be reused, turn them to functions.
    If they happened together, then turn them to classes.

    Offline ollydbg

    • Developer
    • Lives here!
    • *****
    • Posts: 5247
    • OpenCV and Robotics
      • Chinese OpenCV forum moderator
    Re: The 02 November 2012 build (8500) is out.
    « Reply #7 on: November 03, 2012, 02:56:31 pm »
    The bad thing is: if I rebuild C::B, I will sometimes see the warning message(see below)

    Does this mean that my "PATH" was locked by some one/software?
    If some piece of memory should be reused, turn them to variables (or const variables).
    If some piece of operations should be reused, turn them to functions.
    If they happened together, then turn them to classes.

    Offline ollydbg

    • Developer
    • Lives here!
    • *****
    • Posts: 5247
    • OpenCV and Robotics
      • Chinese OpenCV forum moderator
    Re: The 02 November 2012 build (8500) is out.
    « Reply #8 on: November 04, 2012, 06:25:37 am »
    It looks like in my system, wxSetEnv failed.

    See a related discussion: Re: C::B execution paths

    Quote
    In a private project of mine I had the issue that wxSetEnv is unreliable for some reason. So what I did was the following:
    Code:

    bool mySetEnv(const wxString& name, const wxString& value)
    {
      // The WX-way...
      bool success = wxSetEnv(name, value);

      // The MinGW-way...
      wxString putenv_var = name + wxT("=") + value;
    #if wxUSE_UNICODE
      std::string stl_putenv_var = (const char*)putenv_var.mb_str(wxConvLocal);
    #else
      std::string stl_putenv_var = putenv_var.c_str();
    #endif
      char buffer[stl_putenv_var.length()+1]; memset(buffer, 0x00, sizeof(buffer));
      memcpy(buffer, stl_putenv_var.c_str(), stl_putenv_var.length());
      success &= ( putenv(buffer)==0 ); // returns 0 on success
      // success &= ( _putenv(stl_putenv_var.c_str())==0 );

      return success;
    }// mySetEnv

    ...then (and only then!), all my low-level code that relies on envvars being set worked properly. You may face a similar issue here.
    If some piece of memory should be reused, turn them to variables (or const variables).
    If some piece of operations should be reused, turn them to functions.
    If they happened together, then turn them to classes.

    Offline oBFusCATed

    • Developer
    • Lives here!
    • *****
    • Posts: 12123
      • Travis build status
    Re: The 02 November 2012 build (8500) is out.
    « Reply #9 on: November 04, 2012, 10:37:20 am »
    This line is a bit strange:
    Code: [Select]
        char buffer[stl_putenv_var.length()+1];
    because this is not a valid c++, but probably uses some language extension of gcc.

    About the issue: have you looked at the code of wxsetenv? What does it do?
    Have this problem been reported to wx devs?

    They think it is fixed: http://trac.wxwidgets.org/ticket/1413
    « Last Edit: November 04, 2012, 10:39:06 am by oBFusCATed »
    (most of the time I ignore long posts)
    [strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

    Offline ollydbg

    • Developer
    • Lives here!
    • *****
    • Posts: 5247
    • OpenCV and Robotics
      • Chinese OpenCV forum moderator
    Re: The 02 November 2012 build (8500) is out.
    « Reply #10 on: November 04, 2012, 11:55:16 am »
    This line is a bit strange:
    Code: [Select]
        char buffer[stl_putenv_var.length()+1];
    because this is not a valid c++, but probably uses some language extension of gcc.
    Maybe, morten can say something about this.

    Quote
    About the issue: have you looked at the code of wxsetenv? What does it do?
    see below:
    Code: [Select]
    bool wxSetEnv(const wxString& WXUNUSED_IN_WINCE(var),
                  const wxChar *WXUNUSED_IN_WINCE(value))
    {
        // some compilers have putenv() or _putenv() or _wputenv() but it's better
        // to always use Win32 function directly instead of dealing with them
    #ifdef __WXWINCE__
        // no environment variables under CE
        return false;
    #else
        if ( !::SetEnvironmentVariable(var, value) )
        {
            wxLogLastError(_T("SetEnvironmentVariable"));

            return false;
        }

        return true;
    #endif
    }

    I can not see any reason why SetEnvironmentVariable failed.
    Quote
    Have this problem been reported to wx devs?
    I will report it if I have time.

    Quote
    They think it is fixed: http://trac.wxwidgets.org/ticket/1413
    It said:
    Quote
    Changed 4 years ago by neis
    Fixed by revision 42471, which should have ensured that it's correct in 2.8.0 and later.
    But it appears that the bug is still here in wx2.8.12.


    Edit:
    See here: http://docs.wxwidgets.org/2.9.3/group__group__funcmacro__env.html

    Quote
    bool wxSetEnv    (    const wxString &     var,
          const wxString &     value
       )       

    Sets the value of the environment variable var (adding it if necessary) to value.

    Notice that under Windows platforms the program may have two different environment blocks: the first one is that of a Windows process and is always present, but the CRT may maintain its own independent copy of the environment. wxSetEnv() will always update the first copy, which means that wxGetEnv(), which uses it directly, will always return the expected value after this call. But wxSetEnv() only updates the second copy for some compilers/CRT implementations (currently only MSVC and MinGW which uses the same MSVC CRT) and so using wxGetenv() (notice the difference in case) may not return the updated value.

    Parameters
        var   The environment variable to be set, must not contain '=' character.
        value   New value of the variable.

    Returns
        true on success or false if changing the value failed.

    See Also
        wxUnsetEnv()

    Include file:

    #include <wx/utils.h>


    But I do not quite understand this description.
    « Last Edit: November 04, 2012, 11:57:20 am by ollydbg »
    If some piece of memory should be reused, turn them to variables (or const variables).
    If some piece of operations should be reused, turn them to functions.
    If they happened together, then turn them to classes.

    Offline MortenMacFly

    • Administrator
    • Lives here!
    • *****
    • Posts: 9508
    Re: The 02 November 2012 build (8500) is out.
    « Reply #11 on: November 04, 2012, 05:11:45 pm »
    This line is a bit strange:
    Code: [Select]
    char buffer[stl_putenv_var.length()+1];because this is not a valid c++, but probably uses some language extension of gcc.
    Maybe, morten can say something about this.
    Nope I can't other than it compiles and works just fine w/o specific extension (and why is it no C++, btw?!):
    http://www.cplusplus.com/reference/string/string/length/
    Its that same as char buffer[64]; or alike...
    Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
    C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
    C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

    Offline oBFusCATed

    • Developer
    • Lives here!
    • *****
    • Posts: 12123
      • Travis build status
    Re: The 02 November 2012 build (8500) is out.
    « Reply #12 on: November 04, 2012, 05:14:53 pm »
    Its that same as char buffer[64]; or alike...
    No it is not, it is the same as int a=5; char buffer[a];. Have you tried to compile it with -ansi?
    (most of the time I ignore long posts)
    [strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

    Offline p2rkw

    • Almost regular
    • **
    • Posts: 142
    Re: The 02 November 2012 build (8500) is out.
    « Reply #13 on: November 04, 2012, 05:24:02 pm »
    Variable Length Array - it's in C standard but not C++: http://gcc.gnu.org/onlinedocs/gcc/Variable-Length.html
    '64' is compile time constant, string::length is run time constant. 'const' qualifier only allow to call length() on const object.
    « Last Edit: November 04, 2012, 05:27:12 pm by p2rkw »

    Offline MortenMacFly

    • Administrator
    • Lives here!
    • *****
    • Posts: 9508
    Re: The 02 November 2012 build (8500) is out.
    « Reply #14 on: November 04, 2012, 05:31:07 pm »
    No it is not, it is the same as int a=5; char buffer[a];. Have you tried to compile it with -ansi?
    No, why should I?

    Variable Length Array - it's in C standard but not C++: http://gcc.gnu.org/onlinedocs/gcc/Variable-Length.html
    So - according this its OK. And yes, of course I know its a variable and not a constant. I thought oBFusCATed meant the length() method not being standard and I wanted to point put that it returns a const size_t.

    BTW: I think we are getting off-topic ...
    Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
    C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
    C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

    Offline oBFusCATed

    • Developer
    • Lives here!
    • *****
    • Posts: 12123
      • Travis build status
    Re: The 02 November 2012 build (8500) is out.
    « Reply #15 on: November 04, 2012, 06:26:35 pm »
    No, why should I?
    Because you're writing non-standard code which will break with another compiler, which doesn't support GCC extensions probably.
    (most of the time I ignore long posts)
    [strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

    Offline MortenMacFly

    • Administrator
    • Lives here!
    • *****
    • Posts: 9508
    Re: The 02 November 2012 build (8500) is out.
    « Reply #16 on: November 04, 2012, 06:29:48 pm »
    Because you're writing non-standard code which will break with another compiler, which doesn't support GCC extensions probably.
    OK - but I don't want to use another compiler and use several GCC extensions already because they are handy. But yes - its surely a portability issue.
    Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
    C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
    C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

    Offline carra

    • Multiple posting newcomer
    • *
    • Posts: 114
    Re: The 02 November 2012 build (8500) is out.
    « Reply #17 on: November 05, 2012, 03:14:33 pm »
    I can confirm that the fix for custom abbreviations is working correctly now: the empty extra lines are no longer inserted due to Windows line terminators "\r\n".

    However, this bug persists when the abbreviations are using scripts! I don't really know why, since I thought script execution should be unaffected by this.

    For instance, if you write this abbreviation under Windows (using the windows EOL):

    Code: [Select]
    [[ print("*line 1*\r\n*line 2*"); ]]
    CodeBlocks 8500 prints the following:

    Code: [Select]
    *line 1*

    *line 2*

    While 8248 and previous correctly printed

    Code: [Select]
    *line 1*
    *line 2*

    Should I now change my scripts to Linux EOL '\n'? (and hope it won't break EOL consistency in my files)

    EDIT: I have verified that the bug, however, does not happen if you execute that script line in the script console. So it has to do with abbreviations instead
    « Last Edit: November 05, 2012, 03:26:03 pm by carra »

    Offline Alpha

    • Developer
    • Lives here!
    • *****
    • Posts: 1513
    Re: The 02 November 2012 build (8500) is out.
    « Reply #18 on: November 06, 2012, 02:54:07 am »
    However, this bug persists when the abbreviations are using scripts! I don't really know why, since I thought script execution should be unaffected by this.
    That does not make sense... I will see if I can figure out why.

    Should I now change my scripts to Linux EOL '\n'? (and hope it won't break EOL consistency in my files)
    Yes, this is the recommended (by me ;)) method; code generation will match the editor's current EOL style just before insertion (if you would like to double check, set EditorTweaks to show EOL characters).

    Offline shurick

    • Multiple posting newcomer
    • *
    • Posts: 35
    Re: The 02 November 2012 build (8500) is out.
    « Reply #19 on: November 06, 2012, 04:31:11 am »
    Packages for openSUSE 12.1, openSUSE 12.2 (binaries and sources) for 32-bit and 64-bit.
    Packages for openSUSE http://codeblocks.esy.es  (binaries and sources) for 32-bit and 64-bit.

    Offline gd_on

    • Regular
    • ***
    • Posts: 494
    Re: The 02 November 2012 build (8500) is out.
    « Reply #20 on: November 07, 2012, 04:04:57 pm »
    I have a small problem when I build a recent svn version (8523) under windows : exchndl.dll does not seem to be build when I make a full All build (with CodeBlocks.workspace or more precisely CodeBlocks.cbp).
    It is built only if I select specifically as Build target ... "exchndl". Is it normal ?

    gd_on
    Windows 10, svn C::B (last version or almost!), WxWidgets 3.1.3, Compilers 8.1.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\MinGW64) or 32 bits (sjlj, posix in C:\MinGW32).

    Offline MortenMacFly

    • Administrator
    • Lives here!
    • *****
    • Posts: 9508
    Re: The 02 November 2012 build (8500) is out.
    « Reply #21 on: November 07, 2012, 04:25:51 pm »
    It is built only if I select specifically as Build target ... "exchndl". Is it normal ?
    Yes, it has been disabled for several reasons, one is it broke builds on some systems as people were unable to have the pre-requisites required for this target. To avoid noise we disabled it in "All". Hence you need this DLL for the crash report to work correctly. But its enough if you compile it one time explicitly once you have changed the compiler.
    Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
    C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
    C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

    Offline gd_on

    • Regular
    • ***
    • Posts: 494
    Re: The 02 November 2012 build (8500) is out.
    « Reply #22 on: November 07, 2012, 07:46:02 pm »
    Thanks for the reply

    gd_on
    Windows 10, svn C::B (last version or almost!), WxWidgets 3.1.3, Compilers 8.1.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\MinGW64) or 32 bits (sjlj, posix in C:\MinGW32).

    Offline killerbot

    • Administrator
    • Lives here!
    • *****
    • Posts: 5193
    Re: The 02 November 2012 build (8500) is out.
    « Reply #23 on: November 07, 2012, 10:46:12 pm »
    It is built only if I select specifically as Build target ... "exchndl". Is it normal ?
    Yes, it has been disabled for several reasons, one is it broke builds on some systems as people were unable to have the pre-requisites required for this target. To avoid noise we disabled it in "All". Hence you need this DLL for the crash report to work correctly. But its enough if you compile it one time explicitly once you have changed the compiler.

    which reminds me, I was going to provide a new version, and forgot  :-\

    Offline gd_on

    • Regular
    • ***
    • Posts: 494
    Re: The 02 November 2012 build (8500) is out.
    « Reply #24 on: November 08, 2012, 10:29:11 am »
    Thanks for patch in svn 8519 : I'm (we are !) now able to generate fortran code with modules with multi-thread. Before, it worked properly only in mono-thread because modules in fortran are a little bit specials : two files are generated, a classic .o file and a .mod file. This last one may be/is necessary at compile time in other routines/modules, so in multi-threading, you might need a .mod file before the end of it's own build. Now, with the new priority gestion, it's solved since svn 8519.
    Thanks again.

    gd_on
    « Last Edit: November 08, 2012, 03:00:34 pm by gd_on »
    Windows 10, svn C::B (last version or almost!), WxWidgets 3.1.3, Compilers 8.1.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\MinGW64) or 32 bits (sjlj, posix in C:\MinGW32).

    Offline ollydbg

    • Developer
    • Lives here!
    • *****
    • Posts: 5247
    • OpenCV and Robotics
      • Chinese OpenCV forum moderator
    Re: The 02 November 2012 build (8500) is out.
    « Reply #25 on: November 08, 2012, 02:55:25 pm »
    The bad thing is: if I rebuild C::B, I will sometimes see the warning message(see below)

    Does this mean that my "PATH" was locked by some one/software?

    I found a workaround, for those who have the same issue, you can give C::B a new and clean environment, like, start C::B in the console with the command:
    Code: [Select]
    @set PATH=E:\code\common_bin;C:\Program Files\SlikSvn\bin
    start codeblocks.exe

    Here, the PATH variable is set manually, and my c::b build and works fine.

    I guess that my PATH have too many strings, which cause the SetEnvironmentVariable function fail. :)
    « Last Edit: November 08, 2012, 03:02:29 pm by ollydbg »
    If some piece of memory should be reused, turn them to variables (or const variables).
    If some piece of operations should be reused, turn them to functions.
    If they happened together, then turn them to classes.

    Offline White-Tiger

    • Multiple posting newcomer
    • *
    • Posts: 83
    Re: The 02 November 2012 build (8500) is out.
    « Reply #26 on: November 10, 2012, 04:55:57 pm »
    well this isn't about this specific nightly... but rather revision 8536, it simply breaks the windows build^^
    It's not possible to define "unused" as this is often a variable name used with windows. eg. in "winnt.h" it is used for the "DECLARE_HANDLE" define. (MinGW64)
    Windoze 8.1 x86_64 16GiB RAM, wxWidgets-2.8x (latest,trunk), MinGW-builds (latest, posix-threads)
    Code::Blocks (x86 , latest , selection length patch , build option fixes/additions , toggle comments)

    Offline oBFusCATed

    • Developer
    • Lives here!
    • *****
    • Posts: 12123
      • Travis build status
    (most of the time I ignore long posts)
    [strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

    Offline gd_on

    • Regular
    • ***
    • Posts: 494
    Re: The 02 November 2012 build (8500) is out.
    « Reply #28 on: November 11, 2012, 05:26:31 pm »
    Something new in svn 8549 (or a bug ?), but, under Windows 7, an AppData has been created in my Program files (x86)\codeblocks folder and my previous default.conf is not found. Apparently, it's in this new folder that C::B parameters are stored. Is it normal ?
    After reverting to svn 8543, everything is OK again. Is it a bug ? a new behaviour ? But, in that last case, if Program files is write protected, a standard behaviour in Windows 7, I'm not sure it's a good idea : within the user's profile it's better.

    gd_on

    Edit : I have made a full rebuild and an install in a clean empty folder, and everything is OK with svn 8549. Strange. Sorry for the noise !
    « Last Edit: November 11, 2012, 06:18:32 pm by gd_on »
    Windows 10, svn C::B (last version or almost!), WxWidgets 3.1.3, Compilers 8.1.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\MinGW64) or 32 bits (sjlj, posix in C:\MinGW32).

    Offline AndyJ

    • Multiple posting newcomer
    • *
    • Posts: 15
    Re: The 02 November 2012 build (8500) is out.
    « Reply #29 on: November 14, 2012, 10:20:48 am »
    Thanks for all the great work recently!

    I noticed a few nightlies back that on my 2 monitor Win-XP system CodeBlocks no longer remembers that it was last run maximised on my 2nd monitor (this used to work). It did however remember that it was on the the 2nd monitor if not maximised. With the latest nightly, it now always seems to start on my primary monitor regardless of where it was when it was last closed - any ideas?

    Andy

    Edit: Oops, this really applies to the Nov 11th nightly (which now seems to have become something different...)
    « Last Edit: November 14, 2012, 10:22:39 am by AndyJ »

    Offline MortenMacFly

    • Administrator
    • Lives here!
    • *****
    • Posts: 9508
    Re: The 02 November 2012 build (8500) is out.
    « Reply #30 on: November 14, 2012, 11:08:47 am »
    With the latest nightly, it now always seems to start on my primary monitor regardless of where it was when it was last closed - any ideas?
    I know why, but the issue is that its not easily resolvable using wxWidgets as it missed important information on the about the display configuration. So either we implemented it ourselves for all platforms or wait until wxWidgets has the options to use.

    Why it was changes is that with the previous version it was possible, that Windows appeared outside of a (single display) screen when being launched on a dual-monitor system before. This is worse than the effect now. Thus I decided to change it. If you don't like it, revert r8535. I'll think about to make this behaviour an option - although this would be an ugly hack.
    Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
    C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
    C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

    Offline MortenMacFly

    • Administrator
    • Lives here!
    • *****
    • Posts: 9508
    Re: The 02 November 2012 build (8500) is out.
    « Reply #31 on: November 14, 2012, 11:16:21 am »
    Thus I decided to change it. If you don't like it, revert r8535. I'll think about to make this behaviour an option - although this would be an ugly hack.
    ...maybe I just found a better solution... gimme some time to test...
    Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
    C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
    C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

    Offline MortenMacFly

    • Administrator
    • Lives here!
    • *****
    • Posts: 9508
    Re: The 02 November 2012 build (8500) is out.
    « Reply #32 on: November 14, 2012, 01:38:19 pm »
    ...maybe I just found a better solution... gimme some time to test...
    The meanwhile committed fix should work for you (and others, of course). If you are willing to help, compile trunk and report back.
    Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
    C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
    C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

    Offline ambarj2009

    • Single posting newcomer
    • *
    • Posts: 6
    • ambar...j
    Re: The 02 November 2012 build (8500) is out.
    « Reply #33 on: November 27, 2012, 08:16:06 pm »
    I'm having problems with this version (8500), the machine is rebooted, or Code :: Blocks terminates with an error. It does quite often.

    After reviewing event viewer I saw that for this application the error:

    Faulting application: codeblocks.exe, version 0.0.0.0, faulting module msvcrt.dll, version 7.0.2600.5512, fault address 0x00037742.

    I have gcc 4.7.2 installed.

    I appreciate any help.
     :'(
    Let life take its course.

    Offline oBFusCATed

    • Developer
    • Lives here!
    • *****
    • Posts: 12123
      • Travis build status
    Re: The 02 November 2012 build (8500) is out.
    « Reply #34 on: November 27, 2012, 08:25:50 pm »
    I'm having problems with this version (8500), the machine is rebooted, or Code :: Blocks terminates with an error. It does quite often.
    Have you verified that you machine is stable without running codeblocks? Have you checked for hardware stability? Driver stability, etc?
    (most of the time I ignore long posts)
    [strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

    Offline ambarj2009

    • Single posting newcomer
    • *
    • Posts: 6
    • ambar...j
    Re: The 02 November 2012 build (8500) is out.
    « Reply #35 on: November 27, 2012, 08:43:12 pm »
    I'm having problems with this version (8500), the machine is rebooted, or Code :: Blocks terminates with an error. It does quite often.
    Have you verified that you machine is stable without running codeblocks? Have you checked for hardware stability? Driver stability, etc?

    Thanks for answering.  :D

    Yes, it is stable. Although I do not think this is the problem. Everything is new. This week and last.

    In these first two weeks switched to GCC version 4.7.2 and then change the version Code :: Blocks: From here the problems started.

    The symptom is:
    1) Start Code :: Blocks. All is well.
    2) I open the project I work. All is well.
    3) I continue with my work and in minutes the application falls Code :: Blocks, this in the best case.

    Now I tried to disable SpellChecker. I changed it to use a dictionary in Spanish. It seems that for now remains. I do not know if this is the problem, if solved, will put a message.

    The Spanish dictionary also recently installed it, but a little over a month and previous versions of Code :: Blocks seemed fine.
    Let life take its course.

    Offline ambarj2009

    • Single posting newcomer
    • *
    • Posts: 6
    • ambar...j
    Re: The 02 November 2012 build (8500) is out.
    « Reply #36 on: November 28, 2012, 08:56:20 pm »
    I'm having problems with this version (8500), the machine is rebooted, or Code :: Blocks terminates with an error. It does quite often.
    Have you verified that you machine is stable without running codeblocks? Have you checked for hardware stability? Driver stability, etc?

    Thanks for answering.  :D

    Yes, it is stable. Although I do not think this is the problem. Everything is new. This week and last.

    In these first two weeks switched to GCC version 4.7.2 and then change the version Code :: Blocks: From here the problems started.

    The symptom is:
    1) Start Code :: Blocks. All is well.
    2) I open the project I work. All is well.
    3) I continue with my work and in minutes the application falls Code :: Blocks, this in the best case.

    Now I tried to disable SpellChecker. I changed it to use a dictionary in Spanish. It seems that for now remains. I do not know if this is the problem, if solved, will put a message.

    The Spanish dictionary also recently installed it, but a little over a month and previous versions of Code :: Blocks seemed fine.

    Hello again.

    Well, I finally discovered that the problem was with the SpellChecker configuration. To disable it, no longer produce the problems indicated.

    Thank you.
    Until next time.  8)
    Let life take its course.