Author Topic: GUIDE - STL Pretty Print in Code::Blocks  (Read 9625 times)

Offline GravityWell

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: GUIDE - STL Pretty Print in Code::Blocks
« Reply #15 on: October 27, 2012, 12:55:56 am »
Guide is updated to include Linux. Let me know how it goes if you try it.

Offline GravityWell

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: GUIDE - STL Pretty Print in Code::Blocks
« Reply #16 on: October 27, 2012, 04:14:52 am »
Morten: Can you apply the same magic you've applied here: http://svn.berlios.de/wsvn/codeblocks/trunk/src/sdk/resources/select_target.xrc?op=diff&rev=7937&peg=7937&ignorews=1 ?
I just noticed something that may help in reproducing this. It seems if I start Codeblocks without a project, from the Linux start menu or desktop, then load a project, the problem with the "Debugger initialization commands" appears. If I launch Codeblocks with a project, such a double clicking a .cbp file, then the "Debugger initialization commands" text box is properly sized and works.

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
Re: GUIDE - STL Pretty Print in Code::Blocks
« Reply #17 on: October 27, 2012, 05:36:04 pm »
Morten: Can you apply the same magic you've applied here: http://svn.berlios.de/wsvn/codeblocks/trunk/src/sdk/resources/select_target.xrc?op=diff&rev=7937&peg=7937&ignorews=1 ?
Well actually this is a different issue here, but you can try the patch attached and tell me if that helps (I don't have Linux to test ATM)...

BTW: To me it seems more like a WX bug related to static sizers.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline GravityWell

  • Multiple posting newcomer
  • *
  • Posts: 18
Re: GUIDE - STL Pretty Print in Code::Blocks
« Reply #18 on: October 27, 2012, 09:05:09 pm »
Removing <option>1</option> didn't seem to make any difference. Removing the multiline style solved it, but then of course it is limited to one line. It could probably be much better debugged in a IDE in Linux, but my abilities and interest in Linux is limited. Barring any other developments, I think I'll update the Wiki page to recommend opening a project via CBP file if necessary, which seems to be a functioning work-around for some reason.