Author Topic: My Code::Blocks stopped working after SDL installation  (Read 3199 times)

armlesscat

  • Guest
My Code::Blocks stopped working after SDL installation
« on: July 25, 2012, 11:20:14 pm »
being interested in game programming, I decided to install SDL onto code::blocks. After installation, I tried to compile a console application program and received this error message:



-------------- Build: Debug in TextBasedGame ---------------

Linking console executable: bin\Debug\TextBasedGame.exe
mingw32-g++.exe: C:\Program Files\CodeBlocks\MinGW\lib\libmingw32.a: No such file or directory
mingw32-g++.exe: C:\Program Files\CodeBlocks\MinGW\lib\libSDL.dll.a: No such file or directory
mingw32-g++.exe: C:\Program Files\CodeBlocks\MinGW\lib\libSDLmain.a: No such file or directory
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings
 
i have since uninstalled and installed code::blocks, but this error still appears.
Please help me, as I think code:blocks is an excellent compiler and would like to continue using it in the future.

Offline jarod42

  • Multiple posting newcomer
  • *
  • Posts: 82
Re: My Code::Blocks stopped working after SDL installation
« Reply #1 on: July 26, 2012, 11:30:51 am »
Add libraries in linker settings.

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5229
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.