Author Topic: Horizontal scroll little bug  (Read 9698 times)

Offline murnesty

  • Single posting newcomer
  • *
  • Posts: 3
Horizontal scroll little bug
« on: July 24, 2012, 11:38:51 am »
Hi,

Logitech has the feature of horizontal scroll which you can scroll to left and right. (Though not all software support this feature)
When I use this feature on code::block, the scroll bar is moving but the text editor is still remain the same. Hope it will be fixed so my mice value will increase.

Thanks.

Best Regards,
Murnesty
Regards,
Murnesty

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Horizontal scroll little bug
« Reply #1 on: July 24, 2012, 01:58:00 pm »
Vertical and horizontal scrolling works fine here.

You did not post any information about your system, version of C::B, OS and whatever might be of interest.

Do you have "Settings -> Editor -> Scrollbar -> Automatically determin ..." enabled ?
Otherwise the scrollbars thumbsize is set to a default value, that does not always make sense.


Offline dmoore

  • Developer
  • Lives here!
  • *****
  • Posts: 1576
Re: Horizontal scroll little bug
« Reply #2 on: July 24, 2012, 03:08:36 pm »
works just fine on Ubuntu for me too.

Offline murnesty

  • Single posting newcomer
  • *
  • Posts: 3
Re: Horizontal scroll little bug
« Reply #3 on: July 25, 2012, 10:18:47 am »
Hi jens,

  Sorry for lack of information. I'm using :
- Windows7 64bit Home premium sp1.
- Code::block 10.05 32bit - wx2.8.10
- Logitech M325 mouse

I've just enabled the "Automatically determin..." but still not working. Only the scroll bar is moving but text editor doesn't move.

How can I check scrollbar thumbsize is set to default value?
Regards,
Murnesty

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Horizontal scroll little bug
« Reply #4 on: July 30, 2012, 08:15:52 am »
Please do not use personal messages to bump your thread or to continue it !!!
This is very bad style, unless there is really a need to talk to a dev personally.

But to answer your question, there is no change, since I can not reproduce it.

Did you try a nightly build, which uses wx 2.8.12 and has a much more recent version of scintilla ?

Offline murnesty

  • Single posting newcomer
  • *
  • Posts: 3
Re: Horizontal scroll little bug
« Reply #5 on: July 30, 2012, 09:50:46 am »
  Ok.
Regards,
Murnesty

Offline ouch

  • Almost regular
  • **
  • Posts: 221
Re: Horizontal scroll little bug
« Reply #6 on: August 15, 2012, 09:40:58 pm »
Tilt wheel does nothing for me in codeblocks v8234 either. Using an Engage mouse with default windows 7 64bit drivers. (Note: The tilt wheel does work in other apps and websites) The forward and back side buttons also don't do anything. (Though I'm not sure they are supposed to...)

I use "Ctrl + Left or Right Arrow key" mapped to the tilt wheel via AutoHotkey as a workaround. I also have the forward and back buttons navigate between bookmarks.
« Last Edit: August 15, 2012, 11:25:41 pm by ouch »