Author Topic: [Solved] Can't build on Mint  (Read 11161 times)

Offline zeroth

  • Multiple posting newcomer
  • *
  • Posts: 27
[Solved] Can't build on Mint
« on: July 21, 2012, 07:58:12 pm »
Code: [Select]
# export ACLOCAL_FLAGS="-I `wx-config --prefix`/share/aclocal"

# ./bootstrap
libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.in and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
configure.in:79: warning: macro `AM_OPTIONS_WXCONFIG' not found in library
configure.in:80: warning: macro `AM_PATH_WXCONFIG' not found in library
configure.in:79: error: possibly undefined macro: AM_OPTIONS_WXCONFIG
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.in:80: error: possibly undefined macro: AM_PATH_WXCONFIG

# svn info
Path: .
URL: svn://svn.berlios.de/codeblocks/trunk
Repository Root: svn://svn.berlios.de/codeblocks
Repository UUID: 98b59c6a-2706-0410-b7d6-d2fa1a1880c9
Revision: 8141
Node Kind: directory
Schedule: normal
Last Changed Author: mortenmacfly
Last Changed Rev: 8141
Last Changed Date: 2012-07-18 03:15:04 -0400 (Wed, 18 Jul 2012)

# locate wx-config
/etc/alternatives/wx-config
/usr/bin/wx-config
/var/lib/dpkg/alternatives/wx-config

# locate *.m4
/usr/lib/monodevelop/AddIns/MonoDevelop.Autotools/expansions.m4
/usr/lib/monodevelop/AddIns/MonoDevelop.Autotools/templates/expansions.m4
/usr/share/aclocal/aalib.m4
/usr/share/aclocal/alsa.m4
/usr/share/aclocal/argz.m4
/usr/share/aclocal/audiofile.m4
/usr/share/aclocal/codeset.m4
/usr/share/aclocal/esd.m4
/usr/share/aclocal/expat.m4
/usr/share/aclocal/fcntl-o.m4
/usr/share/aclocal/fontutil.m4
/usr/share/aclocal/freetype2.m4
/usr/share/aclocal/gettext.m4
/usr/share/aclocal/glib-2.0.m4
/usr/share/aclocal/glib-gettext.m4
/usr/share/aclocal/glibc2.m4
/usr/share/aclocal/glibc21.m4
/usr/share/aclocal/gsettings.m4
/usr/share/aclocal/gtk-2.0.m4
/usr/share/aclocal/iconv.m4
/usr/share/aclocal/intdiv0.m4
/usr/share/aclocal/intl.m4
/usr/share/aclocal/intldir.m4
/usr/share/aclocal/intlmacosx.m4
/usr/share/aclocal/intltool.m4
/usr/share/aclocal/intmax.m4
/usr/share/aclocal/inttypes-pri.m4
/usr/share/aclocal/inttypes_h.m4
/usr/share/aclocal/lcmessage.m4
/usr/share/aclocal/lib-ld.m4
/usr/share/aclocal/lib-link.m4
/usr/share/aclocal/lib-prefix.m4
/usr/share/aclocal/libFLAC.m4
/usr/share/aclocal/libmikmod.m4
/usr/share/aclocal/libtool.m4
/usr/share/aclocal/lock.m4
/usr/share/aclocal/longlong.m4
/usr/share/aclocal/ltdl.m4
/usr/share/aclocal/ltoptions.m4
/usr/share/aclocal/ltsugar.m4
/usr/share/aclocal/ltversion.m4
/usr/share/aclocal/lt~obsolete.m4
/usr/share/aclocal/mate-common.m4
/usr/share/aclocal/mate-compiler-flags.m4
/usr/share/aclocal/nls.m4
/usr/share/aclocal/ogg.m4
/usr/share/aclocal/pkg.m4
/usr/share/aclocal/po.m4
/usr/share/aclocal/printf-posix.m4
/usr/share/aclocal/progtest.m4
/usr/share/aclocal/sdl.m4
/usr/share/aclocal/size_max.m4
/usr/share/aclocal/smpeg.m4
/usr/share/aclocal/stdint_h.m4
/usr/share/aclocal/threadlib.m4
/usr/share/aclocal/uintmax_t.m4
/usr/share/aclocal/visibility.m4
/usr/share/aclocal/vorbis.m4
/usr/share/aclocal/wchar_t.m4
/usr/share/aclocal/wint_t.m4
/usr/share/aclocal/xsize.m4
/usr/share/aclocal/xtrans.m4
/usr/share/aclocal-1.11/amversion.m4
/usr/share/aclocal-1.11/as.m4
/usr/share/aclocal-1.11/auxdir.m4
/usr/share/aclocal-1.11/ccstdc.m4
/usr/share/aclocal-1.11/cond-if.m4
/usr/share/aclocal-1.11/cond.m4
/usr/share/aclocal-1.11/depend.m4
/usr/share/aclocal-1.11/depout.m4
/usr/share/aclocal-1.11/dmalloc.m4
/usr/share/aclocal-1.11/gcj.m4
/usr/share/aclocal-1.11/header.m4
/usr/share/aclocal-1.11/init.m4
/usr/share/aclocal-1.11/install-sh.m4
/usr/share/aclocal-1.11/lead-dot.m4
/usr/share/aclocal-1.11/lex.m4
/usr/share/aclocal-1.11/lispdir.m4
/usr/share/aclocal-1.11/maintainer.m4
/usr/share/aclocal-1.11/make.m4
/usr/share/aclocal-1.11/minuso.m4
/usr/share/aclocal-1.11/missing.m4
/usr/share/aclocal-1.11/mkdirp.m4
/usr/share/aclocal-1.11/multi.m4
/usr/share/aclocal-1.11/obsol-gt.m4
/usr/share/aclocal-1.11/obsol-lt.m4
/usr/share/aclocal-1.11/obsolete.m4
/usr/share/aclocal-1.11/options.m4
/usr/share/aclocal-1.11/protos.m4
/usr/share/aclocal-1.11/python.m4
/usr/share/aclocal-1.11/regex.m4
/usr/share/aclocal-1.11/runlog.m4
/usr/share/aclocal-1.11/sanity.m4
/usr/share/aclocal-1.11/silent.m4
/usr/share/aclocal-1.11/strip.m4
/usr/share/aclocal-1.11/substnot.m4
/usr/share/aclocal-1.11/tar.m4
/usr/share/aclocal-1.11/upc.m4
/usr/share/aclocal-1.11/vala.m4
/usr/share/autoconf/autoconf/autoconf.m4
/usr/share/autoconf/autoconf/autoheader.m4
/usr/share/autoconf/autoconf/autoscan.m4
/usr/share/autoconf/autoconf/autotest.m4
/usr/share/autoconf/autoconf/autoupdate.m4
/usr/share/autoconf/autoconf/c.m4
/usr/share/autoconf/autoconf/erlang.m4
/usr/share/autoconf/autoconf/fortran.m4
/usr/share/autoconf/autoconf/functions.m4
/usr/share/autoconf/autoconf/general.m4
/usr/share/autoconf/autoconf/headers.m4
/usr/share/autoconf/autoconf/lang.m4
/usr/share/autoconf/autoconf/libs.m4
/usr/share/autoconf/autoconf/oldnames.m4
/usr/share/autoconf/autoconf/programs.m4
/usr/share/autoconf/autoconf/specific.m4
/usr/share/autoconf/autoconf/status.m4
/usr/share/autoconf/autoconf/types.m4
/usr/share/autoconf/autotest/autotest.m4
/usr/share/autoconf/autotest/general.m4
/usr/share/autoconf/autotest/specific.m4
/usr/share/autoconf/m4sugar/foreach.m4
/usr/share/autoconf/m4sugar/m4sh.m4
/usr/share/autoconf/m4sugar/m4sugar.m4
/usr/share/autoconf/m4sugar/version.m4
/usr/share/doc/m4/examples/capitalize.m4
/usr/share/doc/m4/examples/capitalize2.m4
/usr/share/doc/m4/examples/comments.m4
/usr/share/doc/m4/examples/curry.m4
/usr/share/doc/m4/examples/ddivert.m4
/usr/share/doc/m4/examples/debug.m4
/usr/share/doc/m4/examples/esyscmd.m4
/usr/share/doc/m4/examples/exp.m4
/usr/share/doc/m4/examples/file.m4
/usr/share/doc/m4/examples/foreach.m4
/usr/share/doc/m4/examples/foreach2.m4
/usr/share/doc/m4/examples/foreachq.m4
/usr/share/doc/m4/examples/foreachq2.m4
/usr/share/doc/m4/examples/foreachq3.m4
/usr/share/doc/m4/examples/foreachq4.m4
/usr/share/doc/m4/examples/forloop.m4
/usr/share/doc/m4/examples/forloop2.m4
/usr/share/doc/m4/examples/forloop3.m4
/usr/share/doc/m4/examples/fstab.m4
/usr/share/doc/m4/examples/hanoi.m4
/usr/share/doc/m4/examples/incl-test.m4
/usr/share/doc/m4/examples/incl.m4
/usr/share/doc/m4/examples/include.m4
/usr/share/doc/m4/examples/indir.m4
/usr/share/doc/m4/examples/join.m4
/usr/share/doc/m4/examples/loop.m4
/usr/share/doc/m4/examples/misc.m4
/usr/share/doc/m4/examples/multiquotes.m4
/usr/share/doc/m4/examples/patsubst.m4
/usr/share/doc/m4/examples/pushpop.m4
/usr/share/doc/m4/examples/quote.m4
/usr/share/doc/m4/examples/regexp.m4
/usr/share/doc/m4/examples/reverse.m4
/usr/share/doc/m4/examples/stack.m4
/usr/share/doc/m4/examples/stack_sep.m4
/usr/share/doc/m4/examples/sync-lines.m4
/usr/share/doc/m4/examples/sysv-args.m4
/usr/share/doc/m4/examples/trace.m4
/usr/share/doc/m4/examples/translit.m4
/usr/share/doc/m4/examples/undivert.m4
/usr/share/doc/m4/examples/wrap.m4
/usr/share/doc/m4/examples/wrapfifo.m4
/usr/share/doc/m4/examples/wraplifo.m4
/usr/share/doc/m4/examples/wraplifo2.m4
/usr/share/libtool/libltdl/aclocal.m4
/usr/src/codeblocks/acinclude.m4
/usr/src/codeblocks/aclocal.m4
/usr/src/codeblocks/revision.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/aclocal.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/codeset.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/gettext.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/glibc2.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/glibc21.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/iconv.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/intdiv0.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/intl.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/intldir.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/intlmacosx.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/intmax.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/inttypes-pri.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/inttypes_h.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/isc-posix.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/lcmessage.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/lib-ld.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/lib-link.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/lib-prefix.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/libtool.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/lock.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/longlong.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/ltoptions.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/ltsugar.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/ltversion.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/lt~obsolete.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/nls.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/po.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/printf-posix.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/progtest.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/size_max.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/stdint_h.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/uintmax_t.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/visibility.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/wchar_t.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/wint_t.m4
/usr/src/codeblocks/src/plugins/contrib/SpellChecker/hunspell/m4/xsize.m4
/usr/src/codeblocks/src/plugins/contrib/wxContribItems/wxthings/build/aclocal.m4
/usr/src/codeblocks/src/plugins/contrib/wxContribItems/wxthings/build/autoconf_inc.m4
/usr/src/codeblocks/src/sdk/wxpropgrid/build/autoconf_inc.m4
« Last Edit: July 25, 2012, 07:35:52 pm by zeroth »

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Can't build on Mint
« Reply #1 on: July 21, 2012, 08:05:55 pm »
Do you have the wxwidgets development files installed ?

wx-config is in the wx-common package on debian based systems and might be there without the dev-packages, if I remember correctly.

Offline zeroth

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: Can't build on Mint
« Reply #2 on: July 21, 2012, 11:51:58 pm »
Do you have the wxwidgets development files installed ?

wx-config is in the wx-common package on debian based systems and might be there without the dev-packages, if I remember correctly.

yep. I read that in several places while googling, the dev packages are installed.

I meant to post a list of wx packages up there, but forgot to include it. I'll post again when I'm at the machine to assure you that they are installed, but that won't be until tuesday.

Offline zeroth

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: Can't build on Mint
« Reply #3 on: July 24, 2012, 06:25:29 pm »
result of `dpkg -l | grep -i wx`
Code: [Select]
ii  libwxbase2.8-0                                              2.8.11.0-0ubuntu10                      wxBase library (runtime) - non-GUI support classes of wxWidgets toolkit
ii  libwxbase2.8-dev                                            2.8.11.0-0ubuntu10                      wxBase library (development) - non-GUI support classes of wxWidgets toolkit
ii  libwxgtk2.8-0                                               2.8.11.0-0ubuntu10                      wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)
ii  libwxgtk2.8-dev                                             2.8.11.0-0ubuntu10                      wxWidgets Cross-platform C++ GUI toolkit (GTK+ development)
ii  libwxsmithlib0                                              10.05-2                                 wxSmith shared library (Code::Blocks plugin for RAD GUI editing)
ii  wx2.8-headers                                               2.8.11.0-0ubuntu10                      wxWidgets Cross-platform C++ GUI toolkit (header files)

stefanos_

  • Guest
Re: Can't build on Mint
« Reply #4 on: July 25, 2012, 12:21:52 pm »
You may visit my page, specifically this link http://needlecraft.sourceforge.net/dokuwiki/codeblocks-svn-mint

where I explain quite thoroughly all the steps how to install Code::Blocks under Mint (which basically covers every Debian-based distro).

Cheers.

Offline zeroth

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: Can't build on Mint
« Reply #5 on: July 25, 2012, 07:35:36 pm »
You may visit my page, specifically this link http://needlecraft.sourceforge.net/dokuwiki/codeblocks-svn-mint

where I explain quite thoroughly all the steps how to install Code::Blocks under Mint (which basically covers every Debian-based distro).

Cheers.
worked like a charm, thanks!

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9488
Re: Can't build on Mint
« Reply #6 on: July 25, 2012, 09:17:55 pm »
You may visit my page, specifically this link http://needlecraft.sourceforge.net/dokuwiki/codeblocks-svn-mint

where I explain quite thoroughly all the steps how to install Code::Blocks under Mint (which basically covers every Debian-based distro).
Mind potting this in the WiKi under the appropriate section, too, please?
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Can't build on Mint
« Reply #7 on: July 25, 2012, 09:38:17 pm »
You may visit my page, specifically this link http://needlecraft.sourceforge.net/dokuwiki/codeblocks-svn-mint

where I explain quite thoroughly all the steps how to install Code::Blocks under Mint (which basically covers every Debian-based distro).
Mind potting this in the WiKi under the appropriate section, too, please?
I don't have mint on my system (at the moment), but for debian systems, no tweaking is needed, it compiles out of the box, if all needed packages are installed.

stefanos_

  • Guest
Re: [Solved] Can't build on Mint
« Reply #8 on: July 26, 2012, 04:48:34 pm »
jens I don't know about wheey, but the previous version I had to do all this procedure. I will try the same procedure under VirtualBox by installing a clean Debian system to see if it works out of the box as you said. If the issue remains the same and works with my way, then i guess we could add it in Wiki pages.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: [Solved] Can't build on Mint
« Reply #9 on: July 26, 2012, 05:50:22 pm »
I build C::B on lenny, squeeze, wheezy and sid/experimental.
You can believe me or not, but on all systems it worked without tweaking.

The only thing is, that probably a more recent wxwidgets is needed, if not at lease 2.8.10 is available, but this can be downloaded/installed from apt.wxwidgets.org .

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: [Solved] Can't build on Mint
« Reply #10 on: July 26, 2012, 06:16:17 pm »
I will install an actual mint-release and test it there also.

Offline zeroth

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: [Solved] Can't build on Mint
« Reply #11 on: July 26, 2012, 06:44:39 pm »
additional information about my system which may be helpful.
Code: [Select]
# uname -a
Linux brandon-700GR 3.0.0-22-generic #36-Ubuntu SMP Tue Jun 12 17:13:04 UTC 2012 i686 i686 i386 GNU/Linux

# cat /etc/issue
Linux Mint 12 Lisa \n \l

# g++ -v
Using built-in specs.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=/usr/lib/gcc/i686-linux-gnu/4.6.1/lto-wrapper
Target: i686-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.6.1-9ubuntu3' --with-bugurl=file:///usr/share/doc/gcc-4.6/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++,go --prefix=/usr --program-suffix=-4.6 --enable-shared --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.6 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-plugin --enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i686 --with-tune=generic --enable-checking=release --build=i686-linux-gnu --host=i686-linux-gnu --target=i686-linux-gnu
Thread model: posix
gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)

# wx-config --version
2.8.11

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: [Solved] Can't build on Mint
« Reply #12 on: July 26, 2012, 09:12:21 pm »
I just installed Mint 1e3 with cinnamon desktop.

To be able to build C::B-core I neded libwxgtk2.8-dev, wx-common, build-essential, subversion, libtool, autoconf, libgtk2.0-dev and their respective dependencies.

Subversion is only needed to fetch the actual trunk from C::B's repo.

After checking out the sources, I called ./bootstrap, this gave me some warnings, that can safely be ignored.

I created a build-folder (build-trunk), so I do not litter the clean source tree with object- and makefiles.

I changed to the build-folder and called ../configure --prefix=/home/jens/codeblocks-tmp, so I do not need to run make install with root-privilges and can not conflict with system software (easier to remove, just wipe out the install-folders content).

Then make && make install.
And I am able to run C::B without contrib-plugins with a call to ~/codeblocks-tmp/bin/codeblocks .

No need to tweak anything in the sources, no need to deal with ldconfig.


For contrib-plugins additional dev-packages might be needed:

spellchecker -> libhunspell-dev
filemanager -> libgamin-dev
NassiShneiderman -> libboost-dev

If you don't want this, just run ../configure --help, to see how to include and exclude the contrib-plugins.

Edit:
corrected the build-essential package name (removed trailing "s")

Edit2:
On (some?) systems, at least on Mint 12, you need to explicitely install the wx-common packahge to fetch the needed automake-macros.
I would say, that this is a packaging error, because a -common package should always be installed with the packages it is created for.

stefanos_

  • Guest
Re: [Solved] Can't build on Mint
« Reply #13 on: July 27, 2012, 07:47:43 am »
Thank you for testing it. My procedure is to cover plugins too, so I don't know if plugins is the reason that's causing all this fuss; what really matters is to be able to use it to do your job.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: [Solved] Can't build on Mint
« Reply #14 on: July 27, 2012, 11:24:18 am »
If the appropriate dev-packages are installed,it works for plugins also, without any changes to C::B's codebase, makefiles or whatever, just out of the box.

And it works on all my linux boxes with Fedora, CentOS, Mint, Debian and Ubuntu.
I also tested it on OpenSUSE, but this was one or two years ago, but I don't think it has changed.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: [Solved] Can't build on Mint
« Reply #15 on: July 27, 2012, 02:29:17 pm »
[...]what really matters is to be able to use it to do your job.

But you should be aware, that tweaking the sources, if not really needed, might lead to conflicts with later updates.
And if it is really necessary to manually edit the sources and/or configuration-files should be reported upstream, so a possible bug can be fixed.

stefanos_

  • Guest
Re: [Solved] Can't build on Mint
« Reply #16 on: July 27, 2012, 08:02:39 pm »
ok, i guess i should double check it on a clean system and let you know that is bug for sure, and i will report it if it is.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: [Solved] Can't build on Mint
« Reply #17 on: July 27, 2012, 08:28:13 pm »
It's definitely not a bug, at least not a C::B one.

I just build it on Mint 12 (as the originalposter) and there are no issues.

It looks like ha hasn't wx-common installed, the package which includes the automake-macros for wx on Mint 12.
As this is an essential development tool for all automake-based wxwidgtes software, it should be a dependency of the wxwidgets dev-packages (as it is on Mint 13 and Debian).

So I think it's a gain an Ubuntu (this time packaging-) issue, which makes problems. Mint 12 and Mint 13 extensively uses Ubuntu-repos.