Author Topic: wxString debbuging  (Read 1731 times)

Offline spamy

  • Single posting newcomer
  • *
  • Posts: 4
wxString debbuging
« on: February 11, 2012, 04:24:28 pm »
Hi,

I'm using CB under linux and i try to use it under Win7.
But under Win7, the behavior is not the same, i can't evaluate wxString.

The Win7 "Watches" Window shows :
Code: [Select]
Local Variables
    +str
    +static npos=xxxxx
    +m_impl
         +static npos=xxxx
          + _M_dataplus
                  + std allocator
                   . members od std::basic_string
                   . _M_p=0x"an address"
    +m_convertedToChar
 


Under Linux, i'm able to see the wxString content in _M_dataplus->m_impl->_M_p,
but under with Win7,_M_dataplus->m_impl->_M_p just gives a long ( address ?) without any char and
the evaluation under cursor gives: No symbol "wxStringData" in current context.

For both, the gdb_types.script are the same, and seems to be OK.
My settings are:
CB Versions are SVN 7548 for linux and 10.25 for Win7
For Win7, wxWidget is compiled with MONOLITHIC=1 SHARED=1 UNICODE=1 flags

Both using gcc/gdb and wxWidgets-2.9.3.

Could somebody help me to fix this issue ?

Thanks for your help.
« Last Edit: February 11, 2012, 04:33:02 pm by spamy »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12069
    • Travis build status
Re: wxString debbuging
« Reply #1 on: February 11, 2012, 06:37:02 pm »
gdb_types.script doesn't support the wxString in wx2.9.
Use the python pretty printers for wx2.9.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline spamy

  • Single posting newcomer
  • *
  • Posts: 4
[SOLVED]Re: wxString debbuging
« Reply #2 on: February 12, 2012, 06:59:49 am »
thanks,
it seems to work fine.