Author Topic: C::B slows down entirely after building the project a couple of times  (Read 1871 times)

Offline void

  • Single posting newcomer
  • *
  • Posts: 7
Hello,

I tried to find a solution on this in the bug tracker, but I haven't found any report. However, here's my situation:

I'm running C::B for years now on several system configurations, basically all Windows and Linux. What I've experienced so far is, that using Windows everything works fine in conjunction with MinGW. Using Linux on the other hand, I always end up with the same problem, that is a constantly evolving slowdown after using C::B a couple of hours or project rebuilds. In my case it isn't just a minor speed issue, I'm talking about the whole IDE hanging tremendously being almost completely unresponsive to any user interaction. The only thing helping me out is a shutdown and restart of C::B.

I also noticed that during startup C::B is invoking wine for some reason. Is this a normal behaviour? I did not notice that in earlier builds (around <= 2010 and I mean the year, not the be build number ;-). I'm assuming there may be any coherence, but I'm groping in the dark here. Also I'm almost sure the slowdowns only appear when using the code completition plugin, which unfortunately is mandatory for my workflow.

Anyone ever experienced the same problems? I'd like to expel my system being responsible to this, because I've tested on different hardware using different setups (all of them running Kubuntu 11.x by the way).

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: C::B slows down entirely after building the project a couple of times
« Reply #1 on: January 20, 2012, 09:01:18 pm »
I also noticed that during startup C::B is invoking wine for some reason. Is this a normal behaviour?

No. A normal installation of C::B does not start wine.
You can try to start C::B with a clean configuration, either by removing (or better renaming the file default.conf in  ~/.codeblocks) or by using a different personality (start C::B from a virtual terminal with the parameter -p [any_personality_but_default].
If it still starts wine, there must be something wrong with your build of C::B or your system, if it does not, your configuration is broken.

I also do not get the slowdown or unresponsiveness with my version of C::B (from my repo).

By the way, where do you get your C::B from and which version do you use ?

Offline void

  • Single posting newcomer
  • *
  • Posts: 7
Re: C::B slows down entirely after building the project a couple of times
« Reply #2 on: January 31, 2012, 01:45:39 pm »
Jens, thank you very much for your help. I've removed the file from my C::B directory and the wine thing easily disappeared. But the slowdown issues are still present. By the way, I'm using your repo as well, currently being on build 7620.