Author Topic: Program glut does not run  (Read 4183 times)

Offline AlexandreRDSST

  • Single posting newcomer
  • *
  • Posts: 2
Program glut does not run
« on: December 29, 2011, 03:44:05 pm »
basis of the program glut does not run

NOTE: I installed on 2 PCs in the same way and it worked, but not on my pc

of the following message

Code: [Select]
||=== teste, Debug ===|
C:\Program Files\CodeBlocks\MinGW\include\GL\glut.h|50|error: redeclaration of C++ built-in type `short'|
C:\Program Files\CodeBlocks\MinGW\include\GL\glut.h|58|warning: ignoring #pragma comment |
C:\Program Files\CodeBlocks\MinGW\include\GL\glut.h|66|warning: ignoring #pragma comment |
C:\Program Files\CodeBlocks\MinGW\include\GL\glut.h|67|warning: ignoring #pragma comment |
C:\Program Files\CodeBlocks\MinGW\include\GL\glut.h|68|warning: ignoring #pragma comment |
C:\Program Files\CodeBlocks\MinGW\include\GL\glut.h|76|warning: ignoring #pragma warning |
C:\Program Files\CodeBlocks\MinGW\include\GL\glut.h|77|warning: ignoring #pragma warning |
C:\Program Files\CodeBlocks\MinGW\include\GL\glut.h|549|warning: 'int glutCreateMenu_ATEXIT_HACK(void (*)(int))' defined but not used|
||=== Build finished: 1 errors, 7 warnings ===|

My system
OS: Windows 7 ultimate 32Bits

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9488
Re: Program glut does not run
« Reply #1 on: December 29, 2011, 04:46:27 pm »
NOTE: I installed on 2 PCs in the same way and it worked, but not on my pc
You'd better ask in an appropriate forum, like a C++ / GLUT related forum. This forum is related to the IDE "Code::Blocks" and I guess only few people here use GLUT.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ