Author Topic: Project manager looks weird  (Read 6735 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5243
Project manager looks weird
« on: December 07, 2005, 01:42:12 pm »
Since a few days, I have with latest head builds some strange issues, the project manager, looks weird.
See attachment.



Lieven


[attachment deleted by admin]

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: Project manager looks weird
« Reply #1 on: December 07, 2005, 03:31:22 pm »
I've seen that too, but it only happens for me when two or more instances of Code::Blocks are running, and only on the first run of a fresh build.... no idea what that is.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Project manager looks weird
« Reply #2 on: December 07, 2005, 06:16:24 pm »
That's a problem with the splitter. It has happened to me before. Be sure to initialize the splitter position and the appropriate controls' width and height.

(But I forgot exactly what lines i fixed that time... ugh :( )

fane

  • Guest
Re: Project manager looks weird
« Reply #3 on: December 07, 2005, 07:04:00 pm »
This also happened to me with CB revision 1447. In revision 1450 this does not happen (at least to me) but syntax highlighting does not work properly.Take a look at the attachement (and there are more "errors", not only for includes)


[attachment deleted by admin]

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Project manager looks weird
« Reply #4 on: December 07, 2005, 07:53:22 pm »
In revision 1450 this does not happen (at least to me) but syntax highlighting does not work properly.Take a look at the attachement

Uh oh... :(

fane

  • Guest
Re: Project manager looks weird
« Reply #5 on: December 08, 2005, 11:29:45 am »
Thank you for the hint.
I have procedeed as in the link provided by rickg22 http://forums.codeblocks.org/index.php?topic=1472.0 -- I have deleted default.conf, then I have installed CB built by revision 1470. The syntax highlighting problems dissapeared but the problems with the project manager pointed by killerbot are present now. Waiting for RC3...

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: Project manager looks weird
« Reply #6 on: December 08, 2005, 11:52:57 am »
I updated to latest and now I'm getting all the errors descripted in the forum (toolbar, file associations, this, ...) :D

Notice the icons overlaping =P

[attachment deleted by admin]

Offline David Perfors

  • Developer
  • Lives here!
  • *****
  • Posts: 560
Re: Project manager looks weird
« Reply #7 on: December 08, 2005, 02:38:57 pm »
I had that problem to, but what helped for me was:
disable Open Files list
enable it again.

(hmm. when I start C::B again it looks strange again... :S)
OS: winXP
Compiler: mingw
IDE: Code::Blocks SVN WX: 2.8.4 Wish list: faster code completion, easier debugging, refactoring

Offline David Perfors

  • Developer
  • Lives here!
  • *****
  • Posts: 560
Re: Project manager looks weird
« Reply #8 on: December 09, 2005, 02:21:37 pm »
It looks like it is fixed in the latest SVN...
OS: winXP
Compiler: mingw
IDE: Code::Blocks SVN WX: 2.8.4 Wish list: faster code completion, easier debugging, refactoring

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5243
Re: Project manager looks weird
« Reply #9 on: December 17, 2005, 07:13:57 pm »
I think it not yet fixed. Suffering from that problem again today (today's head). Sometimes when CB starts, the latest project is reloaded, but no project tree visible, just the opened files (which is empty in my case). Then for example I drag the CB screen so that the project pane is out of the screen, drag it back and I get immed. as in the screenshot at the top of this topic. I think there's a conflict between the "opened files" part and the workspace/project tree.

Offline grv575

  • Official tester
  • Regular
  • ***
  • Posts: 381
Re: Project manager looks weird
« Reply #10 on: December 17, 2005, 08:20:13 pm »
Well it happens when there is no default.conf file yet.  As soon as this file is created (open cb, close cb), then the problem goes away.  Maybe something in the load-from-xml-config file handling -- a case where the height/width isn't found in the config and it doesn't handle this case properly by using the default (althougth the default eventually gets used when the config file is written).

Offline David Perfors

  • Developer
  • Lives here!
  • *****
  • Posts: 560
Re: Project manager looks weird
« Reply #11 on: December 17, 2005, 10:46:36 pm »
Not exactly true, when I open a excist project and C::B is not yet loaded, the manager looks weird again :?
OS: winXP
Compiler: mingw
IDE: Code::Blocks SVN WX: 2.8.4 Wish list: faster code completion, easier debugging, refactoring

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5243
Re: Project manager looks weird
« Reply #12 on: December 18, 2005, 10:02:36 am »
same here, I think my default.conf does exist.
Unless some ghosts are randomly taking it away.  :)