Author Topic: Boost assertions closes the debugger  (Read 14114 times)

zabzonk

  • Guest
Re: Boost assertions closes the debugger
« Reply #15 on: November 01, 2011, 08:07:28 pm »
Actually, cancel that. I do get a break in the debugger, but the cursor is not accurately positioned after the assert - it seems like in the previous code it got located there by chance.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11629
    • Travis build status
Re: Boost assertions closes the debugger
« Reply #16 on: November 01, 2011, 08:13:51 pm »
ThundThund: Have you tried the debugger's branch nightly? Also have you read this http://wiki.codeblocks.org/index.php?title=Debugging_with_Code::Blocks ?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline ThundThund

  • Multiple posting newcomer
  • *
  • Posts: 21
Re: Boost assertions closes the debugger
« Reply #17 on: November 01, 2011, 08:18:47 pm »
I've not tried that branch. I'm going to read that just in case I forgot something.

Offline ThundThund

  • Multiple posting newcomer
  • *
  • Posts: 21
Re: Boost assertions closes the debugger
« Reply #18 on: November 01, 2011, 08:25:26 pm »
I achieve all the requirements of the article.

zabzonk

  • Guest
Re: Boost assertions closes the debugger
« Reply #19 on: November 01, 2011, 08:27:50 pm »
@oBFusCATed

Did you try the small code sample I posted? Does it work for you? For me it doesn't even stop after the assert using command-line gdb; does it for you?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11629
    • Travis build status
Re: Boost assertions closes the debugger
« Reply #20 on: November 01, 2011, 08:29:25 pm »
Code: [Select]
int main() {
 BOOST_ASSERT(false);
 ...
}
Works flawlessly.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

zabzonk

  • Guest
Re: Boost assertions closes the debugger
« Reply #21 on: November 01, 2011, 08:30:42 pm »
Yes, but does the code I posted work flawlessly?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11629
    • Travis build status
Re: Boost assertions closes the debugger
« Reply #22 on: November 01, 2011, 09:01:13 pm »
Yes, the same as with my code...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

zabzonk

  • Guest
Re: Boost assertions closes the debugger
« Reply #23 on: November 01, 2011, 09:10:16 pm »
Could you post a screenshot? I suspect that what you class as working and what I and the OP class as working may be different.

Offline ThundThund

  • Multiple posting newcomer
  • *
  • Posts: 21
Re: Boost assertions closes the debugger
« Reply #24 on: November 01, 2011, 09:33:06 pm »
What exactly do you need I show in the screenshot?

zabzonk

  • Guest
Re: Boost assertions closes the debugger
« Reply #25 on: November 01, 2011, 09:35:47 pm »
Sorry I meant:

@oBFusCATed

Could you post a screenshot? I suspect that what you class as working and what I and the OP class as working may be different.


You (i.e. ThundThund) are the OP == Original Poster
« Last Edit: November 01, 2011, 09:39:26 pm by Neil Butterworth »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11629
    • Travis build status
Re: Boost assertions closes the debugger
« Reply #26 on: November 01, 2011, 10:46:19 pm »
Hm, why do you need a screen shot? It is the same as if the debugger is stopped on a breakpoint...

And keep in mind that I'm on linux and I'm running the latest debugger branch code. I don't know what is the behaviour of the 10.05 or trunk.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

zabzonk

  • Guest
Re: Boost assertions closes the debugger
« Reply #27 on: November 01, 2011, 11:14:29 pm »
@oBFusCATed

I'd like to see  screenshot so that I can see what you think the correct appearance of the system should be after the boost assert fails. For me it does seem to break in the debugger, but I don't know how you or the OP think this break should correctly be displayed.  My understanding of WX/scintilla is that the appearance should be more or less platform independent, so a screenshot from a working CB implementation should resolve this. And it will take you, what? - two minutes to do?

To be explicit, I'd like to see the debugger call stack window and the editor window.

Offline ThundThund

  • Multiple posting newcomer
  • *
  • Posts: 21
Re: Boost assertions closes the debugger
« Reply #28 on: November 01, 2011, 11:28:40 pm »
I agree, it takes a few seconds to do and could clarify some things  :D.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11629
    • Travis build status
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]