Author Topic: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.  (Read 46294 times)

Offline imianz

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #15 on: October 05, 2011, 11:10:25 am »
I'm sorry, it's a my mistake, I move it to the right section (I hope!)

Offline renega_666

  • Multiple posting newcomer
  • *
  • Posts: 36
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #16 on: October 05, 2011, 01:23:23 pm »
Hi!

I have an issue with breakpoints and the call stack window in the debugger branch (rev 7452) on Windows XP and Windows 7.

1)Whenever I remove a break point while my program is running, this break point is always hit. It disappears if I stop debugging and restart again.

2) The call stack is always empty when my program hit a break point. I have to close the call stack window and re-open it to view its content.

I'm only using the debugger branch so I don't know if those bugs are only related to this branch.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12125
    • Travis build status
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #17 on: October 05, 2011, 01:34:59 pm »
Can I ask you to enable the full debugger's log (Settings -> Debugger -> Debugger's debug log) and then paste it here (using code tags)?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline renega_666

  • Multiple posting newcomer
  • *
  • Posts: 36
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #18 on: October 05, 2011, 01:50:00 pm »
Of course, here it is:
Code: [Select]
PATH=.;D:\Projects\TestGameEngine\libs\SirmoGameEngine\trunk\bin\Debug;D:\Projects\TestGameEngine\libs\SirmoGameEngine\trunk\bin\Release;D:\Projects\TestGameEngine\libs\SirmoGameEngine\libs\Sirmo3DEngine\trunk\bin\Debug;D:\Projects\TestGameEngine\libs\SirmoGameEngine\libs\Sirmo3DEngine\trunk\bin\Release;D:\Projects\TestGameEngine\libs\SirmoGameEngine\libs\SirmoSoundEngine\trunk\bin\Debug;D:\Projects\TestGameEngine\libs\SirmoGameEngine\libs\SirmoSoundEngine\trunk\bin\Release;D:\Projects\TestGameEngine\libs\SirmoGameEngine\libs\libsig\lib;D:\Projects\TestGameEngine\libs\SirmoGameEngine\libs\sfml\lib;C:\MinGW32\bin;C:\Program Files\NVIDIA Corporation\PhysX\Common;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\doxygen\bin;C:\Program Files\Fichiers communs\Autodesk Shared\;C:\WINDOWS\system32\WindowsPowerShell\v1.0;C:\DoxyGen1_6\bin;C:\Program Files\Fichiers communs\Adobe\AGL;C:\Program Files\Graphic Remedy\gDEBugger\;C:\Program Files\Autodesk\Backburner\;C:\Program Files\Visual Leak Detector\bin;C:\Program Files\NVIDIA Corporation\Cg\bin;C:\Program Files\Lua\5.1;C:\Program Files\Lua\5.1\clibs;C:\Program Files\AMD\CodeAnalyst\bin;C:\Program Files\TortoiseSVN\bin;C:\Program Files\Cppcheck\;C:\Program Files\Graphviz 2.28\bin;C:\Program Files\Internet Explorer;C:\Program Files\NVIDIA Corporation\Cg\bin;C:\Program Files\IDM Computer Solutions\UltraCompare\;C:\Program Files\COLLADA\COLLADA_Refinery\bin;C:\Program Files\Java\jre6\bin
Command-line: C:\MinGW32\bin\gdb.exe -nx -fullname  -quiet -args D:/Projects/TestGameEngine/trunk/bin/Debug/TestGameEngine_d.exe
Working dir : D:\WorkingDirectory
> set prompt >>>>>>cb_gdb:
Reading symbols from d:\projects\testgameengine\trunk\bin\debug\TestGameEngine_d.exe...
done.
(gdb) >>>>>>cb_gdb:
> show version
GNU gdb (GDB) 7.3
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "mingw32".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
>>>>>>cb_gdb:
> set confirm off
>>>>>>cb_gdb:
> set width 0
>>>>>>cb_gdb:
> set height 0
>>>>>>cb_gdb:
> set breakpoint pending on
>>>>>>cb_gdb:
> set print asm-demangle on
>>>>>>cb_gdb:
> set unwindonsignal on
>>>>>>cb_gdb:
> set print elements -1
>>>>>>cb_gdb:
> set debugevents on
>>>>>>cb_gdb:
> set disassembly-flavor att
>>>>>>cb_gdb:
> catch throw
Catchpoint 1 (throw)
>>>>>>cb_gdb:
> source C:\Program Files\CodeBlocks\share\codeblocks/scripts/stl-views-1.0.3.gdb
>>>>>>cb_gdb:
> set print static-members off
show print static-members off

>>>>>>cb_gdb:Printing of C++ static members is off.
> directory D:/Projects/TestGameEngine/trunk/
>>>>>>cb_gdb:Printing of C++ static members is off.
> break "D:/Projects/TestGameEngine/trunk/src/TestApplication.cpp:105"
>>>>>>cb_gdb:
> run
>>>>>>cb_gdb:Breakpoint 2 at 0x403b5c: file D:\Projects\TestGameEngine\trunk\src\TestApplication.cpp, line 105.
>>>>>>cb_gdb:
gdb: windows_init_thread_list
[New Thread 3408.0x698]
[New Thread 3408.0x718]
[New Thread 3408.0xc38]
[New Thread 3408.0x8e0]
[New Thread 3408.0x6ec]
[New Thread 3408.0x504]
[New Thread 3408.0xc50]
[New Thread 3408.0xb88]
[New Thread 3408.0xac4]
[New Thread 3408.0x780]
warning: !!!Warning!!!: Impossible de jouer l'animation du modèle, l'index est out of range!
Breakpoint 2, sge::TestApplication::onFramePreUpdate (this=0x23fdb8) at D:\Projects\TestGameEngine\trunk\src\TestApplication.cpp:105
d:\projects\testgameengine\trunk\src\testapplication.cpp:105:3701:beg:0x403b5c
>>>>>>cb_gdb:
> set debugevents off
> bt 30
>>>>>>cb_gdb:
#0  sge::TestApplication::onFramePreUpdate (this=0x23fdb8) at D:\Projects\TestGameEngine\trunk\src\TestApplication.cpp:105
#1  0x6cb4bad6 in sge::GameApplication::doFrame (this=0x23fdb8) at D:\Projects\TestGameEngine\libs\SirmoGameEngine\trunk\src\GameApplication.cpp:330
#2  0x6cb4ba2a in sge::GameApplication::doGameLoop (this=0x23fdb8) at D:\Projects\TestGameEngine\libs\SirmoGameEngine\trunk\src\GameApplication.cpp:317
#3  0x6cb4aac7 in sge::GameApplication::Run (this=0x23fdb8) at D:\Projects\TestGameEngine\libs\SirmoGameEngine\trunk\src\GameApplication.cpp:132
Cannot access memory at address 0x0
#4  0x004016ef in [email protected] (hThisInstance=0x400000, hPrevInstance=0x0, lpszArgument=0x251f20 "", nCmdShow=10) at D:\Projects\TestGameEngine\trunk\main.cpp:32
#5  0x0041954e in main (argc=) at ../mingw/main.c:73
>>>>>>cb_gdb:
> bt 30
Cannot access memory at address 0x0
#0  sge::TestApplication::onFramePreUpdate (this=0x23fdb8) at D:\Projects\TestGameEngine\trunk\src\TestApplication.cpp:105
#1  0x6cb4bad6 in sge::GameApplication::doFrame (this=0x23fdb8) at D:\Projects\TestGameEngine\libs\SirmoGameEngine\trunk\src\GameApplication.cpp:330
#2  0x6cb4ba2a in sge::GameApplication::doGameLoop (this=0x23fdb8) at D:\Projects\TestGameEngine\libs\SirmoGameEngine\trunk\src\GameApplication.cpp:317
#3  0x6cb4aac7 in sge::GameApplication::Run (this=0x23fdb8) at D:\Projects\TestGameEngine\libs\SirmoGameEngine\trunk\src\GameApplication.cpp:132
#4  0x004016ef in [email protected] (hThisInstance=0x400000, hPrevInstance=0x0, lpszArgument=0x251f20 "", nCmdShow=10) at D:\Projects\TestGameEngine\trunk\main.cpp:32
#5  0x0041954e in main (argc=) at ../mingw/main.c:73
>>>>>>cb_gdb:
> cont
Breakpoint 2, sge::TestApplication::onFramePreUpdate (this=0x23fdb8) at D:\Projects\TestGameEngine\trunk\src\TestApplication.cpp:105
d:\projects\testgameengine\trunk\src\testapplication.cpp:105:3701:beg:0x403b5c
>>>>>>cb_gdb:
> bt 30
Cannot access memory at address 0x0
#0  sge::TestApplication::onFramePreUpdate (this=0x23fdb8) at D:\Projects\TestGameEngine\trunk\src\TestApplication.cpp:105
#1  0x6cb4bad6 in sge::GameApplication::doFrame (this=0x23fdb8) at D:\Projects\TestGameEngine\libs\SirmoGameEngine\trunk\src\GameApplication.cpp:330
#2  0x6cb4ba2a in sge::GameApplication::doGameLoop (this=0x23fdb8) at D:\Projects\TestGameEngine\libs\SirmoGameEngine\trunk\src\GameApplication.cpp:317
#3  0x6cb4aac7 in sge::GameApplication::Run (this=0x23fdb8) at D:\Projects\TestGameEngine\libs\SirmoGameEngine\trunk\src\GameApplication.cpp:132
#4  0x004016ef in [email protected] (hThisInstance=0x400000, hPrevInstance=0x0, lpszArgument=0x251f20 "", nCmdShow=10) at D:\Projects\TestGameEngine\trunk\main.cpp:32
#5  0x0041954e in main (argc=) at ../mingw/main.c:73
>>>>>>cb_gdb:
> quit
Hope this will help you!

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12125
    • Travis build status
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #19 on: October 05, 2011, 02:21:20 pm »
Code: [Select]
Cannot access memory at address 0x0
Probably this breaks the call stack refresh.

p.s. I've added it to the TODO list and I'll check it when I get there.
p.p.s. At the moment I've redesigned the breakpoints, so this should wait a bit, I'm just testing it now.
« Last Edit: October 05, 2011, 02:23:33 pm by oBFusCATed »
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline renega_666

  • Multiple posting newcomer
  • *
  • Posts: 36
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #20 on: October 05, 2011, 02:27:43 pm »
Ok take your time!
this is just a little issue that doesn't prevent me from working :)

Offline Aradayn

  • Single posting newcomer
  • *
  • Posts: 8
Error Message, then Crash
« Reply #21 on: October 07, 2011, 11:15:02 pm »
First, thank you to everyone who's made Code::Blocks possible. The debugger branch has improved an already great project; thanks!

I'd like to report two related debugging problems.

First, when I try debugging, I get the message:
"ERROR: You need to specify a debugger program in the debuggers's settings."

In an attempt to fix this problem, I went to the menu, but the build crashed when I went to the Settings > Debugger... menu option.

codeblocks.exe caused an Unknown [0xC000041D] Exception at location 734d4c4f.

Registers:
eax=0cf46500 ebx=00000001 ecx=00000000 edx=00000000 esi=0000a918 edi=0004175c
eip=763a40c4 esp=00093f3c ebp=00093f88 iopl=0         nv up ei pl zr na po nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000246

Call stack:
763A40C4  USER32.dll:763A40C4  GetScrollInfo
763A410F  USER32.dll:763A410F  SetScrollInfo
763BD55F  USER32.dll:763BD55F  SetScrollRange
7213E05E  COMCTL32.DLL:7213E05E  Ordinal382
720BD0E6  COMCTL32.DLL:720BD0E6  GetWindowSubclass
7213D744  COMCTL32.DLL:7213D744  ImageList_Draw
720BD0E6  COMCTL32.DLL:720BD0E6  GetWindowSubclass
7213D744  COMCTL32.DLL:7213D744  ImageList_Draw
720BD0E6  COMCTL32.DLL:720BD0E6  GetWindowSubclass
7213D744  COMCTL32.DLL:7213D744  ImageList_Draw


The function calls continue on like that. I updated the wxwidgets DLL and also tried running the program in administrator mode, but neither seemed to help. I'm running on Windows 7 service pack 1.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12125
    • Travis build status
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #22 on: October 07, 2011, 11:34:06 pm »
Yes, another one who has this mysterious crash.
So now if we could understand why it is happening...

I've tried to debug it, but I couldn't understand the reason.

Edit: do you happen to have tortoise svn 64bit installed or other shell extensions?
« Last Edit: October 07, 2011, 11:38:17 pm by oBFusCATed »
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Aradayn

  • Single posting newcomer
  • *
  • Posts: 8
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #23 on: October 07, 2011, 11:51:35 pm »
Maybe it has something to do with the version of MinGW/GDB I'm using?

gdb -v
GNU gdb (GDB) 7.3
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "mingw32".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.

gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=c:/development/mingw/bin/../libexec/gcc/mingw32/4.5.2/lto-wrapper.exe
Target: mingw32
Configured with: ../gcc-4.5.2/configure --enable-languages=c,c++,ada,fortran,objc,obj-c++ --disable-sjlj-exceptions --wi
th-dwarf2 --enable-shared --enable-libgomp --disable-win32-registry --enable-libstdcxx-debug --enable-version-specific-r
untime-libs --disable-werror --build=mingw32 --prefix=/mingw
Thread model: win32
gcc version 4.5.2 (GCC)


Edit: Yes, I have Tortoise SVN 64 installed as a shell extension. I also have the AMD VISION Engine Control Center extension (ATI graphics card stuff)
« Last Edit: October 07, 2011, 11:53:07 pm by Aradayn »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12125
    • Travis build status
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #24 on: October 08, 2011, 12:31:19 am »
The GDB is not involved in the crash.
The crash happens somewhere in the user32.dll, gdi32.dll or some other system dll.
Can you try to remove/uninstall the TortoiseSVN? I'm not on windows at the moment and I can't test it right now.

p.s. I'm using nVidia card. I guess it is not a bad video driver.
p.p.s. Unfortunately I can debug it with gdb, because it doesn't understand ms symbols.  :?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Aradayn

  • Single posting newcomer
  • *
  • Posts: 8
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #25 on: October 08, 2011, 06:53:51 am »
I uninstalled Tortoise SVN, restarted, and am still getting the same crash.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12125
    • Travis build status
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #26 on: October 08, 2011, 08:42:26 am »
OK, What else do you have installed?
If you don't want to state it in public send me an Personal message.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5247
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: Error Message, then Crash
« Reply #27 on: October 08, 2011, 09:07:48 am »
crashed when I went to the Settings > Debugger... menu option.
I have no such crash.
I guess there are something when when c::b try to open the Debugger dialog and read the associated resources. Maybe, your configure file is wrong, can you try to remove/backup all the c::b configurations, and use/create a new one for testing?
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12125
    • Travis build status
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #28 on: October 08, 2011, 07:00:24 pm »
ollydbg: There is not resource file involved in this dialog. The dialog is created with wxSmith, so it is all code. And the strangest thing is that it fails somewhere deep in the Win32/64 apis :(. And it fails on only two computers: mine and Aradayn's one. I've tried it on 3-4-5 other installs and it worked perfectly. :(
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Aradayn

  • Single posting newcomer
  • *
  • Posts: 8
Re: The 17 September 2011 build (7452) DEBUGGER BRANCH version is out.
« Reply #29 on: October 08, 2011, 09:22:58 pm »
I deleted everything in my Code Blocks as well as AppData/CodeBlocks, created a new folder from the nightly build and copied the wxwidgets DLL to it, and the crash still occurred on selecting the Settings > Debugging... menu item.

As far as installed programs... Well, I have lots. Too many to list. As far as ones with shell extensions, I had 7-Zip and Tortoise SVN and VLC, and I uninstalled all of these and it still crashed. I also had this extension that calculated the hashes of files in the properties dialog, and I uninstalled that one, too, but it still crashes. I still have the Microsoft Security Essentials extension and the DirectX SDK texture conversion extension too.