Author Topic: C::B Hanging While Using wxSmith  (Read 3540 times)

s1tony

  • Guest
C::B Hanging While Using wxSmith
« on: December 01, 2005, 08:44:50 pm »
Hello Group,

Another Newbie to C::B here.  In general, the IDE looks to be headed in the right direction.  However, I am having trouble with wxSmith.  In order to familiarize myself with the tool, I have been attempting (several times) to step through the "Hello world" Tutorial, posted on the site Wiki.

I am able to create a new wxWidgets project, compile, and run.  However, as I am following along with the tutorial, using wxSmith to add elements, C::B hangs, using 100% CPU.  In an effort to be patient, I let it run for several minutes like this before killling the app.  Fortunately, it appears as though the program hangs at the same point in the tutorial every time (at least the few times I attempted this):

Quote
And because this text looks so lonely, we will add button here:

    * Select Newly created text
    * Chose "After" Insertion type
    * Click on Button's icon

As soon as I select the "After" Insertion type, she hangs.

My platform is as follows:

AMD Duron 2.1GHz (overclocked, but very stable)
Windows 2000

Anyone have any suggestions?  At this point, I am considering either giving in to a Microsoft IDE, or going way old school and programming directly against the WIN32 API (hopefully without losing my sanity).  On the other hand, I guess I could learn how to code using wxWidgets, without a GUI editor.

Thank you.

s1tony





« Last Edit: December 02, 2005, 02:11:11 am by s1tony »

Offline squizzz

  • Almost regular
  • **
  • Posts: 132
Re: C::B Hanging While Using wxSmith
« Reply #1 on: December 01, 2005, 10:14:56 pm »

Quote
And because this text looks so lonely, we will add button here:

    * Select Newly created text
    * Chose "After" Insertion type
    * Click on Button's icon

As soon as I select the "After" Insertion type, she hangs.

It happened to me too with wxSmith included in RC2 release package (that you are likely using).
But wxSmith got much more stable now, you can try to compile SVN version of C::B with new version of the plugin yourself, or get some official "unofficial" builds made by Ceniza and Therion here: http://gda.utp.edu.co/~ceniza/CodeBlocks/ or http://paginas.terra.com.br/informatica/mauricio/codeblocks/ .

PS. be warned of drastic improvements made by wxSmith devs since RC2. ;)
« Last Edit: December 01, 2005, 10:19:29 pm by squizzz »
this space is for rent

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: C::B Hanging While Using wxSmith
« Reply #2 on: December 01, 2005, 10:23:18 pm »
Thx for reporting this.
I know that cyberkoa had simillar problem, i don't remember how did he fix that.

One question - have You used latest SVN binary shapshoot (http://gda.utp.edu.co/~ceniza/CodeBlocks/) ? Palette has been totally rewritten and doesn't use combo boxes anymore.
That could fix the problem :)

If it won't help I propose using other wxWidgets RAD tools (it really saves time ;) ):

http://www.upcase.de/stuff/wxRapid_setup.exe
https://sourceforge.net/projects/wxformbuilder/
http://wxstudio.sourceforge.net/

s1tony

  • Guest
Re: C::B Hanging While Using wxSmith
« Reply #3 on: December 06, 2005, 07:25:19 pm »
Thanks for the suggestions - I just got back to this project, so I will try using the latest SVN binary snapshot, and see what happens.

Offline cyberkoa

  • Plugin developer
  • Almost regular
  • ****
  • Posts: 145
    • http://
Re: C::B Hanging While Using wxSmith
« Reply #4 on: December 06, 2005, 08:28:01 pm »
yup, I face the same problem last time . It was solved in the later major changes , grab an SVN version , you will be surprised with the changes