Author Topic: Error message : "(...) version WXU_2.8.2 not defined (...)"  (Read 2680 times)

Offline anamine

  • Single posting newcomer
  • *
  • Posts: 3
Hello,

I am new on this forum and I hope not to blunder too much... I am not at all an informatic expert, I have to get familiar with Code Blocks, and I hope I can find some comfort here.

My system is Unbuntu karmic. I have first installed Code Blocks, following (blindly) the instructions from the Wiki:
http://wiki.codeblocks.org/index.php?title=Installing_Code::Blocks_nightly_build_on_Ubuntu

Now if I try to run it I get the following error message:
"codeblocks: relocation error: /usr/lib/libcodeblocks.so.0: symbol _Z18wxSafeConvertWX2MBPKw, version WXU_2.8.2 not defined in file libwx_baseu-2.8.so.0 with link time reference"

Could you please tell me how to solve this ?

Thanks in advance.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Error message : "(...) version WXU_2.8.2 not defined (...)"
« Reply #1 on: July 12, 2011, 09:42:43 pm »
Which version of ubuntu do you use, and which revision of C::B ?

Offline anamine

  • Single posting newcomer
  • *
  • Posts: 3
Re: Error message : "(...) version WXU_2.8.2 not defined (...)"
« Reply #2 on: July 13, 2011, 09:31:59 am »
Hello Jens,

My system is:

Ubuntu 9.10 (karmic)
Kernel Linux 2.6.31-14-generic
GNOME 2.28.1

I got my version of C::B following this path (from the homepage of the site):

Code::Blocks 10.05 is here! (downloads)
=> Download the binary release
=> Linux 64-bit
=> codeblocks-10.05-1-debian-amd64.tar.bz2

Thanks,
Ana