Code::Blocks
October 22, 2014, 03:46:09 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: When registered with our forums, feel free to send a "here I am" post in http://forums.codeblocks.org/index.php/topic,14168.0.html to differ human beings from SPAM bots.
 
   Home   Help Search Login Register  :: WebsiteWiki  
Pages: [1]   Go Down
  Send this topic  |  Print  
Author Topic: _ZN13DebuggerState7CleanUpEv??Anyone know??[solved]  (Read 2487 times)
wuxian610
Advanced newcomer
*
Offline Offline

Posts: 13


« on: November 29, 2005, 11:37:54 am »

HI,everyone:

           When I run the C:B(rc2), the "CodeBlocks" pops up,  saying: ....undefined symbol: _ZN13DebuggerState7CleanUpEv.
           The details:
                       /usr/local/share/codeblocks/plugins/libdebuggergdb.so: undefined symbol: _ZN13DebuggerState7CleanUpEv
                      /usr/local/share/codeblocks/plugins/libcompiler.so: undefined symbol:
                                                                          _ZN11EditPairDlgC1EP8wxWindowR8wxStringS3_RKS2_NS_10BrowseModeEv

          And the menu of the interface contains: File  Edit  View  Search  Project  wxSmith   Tools  Plugins  Settings  Help,
but ....where are  the "Debug" and the "Run" ?

         Can anyone give me a hand??Thanks!~
                                                                                                                             yours
« Last Edit: November 30, 2005, 02:37:12 am by wuxian610 » Logged
Urxae
Regular
***
Offline Offline

Posts: 376



« Reply #1 on: November 29, 2005, 05:51:55 pm »

Looks like another case of "the unix makefiles/.cbp is out of date" phenomenon :?...
DebuggerState is a relatively new part of the debugger plugin, and seems to not have been added to whichever build method you used (and quite possibly not to the other one either).
Oh, and I very much doubt it's actually RC2 as you claim, as DebuggerState was added to version control on Nov 23rd, and according to the main page RC2 was released Oct 25 (about a month earlier Wink).
EditPairDlg is also quite recent (Nov 25).

Since the debugger plugin needs DebuggerState and the compiler plugin needs EditPairDlg according to your error message, that would explain why those menus aren't available: the plugins that should create them couldn't be loaded.
« Last Edit: November 29, 2005, 05:55:21 pm by Urxae » Logged
Blaubaer
Newcomer
*
Offline Offline

Posts: 8


« Reply #2 on: November 29, 2005, 06:36:45 pm »

I had the same Problem. If your building with autotools you can put the lines
"debuggerstate.cpp" into "src/plugins/debuggergdb/Makefile.am" and
"editpairdlg.cpp" into "src/sdk/Makefile.am".

make clean && make && sudo make install

That did it for me.
Logged
wuxian610
Advanced newcomer
*
Offline Offline

Posts: 13


« Reply #3 on: November 30, 2005, 02:41:24 am »

I had the same Problem. If your building with autotools you can put the lines
"debuggerstate.cpp" into "src/plugins/debuggergdb/Makefile.am" and
"editpairdlg.cpp" into "src/sdk/Makefile.am".

make clean && make && sudo make install

That did it for me.

Thanks, all~! I have solved!
                                                                                                   (@V@):mrgreen: :mrgreen: :lol:
Logged
heromyth
Advanced newcomer
*
Offline Offline

Posts: 98


WWW
« Reply #4 on: December 02, 2005, 09:52:53 am »

This problem seems not much more critical. However, I still submit a patch file which can be get at http://sourceforge.net/tracker/index.php?func=detail&aid=1370946&group_id=126998&atid=707418.
Logged
Pages: [1]   Go Up
  Send this topic  |  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!