Author Topic: Debugger finished with status 1  (Read 8988 times)

Offline FrankTheFox

  • Single posting newcomer
  • *
  • Posts: 7
Debugger finished with status 1
« on: June 23, 2011, 02:49:32 pm »
Hi,

i got the following message from the debugger.

Quote
Debugger name and version: GNU gdb (GDB; openSUSE 11.1) 6.8.50.20081120-cvs
Debugger finished with status 1


and this is from Debug (debug ) tab

Quote
LD_LIBRARY_PATH=.:/usr/lib/mpi/gcc/openmpi/lib
Command-line: /usr/bin/gdb -nx -fullname  -quiet -args bin/Debug/wxProject
Working dir : /home/myHome/myProjects/wxProject/
[?1034h(gdb)
> set prompt >>>>>>cb_gdb:
>>>>>>cb_gdb:
> show version
GNU gdb (GDB; openSUSE 11.1) 6.8.50.20081120-cvs
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i586-suse-linux".
For bug reporting instructions, please see:
<http://bugs.opensuse.org/>.
>>>>>>cb_gdb:
> set confirm off
>>>>>>cb_gdb:
> set width 0
>>>>>>cb_gdb:
> set height 0
>>>>>>cb_gdb:
> set breakpoint pending on
>>>>>>cb_gdb:
> set print asm-demangle on
>>>>>>cb_gdb:
> set unwindonsignal on
>>>>>>cb_gdb:
> set disassembly-flavor intel
>>>>>>cb_gdb:
> catch throw
Function "__cxa_throw" not defined.


Does anybody know how to fix this?


Franky

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12122
    • Travis build status
Re: Debugger finished with status 1
« Reply #1 on: June 23, 2011, 02:59:14 pm »
Install newer gdb or disable the "Catch C++ exceptions" option
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline FrankTheFox

  • Single posting newcomer
  • *
  • Posts: 7
Re: Debugger finished with status 1
« Reply #2 on: June 23, 2011, 03:19:51 pm »
hi,

Thanks, disabling the "Catch C++ exceptions" option helps.

Greetz
 Franky