Author Topic: Weird Right to left issue on the main UI  (Read 7521 times)

ams790

  • Guest
Weird Right to left issue on the main UI
« on: October 13, 2010, 11:07:02 pm »
HI all..
This's my First post in here and my first experience with Code::Blocks is very weird ! First I installed the Application, chose the compiler and did everything normally. When I First Run the programme, I was shocked to see that EVERYTHING in the interface looks like as if you are using a mirror ! From right to left. By the way : My default machine language sittings is Arabic ( My First language ),which's written from right to left. But to read codes and right codes from right to left ? Ok ! this's a very weird problem !
I tried the Editor configuration sittings, changed encoding in to default as a try, and unmarked ( try system locale sitting ) then restarted the programme ,and nothing happened.
I have windows 7 already installed with Arabic package. Any ideas ?
right any thing in a piece of paper, read it at the mirror to understand what's going on here !!!!!

Your response is Appreciated


Offline azoharthi

  • Single posting newcomer
  • *
  • Posts: 2
Re: Weird Right to left issue on the main UI
« Reply #2 on: December 07, 2011, 04:38:32 am »

I know the solution

this problem happens in every system that uses a right to left language in the settings for region and currency and time.
you simply change those setting in your computer through control panel.

i just fixed my problem and I thought it would be nice to share. It is kind of frustrating that even with so much time since this post the problem was not fixed yet.

Offline azoharthi

  • Single posting newcomer
  • *
  • Posts: 2
Re: Weird Right to left issue on the main UI
« Reply #3 on: December 07, 2011, 04:53:24 am »
sorry...forget to tell you that there is another way to fix this from code blocks setting so you don't have to change your regional language to English.

open code blocks
from the upper tab chose settings => environment
from the side icons chose view (the big eyeball!)
uncheck the second box (internalization).
click OK and restart your code blocks and everything will be peachy.

regards.