Author Topic: Problem Building project with Code::Block  (Read 11311 times)

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Problem Building project with Code::Block
« Reply #15 on: October 04, 2010, 04:07:02 pm »
Go to "Settings -> Compiler and debugger... -> GCC -> Toolchain executables" and make sure the compiler installation dir points to the directory of your MinGW-install that includes the bin-dir (not the bin-dir itself) and make sure the executables that are set exist in the bin-dir of your MinGW-install.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6512
    • My Best Post
Re: Problem Building project with Code::Block
« Reply #16 on: October 04, 2010, 04:13:27 pm »
It looks like you have added the include path the Compilers uses automatically in the wrong way.

Check your Code::Blocks compiler configuration.

Edit: Make sure you pick the right Compiler from the "Selected Compiler" Pull-down list and make it the default compiler


This one is likely right
"Settings->Compiler and Debugger->Global Compiler settings->Toolchain executables"

But,
"Settings->Compiler and Debugger->Global Compiler settings->Search Directory" is likely wrong
The Three Sub Tabs are empty on me.

And
"Settings->Compiler and Debugger->Global Compiler settings->Linker Settings"
is also empty on mine.

Tim S.
 
« Last Edit: October 04, 2010, 04:16:09 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline arashfahim

  • Single posting newcomer
  • *
  • Posts: 9
Re: Problem Building project with Code::Block
« Reply #17 on: October 04, 2010, 04:35:08 pm »
The compiler I chose is GNU GCC Compiler.
"Settings->Compiler and Debugger->Global Compiler settings->Search Directory" was not empty in mine. I deleted all the PATHs.
The other tabs were empty.
It fixed the problem. Thanks a lot every body.