Author Topic: Keeps asking for compiler on start up  (Read 2509 times)

Offline Decrius

  • Multiple posting newcomer
  • *
  • Posts: 81
    • Daevius
Keeps asking for compiler on start up
« on: September 15, 2010, 08:43:40 pm »
Every time I start up CodeBlocks it asks me for the (default) compiler. As if it doesn't save the setting.

I'm running this on Win7 x86, does anyone have a solution for this problem?
Check out my website: http://www.daevius.com

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12235
    • Travis build status
Re: Keeps asking for compiler on start up
« Reply #1 on: September 15, 2010, 09:34:07 pm »
What version of CB?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Keeps asking for compiler on start up
« Reply #2 on: September 15, 2010, 09:45:32 pm »
Every time I start up CodeBlocks it asks me for the (default) compiler. As if it doesn't save the setting.

I'm running this on Win7 x86, does anyone have a solution for this problem?
One  of the compilers does not have a master-path-entry (most likely LLVM D, because it's newly added), you can find out which one it is, if it has an empty status in the window you get when starting C::B.

Open "Settings -> Compiler and debugger -> Global compiler settings -> [the invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]] -> Toolchain executables" and run "Auto detect", it will tell you that it can not find a valid installation and whether it should use the default directory, answer yes and the error should go.

Offline Decrius

  • Multiple posting newcomer
  • *
  • Posts: 81
    • Daevius
Re: Keeps asking for compiler on start up
« Reply #3 on: September 15, 2010, 11:26:33 pm »
Every time I start up CodeBlocks it asks me for the (default) compiler. As if it doesn't save the setting.

I'm running this on Win7 x86, does anyone have a solution for this problem?
One  of the compilers does not have a master-path-entry (most likely LLVM D, because it's newly added), you can find out which one it is, if it has an empty status in the window you get when starting C::B.

Open "Settings -> Compiler and debugger -> Global compiler settings -> [the invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]] -> Toolchain executables" and run "Auto detect", it will tell you that it can not find a valid installation and whether it should use the default directory, answer yes and the error should go.

Excellent, works like a charm!
Check out my website: http://www.daevius.com

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12235
    • Travis build status
Re: Keeps asking for compiler on start up
« Reply #4 on: September 16, 2010, 12:04:51 am »
devs: Probably C::B could be made to spit some message what has gone wrong...

Last days I'm experiencing this problem too and it is a bit random. Also on windows it happens far more often.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]