Author Topic: wxWidgets 2.6.2??  (Read 2463 times)

Offline rowck001

  • Single posting newcomer
  • *
  • Posts: 9
wxWidgets 2.6.2??
« on: November 08, 2005, 12:53:20 pm »
Hi

I have spent a frustrating afternoon trying to get wxWindows to compile and use in code::blocks.

No matter what command-line I use - I cannot generate a release version ie. wxmsw.lib instead of wxmswd.lib!

Does nayone know what command-line to use to compile wxwidgets? NOT THE DLL VERSION - the static library

Trying to compile an application in codeblocks with the debug version just gives link errors:

....... free already defined in LIBCVT.LIB blah, blah blah.....

selecting any combination of multi/single thread debug compiler option does not help at all!!

Offline kisoft

  • Almost regular
  • **
  • Posts: 194
Re: wxWidgets 2.6.2??
« Reply #1 on: November 08, 2005, 01:07:36 pm »
No matter what command-line I use - I cannot generate a release version ie. wxmsw.lib instead of wxmswd.lib!
...
....... free already defined in LIBCVT.LIB blah, blah blah.....

selecting any combination of multi/single thread debug compiler option does not help at all!!

May be try: make clean
before compile. Already old files.
Very similar.
OS: WinXPSP3
wxWidgets: 2.8.12
CodeBlocks: Master github cbMakefileGen plugin:
https://github.com/kisoft/cbmakefilegen