Author Topic: Code::Blocks (wxWidgets) using the wrong font color for disabled text.  (Read 2514 times)

Offline relpats_eht

  • Single posting newcomer
  • *
  • Posts: 4
OS: Linux (Gentoo)
GUI: KDE 4.4
Code::Blocks: 10.5
GTK Theme: gtk-engines-qtcurve
WxGTK: 2.8.10
GTK: 2.0

The problem has been brought up before (http://forums.codeblocks.org/index.php/topic,12423.0.html) for Code::Blocks version 8.2, where it affected my configuration as well. The problem seems to have gotten worse with the upgrade now also making tabs unreadable.

I have fixed this in my build of Code::Blocks by finding instances of wxSYS_COLOUR_GRAYTEXT and replacing them with the appropriate color for my theme, but I though I'd bring it up here in hopes a fix that were less of a hack could be made in some revision.

[attachment deleted by admin]

Offline Phenom

  • Multiple posting newcomer
  • *
  • Posts: 57
This hs been discused many times. Probably you should search the forum.
Anyway, see here.

Offline relpats_eht

  • Single posting newcomer
  • *
  • Posts: 4
Yes, that is the topic I linked in my original post (+url mangling). I did not find any other results on the subject given a cursory search and thought I might make known the issue was still present in this newer version.

If you would be so kind, do point out the other topics of similar discussion. I would like to look them over.

Offline nanyu

  • Almost regular
  • **
  • Posts: 188
  • nanyu
I have a suggestion: do not use gray text to express "disable", but use a gray icon.