Author Topic: CB giving error with status -1073741819  (Read 8985 times)

Offline ishu161

  • Multiple posting newcomer
  • *
  • Posts: 12
CB giving error with status -1073741819
« on: June 30, 2010, 08:44:57 pm »
okay, i've written a simple hello world program...

Code: [Select]
//a simple hello world program
#include<iostream>
int main()
{

    std::cout<<"Hello World!\n";
    char response;
    std::cin>> response;
    return 0;
}

and when i compile/build and Run it, the DOS window opens and windows give the gud ol' "send, Don't send" error.....after that, there is the following message in the window, which is also in the Build log :

Code: [Select]
Process terminated with status -1073741819 (0 minutes, 21 seconds)
well, in the window, it says that process returned -1073741819....which i'm guessing is a garbage value?

i've searched for this over the net, can't find it, and i'm pretty sure the coding is not the problem...help me out?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11722
    • Travis build status
Re: CB giving error with status -1073741819
« Reply #1 on: June 30, 2010, 09:30:32 pm »
Read the forum rules....
This is not a forum for discussing general programming, but a forum to discuss using CB for programming...

Buy a GOOD C++ book and read!
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline ishu161

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: CB giving error with status -1073741819
« Reply #2 on: June 30, 2010, 09:36:47 pm »
dude i know C++......i have programmed before...but this is giving me a headache coz i don't know what i'm doing wrong!
the compiler is there, the ide is there, the code is there, but no output!!! i have read the FAQs, AND the User Manual.....can't seem to find what's wrong!!!
don't reply if u don't wanna help man, no one's asking you to flame me

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11722
    • Travis build status
Re: CB giving error with status -1073741819
« Reply #3 on: June 30, 2010, 10:49:15 pm »
OK, but you've not read the forum's rules and there is no version info for OS, CB, compiler, no full build log...

Do you use a project or this is a single compiled using single cpp file?

btw, you code sample works perfectly on my machine...
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline ishu161

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: CB giving error with status -1073741819
« Reply #4 on: June 30, 2010, 11:30:49 pm »
well..thanks for at least replying....and i had read the rules...just a little frustrated...

i'm using windows xp sp2

i reinstalled C::B since the last post....and tried again, this time i'm getting an error saying the iostream file/directory doesn't exists.....i'm pretty sure minGW is installed, so why?

here's the build log:

Code: [Select]
mingw32-gcc.exe   -I"C:\Program Files\CodeBlocks\MinGW"  -c "C:\Documents and Settings\manish\My Documents\CodeBlocks\My Intro To OOP\Untitled1.c" -o "C:\Documents and Settings\manish\My Documents\CodeBlocks\My Intro To OOP\Untitled1.o"
C:\Documents and Settings\manish\My Documents\CodeBlocks\My Intro To OOP\Untitled1.c:2:19: error: iostream: No such file or directory
C:\Documents and Settings\manish\My Documents\CodeBlocks\My Intro To OOP\Untitled1.c: In function 'main':
C:\Documents and Settings\manish\My Documents\CodeBlocks\My Intro To OOP\Untitled1.c:6: error: expected expression before ':' token
C:\Documents and Settings\manish\My Documents\CodeBlocks\My Intro To OOP\Untitled1.c:8: error: duplicate label 'std'
C:\Documents and Settings\manish\My Documents\CodeBlocks\My Intro To OOP\Untitled1.c:6: note: previous definition of 'std' was here
C:\Documents and Settings\manish\My Documents\CodeBlocks\My Intro To OOP\Untitled1.c:8: error: expected expression before ':' token
Process terminated with status 1 (0 minutes, 5 seconds)
4 errors, 0 warnings
 

this thing hapenned when i initially installed code::blocks, but for some reason, it was able to at least compile the file later, and started giving the error message i posted earlier. Now, its even more hopeless.
i know C++ coding...the logic to the programs...i don't understand this! :(

and i was coding in an 'empty file' in an 'empty project'...and even a direct 'empty file'...same result
 
« Last Edit: June 30, 2010, 11:32:51 pm by ishu161 »

Offline ishu161

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: CB giving error with status -1073741819
« Reply #5 on: June 30, 2010, 11:39:21 pm »
the same thing happened again:

build log:

http://pastebin.com/huZZXsL8

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6511
    • My Best Post
Re: CB giving error with status -1073741819
« Reply #6 on: June 30, 2010, 11:43:37 pm »
Please use .cpp for C++ Files!
Code::Blocks considers .c files to be C Programs.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline ishu161

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: CB giving error with status -1073741819
« Reply #7 on: June 30, 2010, 11:50:51 pm »
okay.....its still the same....error

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6511
    • My Best Post
Re: CB giving error with status -1073741819
« Reply #8 on: July 01, 2010, 01:09:21 am »
okay.....its still the same....error

Then install the MinGW G++ needed for compiling C++ programs. Note, I really do not believe you got the same error.
But, I have seen a lot of people not install the C++ Compiler that could give about the same error again.
Please post new build log if you still need more help.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline ishu161

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: CB giving error with status -1073741819
« Reply #9 on: July 01, 2010, 01:28:33 am »
i believe i already have minGW installed.....it exists in the codeblocks directory...

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6511
    • My Best Post
Re: CB giving error with status -1073741819
« Reply #10 on: July 01, 2010, 02:03:53 am »
Please post new build log if you still need more help.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline ishu161

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: CB giving error with status -1073741819
« Reply #11 on: July 01, 2010, 02:06:40 am »
okay...i restarted the whole thing.
this is the code:

Code: [Select]
#include<iostream>
int main()
{

    using std::cout;
    using std::cin;
    cout<<"Hello World!\n";
    char response;
    cin>> response;
    return 0;
}

after that i hit "build and run", which caused a shell window to appear.

here is a screenshot:

http://i48.tinypic.com/2vjrf44.jpg

when i hit the key, this was in the build log:

Code: [Select]
Checking for existence: C:\Documents and Settings\manish\My Documes\CodeBlocks\123\bin\Debug\123.exe
Executing: "C:\Program Files\CodeBlocks/cb_console_runner.exe" "C:\Documents and Settings\manish\My Documes\CodeBlocks\123\bin\Debug\123.exe"  (in C:\Documents and Settings\manish\My Documes\CodeBlocks\123\.)
Process terminated with status -1073741819 (4 minutes, 32 seconds)
 

i don't know whats happening :(  i'll never advance in c++ this way...

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6511
    • My Best Post
Re: CB giving error with status -1073741819
« Reply #12 on: July 01, 2010, 02:22:57 am »
Please Turn on FULL compiler logging and post full re-build log if you want any help.
http://wiki.codeblocks.org/index.php?title=FAQ#Q:_How_do_I_troubleshoot_an_compiler_problem.3F

FYI: re-build means clean and then build.

Tim S.
« Last Edit: July 01, 2010, 02:25:08 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline ishu161

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: CB giving error with status -1073741819
« Reply #13 on: July 01, 2010, 02:30:36 am »
i had already activated it....anyways, i did it again...

and i'm not able to rebuild.....re-build and clean buttons are in-accesible


btw....is this what you mean:
before execution (build only)
http://pastebin.com/fNtzbz2y??
« Last Edit: July 01, 2010, 02:35:56 am by ishu161 »

Offline ishu161

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: CB giving error with status -1073741819
« Reply #14 on: July 01, 2010, 02:35:18 am »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6511
    • My Best Post
Re: CB giving error with status -1073741819
« Reply #15 on: July 01, 2010, 02:47:11 am »
I give up helping you; no idea how you got that long of build log.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline ishu161

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: CB giving error with status -1073741819
« Reply #16 on: July 01, 2010, 02:48:53 am »
well, thanks for being honest :)
i'll figure something out....

if you know someone else who can...can you please provide me their link?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11722
    • Travis build status
Re: CB giving error with status -1073741819
« Reply #17 on: July 01, 2010, 09:32:29 am »
Remove any traces from mingw and reinstall the compiler.
It seems to be broken.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]