Author Topic: CodeBlocks keyboard input really slow on Mac OS X 10.6.3 – Not sure why.  (Read 15412 times)

Offline edwin

  • Multiple posting newcomer
  • *
  • Posts: 38
Hello,

I searched this support forum (and Googled in general) for the answer I seek but I was unable to find the information I was looking for. Therefore this post…


Question 1:
Has anyone else experienced extremely slow keyboard input while using the CodeBlocks IDE under Mac OS X Snow Leopard v10.6.3?



The keyboard responsiveness of the IDE has always been extremely slow for me and I have tried to work with it as is but I am beginning to wonder if there might be some configuration change somewhere that might help – either in C::B or in the OS.

Maybe is it something specific to my OS X environment or some other silly setting I have not set properly. My Mac is used only for Development – No web surfing, no viruses, etc.

Thanks in advance for anyone who might be able to give me a bit of insight as to why this may be occurring.

I really love C::B and can’t wait for it to mature further. If I wasn’t so darn busy trying to make money (to keep the lights on), I would pitch in and help with the development. Maybe soon…

Thanks again….

edwin

   

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
Which plugins do you have enabled ? You might try disabling a few (or all).

Offline afb

  • Developer
  • Lives here!
  • *****
  • Posts: 884
I really love C::B and can’t wait for it to mature further. If I wasn’t so darn busy trying to make money (to keep the lights on), I would pitch in and help with the development. Maybe soon…

It's also possible to donate money, instead of time, if Code::Blocks is useful to your work...

See http://www.codeblocks.org/donations


Offline edwin

  • Multiple posting newcomer
  • *
  • Posts: 38
Hello afb,

Thank you for your reply.

These plugins are currently enabled:
Symbol Table Plugin v1.0
Source code formatter v1.2
Help plugin v1.1
File extension handler v1.0
Debugger v0.3
Compiler v0.99
BrowseTracker v1.2.94 2010/02/25

There are other plugins loaded but not enabled. I disabled all the other plugins that I thought I would not need (hopefully to reduce any bugs or other issues).

It would be terrific if you have any ideas….

Thank you,

edwin


Offline AlisdairM

  • Single posting newcomer
  • *
  • Posts: 6
Just to note I see the same problem, even with *all* plugins disabled.  (I had to disable all plugins to get past some basic crashes, and slowly re-enabling them till I identify the 'bad' ones)

I had put this down to running a basic MacBook (not the pro!) - are you running on something substantially more powerful?

My suspicion is this is a wxWidgets or Scintilla issue, running on OSX, rather than something specific to CodeBlocks, although I don't have any other wx/Scintilla apps to compare with.

Online oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11816
    • Travis build status
You could try SCiTe, don't know if it is ported to osx... it has been ported to linux
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline edwin

  • Multiple posting newcomer
  • *
  • Posts: 38
Hi AlisdairM,

I am glad you posted your information.

Regarding slow keyboard input:
I went through the exact same process of disabling all plugins in order to narrow down the issue. Seeing that disabling all plugins did dot remedy the situation, I only enable minimal plugins that I thought were absolutely helpful to my work while still maintaining stability of the IDE.

I am running CodeBlocks on OS X v10.6.3 on a 15” MacBook Pro. I also tried the same C::B setup on another Mac that is here but the same behavior was experienced.

I think you are correct in that it looks to be associated with wxWidgets (I use v2.8.10 for my C::B build) or something in Scintilla.

Other Notes:
When I navigate within an open source code module within CodeBlocks using arrow keys, the cursor movement is reasonable. However, when I edit the document (by typing in new code lines for example), the keyboard characters experience long delays.

It almost appears that there is some kind of “non-optimal” buffering issue when inserting characters into open files. Logically the IDE is working properly seeing it does not crash and everything I type eventually gets inserted into the open documents.

Another item to note is that cut and paste operations within the same documents also work reasonable (without large cut and paste delays). Hmmmm... strange…



Two other items:

Item 1: Code completion plugin crashing the IDE
Have you seen the “Code completion” plugin crash CodeBLocks when saving a workspace or terminating the CodeBlocks app? I see this behavior and have just been working around the issue. I have been saving crash dumps and this issue is repeatable. The call stacks all look similar.

Item 2: CodeBlocks startup is long
The startup time is extremely long. It appears that loading plugins is very slow for some reason. I did run C::B through the debugger to see what was causing the long startup times but I only had a small amount of time I could spend tracking down this issue. Unfortunately I need to have more time to complete a better analysis of what is actually going on.

My only guess is that all the plugins - as they are being loaded -  have to be relocated in memory thus slowing down the entire load process. I am only guessing here but would like to know what you think.


CodeBlocks is a nice IDE and I am sure these issues can eventually be resolved considering all the hard (and great) work that has already been completed on the IDE.

Thank you,

edwin


Offline Four

  • Single posting newcomer
  • *
  • Posts: 5
I experience the same issues. I tried disabling all the plugins but still keyboard input is slow. Long startup time, its not that long but seeing other software with similar functionality like Geany, codeblocks should be faster. I haven't experienced codeblocks crashing. I noticed entering characters & manipulating the text is slow but selecting. text, moving the caret & etc... is fine.

Codeblocks version 10.05 Rev 0
I'm on Debian unstable
« Last Edit: January 25, 2011, 02:07:44 am by Four »

Offline Calexus

  • Multiple posting newcomer
  • *
  • Posts: 48
I have had the same problem but in winxp not osx. I didn't really think much about it as I was running codeblocks on an netbook and didn't really expect it to work flawlessly. Moving the caret using the keyboard is really slow but moving it using the mouse works as normal.

But I do have problem with scrolling being extremely slow in osx (snow leopard), I simply use the keyboard or the scrollbar instead but it's a bit annoying not being able to use the scroll wheel or multi-touch scroll.

Edit >> osx 10.6.6

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9493
Make sure in the editor settings -> code completion you have disabled the option "update parser when typing". This would explain this slow behaviour otherwise.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline edwin

  • Multiple posting newcomer
  • *
  • Posts: 38
Re: CodeBlocks keyboard input really slow on Mac OS X 10.6.3 – Not sure why.
« Reply #10 on: January 25, 2011, 04:53:49 pm »
Hi Morten,

Thank you for that tip. I would like to try what you suggest but when I change and save the updated setting, my C::B crashes and the old setting persists. :(

Is it possible to change this setting manually in a config file outside of the IDE?

Thank you,

edwin


Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9493
Re: CodeBlocks keyboard input really slow on Mac OS X 10.6.3 – Not sure why.
« Reply #11 on: January 25, 2011, 07:35:52 pm »
Is it possible to change this setting manually in a config file outside of the IDE?
Although this is really not recommended, you can try to add/modify the (existing) section in the default.conf file as following:
Code: [Select]
<code_completion>
<WHILE_TYPING bool="0" />
</code_completion>
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: CodeBlocks keyboard input really slow on Mac OS X 10.6.3 – Not sure why.
« Reply #12 on: January 25, 2011, 07:40:05 pm »
If I remember right, we had a similar issue some 1-2 years ago with some Linux distros that used some bugged Cairo lib, or something. For whatever reason, the editor spent *huge* amounts of time in calculating character widths over and over again.

Not sure if that is of any help in your particular case, but it might be worth checking that all your 3rd party dependencies are up to date.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline Four

  • Single posting newcomer
  • *
  • Posts: 5
Re: CodeBlocks keyboard input really slow on Mac OS X 10.6.3 – Not sure why.
« Reply #13 on: January 25, 2011, 07:57:30 pm »
Unfortunately disabling "update parser when typing" didn't work but disabling the code completion auto popping ("Automatically Launch when typed # of letters") worked. Maybe doing the auto completion when you type a "." , "::", or  "->" and etc.. would be better.

Offline AndreasO

  • Single posting newcomer
  • *
  • Posts: 2
    • adrastea
Re: CodeBlocks keyboard input really slow on Mac OS X 10.6.3 – Not sure why.
« Reply #14 on: February 23, 2013, 10:32:41 pm »
Hi,

Was this problem ever solved? I'm having exactly the same problems with a delayed, very slow keyboard input and a long startup time on Mac OS X 10.7.5 and CodeBlocks 12.11 (all plugins apart from Compiler disabled).

Best regards,
Andreas

Offline AndreasO

  • Single posting newcomer
  • *
  • Posts: 2
    • adrastea
Updated to Mac OS 10.8.2 and still the same problem. :(

Offline Zillah

  • Single posting newcomer
  • *
  • Posts: 2
Hey,

after around 5000 lines of code the slow input gets really annoying. CPU1 is at 100% while typing. I already tested several settings/plugins but I still cannot detect the corrupt piece.

An alternative is running the x11 mac port version (see the wiki for installation instructions, but use "codeblocks" instead of "codeblocks-devel") which works flawlessly for me.

Best,

Zillah

Online oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11816
    • Travis build status
after around 5000 lines of code the slow input gets really annoying. CPU1 is at 100% while typing. I already tested several settings/plugins but I still cannot detect the corrupt piece.
Can you try to profile it (Apple has a free tool Shark-something), so we can see where it is slow?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Zillah

  • Single posting newcomer
  • *
  • Posts: 2
Hmm thats a good idea, I will try to in the near future and I will let you know the results.

Offline fcorm

  • Single posting newcomer
  • *
  • Posts: 2
Same problem here. OS X 10.6.8 (Snow Leopard), Code::Blocks SP1 version (released Jan 2013), Code Completion plugin disabled. Keyboard input is tremendously slow...