Author Topic: wxWidgets: dll / program mismatch  (Read 3441 times)

Offline SpringRainSoftware

  • Single posting newcomer
  • *
  • Posts: 3
wxWidgets: dll / program mismatch
« on: November 02, 2005, 03:39:45 am »
I'm getting the following error:

"Mismatch between the program and library build versions detected"

It then lists the options for each.  It shows I am using a debug version of wxWidgets (which is correct), but it says my application is not in debug mode.  I've set this under: Project Build Options -> Produce Debugging Symbols.  The check box _is_ checked.

It is a default wxWidgets template, with a DLL linked in (manually changed the path to the correct library)  I'm guessing I'm missing something simple.  Any suggestions or questions I can answer to help come up with some ideas??

Thanks folks!
-----
C:B version -> RC2
wxWidgets -> 2.6.2 DLL

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: wxWidgets: dll / program mismatch
« Reply #1 on: November 02, 2005, 03:55:53 am »
The program may have debug symbols enabled, but it was compiled with the "release" version of wxwidgets.

As a general note, you DON'T need a debug version of wxwidgets. We've been debugging with the "release" version and have had no problems with it.

Offline xuegao0807

  • Single posting newcomer
  • *
  • Posts: 3
Mismatch between the program and library build versions detected
« Reply #2 on: April 22, 2014, 12:15:37 pm »
hello:
      I'm a newer to use codeblocks ,I want to built a wxWidgets object. compiling it is ok ,but when I run , there are error
Code: [Select]
Mismatch between the program and library build versions detected
The library used 2.8(no debug,Unicode,compiler with C++ ABI 1002,wx container,compatible with 2.6),
And your program used 2.8(debug,Unicode,compiler with C++ ABI 1002,wx container, compatible with 2.6)
can someone help me? thank you very much!

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2432
Re: wxWidgets: dll / program mismatch
« Reply #3 on: April 22, 2014, 06:29:32 pm »
this has nothing to do with c::b...

you simply have to ensure that the wxWidgets version of your compiler and your target machine match...

You compiled your program with a debug version of the library, but try to run the program with a non debug library... Simply copy the dll, from the compiler library path to your program base dir...