Author Topic: Problem configuring Digital Mars as default compiler  (Read 26294 times)

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: Problem configuring Digital Mars as default compiler
« Reply #15 on: November 01, 2005, 09:51:04 pm »
About make, its not called if you are using direct compilation in C::B

About spaces in path, yes, I'm talking about installing the compiler in a dir without spaces. In some compilers, it cause troubles.
« Last Edit: November 01, 2005, 09:54:30 pm by takeshimiya »

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9493
Re: Problem configuring Digital Mars as default compiler
« Reply #16 on: November 01, 2005, 11:39:00 pm »
I'm using mingw32-make (from MinGW) as Make program for DMars, dunno if it's related.
The same for me (that's the default configuration from within Code::Blocks.

I now ran SysInternals filemon myself. It's definetly the linker from DMC that is being called on my machine. Did you run filemon already? What's the result? Why is the difference? Do you have another version on DMC (note the name of the ZIP-file I downloaded)?

I can only confirm what takeshimiya said as well: In my opinion it's always a bad idea to have a compiler system in a path with spaces. Especially that's the case with cross-platform compilers. Could you just try another folder without spaces?

Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline Israel

  • Multiple posting newcomer
  • *
  • Posts: 14
Re: Problem configuring Digital Mars as default compiler
« Reply #17 on: November 02, 2005, 12:47:41 am »
> The same for me (that's the default configuration from within Code::Blocks.

Ok, thanks.

> I now ran SysInternals filemon myself. It's definetly the linker from DMC that is being called on my machine. Did you run filemon
> already? What's the result? Why is the difference? Do you have another version on DMC (note the name of the ZIP-file I
> downloaded)?

I didn't run filemon because I can see from my firewall which program (including the path) is getting invoked.  It is definitely the link.exe from the dm845c/dm/bin.  I had the same DMC version as you, and only one version.

> I can only confirm what takeshimiya said as well: In my opinion it's always a bad idea to have a compiler system in a path with
> spaces. Especially that's the case with cross-platform compilers. Could you just try another folder without spaces?

I really didn't think this had anything to do with it, because the linker was getting invoked, but you guys have been great, so I tried it.  As I suspected, big waste of time, it didn't change anything.  If the right linker hadn't been getting invoked, that could have been a candidate, but since it was, the execution path couldn't be the issue.

And then I thought to myself, self, maybe it's something like the spaces in a path name.  Not spaces, but something else objectionable.  And not the path for DMC, but the target path.

And there it was: wxp/utilities/dev/c++/console1

When I changed the C++ folder name to CPP, it worked.

Now isn't that a stinker!?

The thread I pointed-to earlier on DMC's forums has been updated.

You guys rock.  Thanks for the help, and for sticking with me.  I hope I can return the favor some day.

Best Regards,

Israel, at quarter to 2:00 in the morning.

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9493
Re: Problem configuring Digital Mars as default compiler
« Reply #18 on: November 02, 2005, 07:15:47 am »
Now isn't that a stinker!?
...it is...  :lol:

Well, glad it works now. It began to become quite weird anyway.

Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: Problem configuring Digital Mars as default compiler
« Reply #19 on: November 02, 2005, 08:30:16 am »
 :D It's great you got it working!

I've had lots of problems with files and paths.
I always try to stick to good old chars [A-Z] [0-9] in path.
Any other char (like space, -, +, ', ., etc) can screw some tools/programs.

Is incredible how very few programs can handle perfectly a filename/path.
Some of my filenames are in japanese (unicode), and in year 2005 almost like a 10% of all the programs can handle them.
I think I can build a list of the programs that does support it. It's soo annoying when they doesn't support unicode/special chars...

Offline Israel

  • Multiple posting newcomer
  • *
  • Posts: 14
Re: Problem configuring Digital Mars as default compiler
« Reply #20 on: November 02, 2005, 01:35:47 pm »
I mentioned earlier in the thread that I posted on the dmc forum to see if anyone had any ideas.  Someone over there said that OPTLINK was very old and wasn't being updated!  And I read on DMC that dmc.exe is the all-in-one compiler/linker, so maybe we should be building some other way.

I asked the question over there- you can see the thread if you're interested.

Thanks again for all the help, guys! :-)

Israel
likin' Code::Blocks!

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: Problem configuring Digital Mars as default compiler
« Reply #21 on: November 22, 2005, 05:40:04 am »
It's true it's more updated, and it generates .def files.
link.exe and lib.exe should be replaced by dmc.exe with it's parameters.

Offline severach

  • Multiple posting newcomer
  • *
  • Posts: 44
Re: Problem configuring Digital Mars as default compiler
« Reply #22 on: December 21, 2005, 07:19:36 am »
>C:\Program Files\dm845c\dm\include

You cannot install DMC into a path with spaces. Some of the programs are not space aware. If you install DMC into C:\dm\ where it is expected, everything including Code::Blocks will work best.

If you want to use the latest SDK, you may want my DMC addon:

ftp://isisbst.no-ip.com/PRIVATE/NPPTextFX.htm

built from:

http://cmeerw.org/prog/dm/ms_sdk.html