Author Topic: codeblocks 8.02, windows xp, program won't build  (Read 11953 times)

Offline squirrel_123

  • Single posting newcomer
  • *
  • Posts: 3
codeblocks 8.02, windows xp, program won't build
« on: March 31, 2010, 01:41:15 pm »
hi, I've looked through all the other threads about this and they're all for vista and none of the solutions worked  :?
i have the 8.02, and it's installed on windows xp
when i try to build a program, it's just complete silence, nothing happens
if i click run, it says, this program hasn't been built yet, do you want to build it now, yes or no.
so i click yes, but then nothing happens again.
i know there's nothing wrong with the program i've written because it works on the codeblocks at my uni.
help please!

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12129
    • Travis build status
Re: codeblocks 8.02, windows xp, program won't build
« Reply #1 on: March 31, 2010, 02:35:05 pm »
Have you read the FAQ?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline squirrel_123

  • Single posting newcomer
  • *
  • Posts: 3
Re: codeblocks 8.02, windows xp, program won't build
« Reply #2 on: March 31, 2010, 02:39:20 pm »
yes, it wasn't on there  :(

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12129
    • Travis build status
Re: codeblocks 8.02, windows xp, program won't build
« Reply #3 on: March 31, 2010, 02:46:36 pm »
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Notforsell

  • Single posting newcomer
  • *
  • Posts: 2
Re: codeblocks 8.02, windows xp, program won't build
« Reply #4 on: March 31, 2010, 04:07:45 pm »
I am a chinese, and I have the same problem, it doesn't work after Reinstallation of windows xp,
it just does nothing when I kick build...and while I kick run, it prints "It seems that the file has not
been built yet. Do you want to built now?", then I kick yes, but it still do nothing....
please help :( :( :(

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6678
    • My Best Post
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Notforsell

  • Single posting newcomer
  • *
  • Posts: 2
Re: codeblocks 8.02, windows xp, program won't build
« Reply #6 on: April 01, 2010, 02:08:53 am »
Yes, but it still doesn't work
it just does nothing when I click build, and run.
No any imformation, or something else, it just blank. :(

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6678
    • My Best Post
Re: codeblocks 8.02, windows xp, program won't build
« Reply #7 on: April 01, 2010, 03:29:50 am »
Post the full build log after a re-build.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline squirrel_123

  • Single posting newcomer
  • *
  • Posts: 3
Re: codeblocks 8.02, windows xp, program won't build
« Reply #8 on: April 01, 2010, 11:29:33 am »
What about this:
http://wiki.codeblocks.org/index.php?title=FAQ#Q:_How_do_I_troubleshoot_an_compiler_problem.3F

Have you enabled the full logging?

yeah, i already found this yesterday in one of the other threads, it did nothing.
and about posting a full build log..there is literally nothing in the build log. it just does absolutely nothing when I click build  :?

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6678
    • My Best Post
Re: codeblocks 8.02, windows xp, program won't build
« Reply #9 on: April 01, 2010, 03:53:08 pm »
I can not help you, all I can suggest is delete and re-install.

I would suggest un-installing Code::Blocks and deleting the config files.

How to delete configuration files.

Open using run this folder %APPDATA%\codeblocks delete at least the file default.conf; I suggest deleting them all.

Tim S.

C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

zim

  • Guest
Re: codeblocks 8.02, windows xp, program won't build
« Reply #10 on: April 04, 2010, 03:55:44 am »
I had the same problem, but I found a solution. I don't know if this will work for you, but . . .

I uninstalled, then reinstalled.

Then, under Settings-> Compiler and debugger -> Other Settings Tab -> Compiler logging: I chose 'Full command line'.

(So far this is exactly what the FAQ said to do)

Then, in the same 'Global compiler settings' window, under Selected compiler, I chose 'GNU GCC Compiler', then hit the 'set as default' button.

Now everything works.

Hope this helps. Good luck.
 

Offline shiqing

  • Single posting newcomer
  • *
  • Posts: 2
Re: codeblocks 8.02, windows xp, program won't build
« Reply #11 on: August 16, 2011, 11:32:18 am »
Hi,

Sorry to pull this thread up again. I got the same problem with Codeblocks 10.5 + MinGW on Windows 7.

The problem is that, the project will be compiled only when the full compiler logging is enabled. It will not work if you wanna have task description for the compiler log.

After some tests, I did find another better solution. In the toolchain settings, the make program is set to make.exe by default, changing it to mingw32-make.exe will get rid of the problem.

I don't know whether it's a bug or what. If someone else has already posted it before, then please just ignore me.


Shiqing