Author Topic: I tried using a make file and now I can't build anything  (Read 2396 times)

Offline Gavrillo

  • Single posting newcomer
  • *
  • Posts: 7
I tried using a make file and now I can't build anything
« on: March 24, 2010, 12:06:35 am »
I decided to use a make file rather than C::B's built in build partly because I don't want to be tied in to C::B and a make file seems more portable.  So I've been messing around (unsuccessfully) trying to compile with a make file.

Now I can't compile with anything!  I start a project and try an compile the basic framework provided, that worked when I first got C::B and I get:

C:\wxWidgets2.8\include\wx\buffer.h||In constructor `wxCharBuffer::wxCharBuffer(const char*)':|
C:\wxWidgets2.8\include\wx\buffer.h|127|error: `strdup' was not declared in this scope|
C:\wxWidgets2.8\include\wx\buffer.h|127|warning: unused variable 'strdup'|
C:\wxWidgets2.8\include\wx\buffer.h||In member function `wxCharBuffer& wxCharBuffer::operator=(const char*)':|
C:\wxWidgets2.8\include\wx\buffer.h|127|error: `strdup' was not declared in this scope|  etc etc.....

I can't think what I've done but any help would be appreciated. 
I am pretty sure I have set or unset something in C::B that is causing the failure.
In fact I tried reinstalling C::B but it didn't help.
I have of course unchecked the tick box in Project\Properties\custom make file.

Thanks in advance.
ps:  I've never posted anything before so please be tolerant of any transgressions.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6193
    • My Best Post
Re: I tried using a make file and now I can't build anything
« Reply #1 on: March 24, 2010, 02:12:43 am »
What Compiler and its version?
What version of Windows?

Turn on Full Compiler Logging; see Wiki FAQ on how to troubleshoot a compiler issue.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Testing, compiling CB Trunk against wxWidgets 3.0.2.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline Gavrillo

  • Single posting newcomer
  • *
  • Posts: 7
Re: I tried using a make file and now I can't build anything
« Reply #2 on: March 27, 2010, 01:03:26 am »
I reinstalled wxWidgets (Pack) and that sorted everything out!  -- Thanks to the person who replied