Author Topic: Bug: "Configure Code Completion" Crashes  (Read 10533 times)

Offline Muhammad Haggag

  • Multiple posting newcomer
  • *
  • Posts: 23
    • Developer journal
Bug: "Configure Code Completion" Crashes
« on: May 09, 2004, 10:38:28 am »
The subject says it all.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Bug: "Configure Code Completion" Crashes
« Reply #1 on: May 09, 2004, 10:45:21 am »
Everytime? Did you do anything special?
Be patient!
This bug will be fixed soon...

Offline Muhammad Haggag

  • Multiple posting newcomer
  • *
  • Posts: 23
    • Developer journal
Bug: "Configure Code Completion" Crashes
« Reply #2 on: May 09, 2004, 10:49:14 am »
Yes, everytime :)
No, I didn't do anything special to that (Though frankly, I'm special ;))

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Bug: "Configure Code Completion" Crashes
« Reply #3 on: May 09, 2004, 11:11:29 am »
OK, give me some more info.
When does it crash? Just by clicking "Settings/plugins/code completion"? Do you ever get to see the dialog? Does it crash when exiting the dialog? Did you press OK or Cancel?

I need more info  :roll:
Be patient!
This bug will be fixed soon...

Offline Muhammad Haggag

  • Multiple posting newcomer
  • *
  • Posts: 23
    • Developer journal
Bug: "Configure Code Completion" Crashes
« Reply #4 on: May 09, 2004, 02:32:50 pm »
As soon as I click "Settings/Plugins/Code Completion" it crashes. I don't get any dialogs or anything. Can you send me the debug symbols? (if they're not *big*)
I might be able to hook into it with WinDbg or CDB and see where it's happening.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Bug: "Configure Code Completion" Crashes
« Reply #5 on: May 09, 2004, 03:38:58 pm »
Hmm, most probably a file must be missing from the setup file. Do you have the share/CodeBlocks/code_completion.zip file?
Be patient!
This bug will be fixed soon...

Offline Muhammad Haggag

  • Multiple posting newcomer
  • *
  • Posts: 23
    • Developer journal
Bug: "Configure Code Completion" Crashes
« Reply #6 on: May 09, 2004, 03:45:15 pm »
Quote from: mandrav
Hmm, most probably a file must be missing from the setup file. Do you have the share/CodeBlocks/code_completion.zip file?
Errr.... No! That must be it, then -- I'll reinstall.
Anyway, better check for that condition (missing file) in your code instead of crashing :)

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Bug: "Configure Code Completion" Crashes
« Reply #7 on: May 09, 2004, 03:48:45 pm »
Quote from: MHaggag
Quote from: mandrav
Hmm, most probably a file must be missing from the setup file. Do you have the share/CodeBlocks/code_completion.zip file?
Errr.... No! That must be it, then -- I'll reinstall.
Anyway, better check for that condition (missing file) in your code instead of crashing :)


In case I 've forgotten to add it in the setup file, get it from <a href="http://www.codeblocks.org/files/code_completion.zip">here</a> and put it under share/CodeBlocks

I 'm gonna verify the setup files...
Be patient!
This bug will be fixed soon...

Offline Muhammad Haggag

  • Multiple posting newcomer
  • *
  • Posts: 23
    • Developer journal
Bug: "Configure Code Completion" Crashes
« Reply #8 on: May 09, 2004, 03:59:01 pm »
Quote from: mandrav
In case I 've forgotten to add it in the setup file, get it from <a href="http://www.codeblocks.org/files/code_completion.zip">here</a> and put it under share/CodeBlocks

I 'm gonna verify the setup files...

Yup, you've forgotten to do that it seems. Either that or the installer doesn't install them, because I've tried reinstalling it.