Author Topic: 8.03 release?  (Read 23705 times)

Offline mariocup

  • Developer
  • Lives here!
  • *****
  • Posts: 587
Re: 8.03 release?
« Reply #45 on: February 16, 2010, 09:44:07 pm »
Hi Martin,

this would be the expected behaviour, but at my configuration it does not. I tried to start codeblocks with --safe-mode and -p=test. In both cases the multiple selection works as expected.

No I have to see which setting in my codeblocks environment is causing the strange behaviour with default.conf.

Offline mariocup

  • Developer
  • Lives here!
  • *****
  • Posts: 587
Re: 8.03 release?
« Reply #46 on: February 16, 2010, 10:07:49 pm »
Hi,

my settings of BrowseTracker plugin caused the behaviour. "Enable BrowseMarks" was activated and the setting "Toggle BrowseMark Key" was configured for "Ctrl-Left_Mouse". If I change this setting everything works fine, but I forgot that I ever configured BrowseTracker with this behaviour. I hope that this is not a pitfall for other users.

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
Re: 8.03 release?
« Reply #47 on: February 17, 2010, 06:43:47 am »
"Toggle BrowseMark Key" was configured for "Ctrl-Left_Mouse".
Ouch! Who is the dev of BrowseTracker? Pecan? Probably you want to send him a PM telling so.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2180
Re: 8.03 release?
« Reply #48 on: February 19, 2010, 08:45:04 pm »
Hi,

my settings of BrowseTracker plugin caused the behaviour. "Enable BrowseMarks" was activated and the setting "Toggle BrowseMark Key" was configured for "Ctrl-Left_Mouse". If I change this setting everything works fine, but I forgot that I ever configured BrowseTracker with this behaviour. I hope that this is not a pitfall for other users.

It's going to take some major work to remove Ctrl-Left mouse from BrowseTracker.

If you use multiple mark selection in the editor, you'll have to disable BrowseTracker for the time being.

EDIT:
BrowseTracker will no longer use the Ctrl-Left_Mouse options when the user has enabled Editor Multi-Selection.

The user can clear BrowseMarks via the menu items.

Setting a hot key to the View/BrowseTracker/Clear menu item will make it easier to clear the Browsemarks.
 
« Last Edit: February 20, 2010, 02:42:05 am by Pecan »