Author Topic: After Upgrade to Ubuntu 9.10 Code::Blocks will not start  (Read 2093 times)

Offline donnyb

  • Single posting newcomer
  • *
  • Posts: 5
After Upgrade to Ubuntu 9.10 Code::Blocks will not start
« on: January 09, 2010, 09:52:35 pm »
I upgraded to ubuntu 9.10. Was using Code blocks and then I closed it and when I came to open it again it keeps going to the debug report, asking me to submit. I have reinstalled the code blocks, with no change. tempted to wipe out ubuntu 9.10 and go back to 9.04. Help Please. Before the re-install I removed the code-blocks using the package manager.

Offline mariocup

  • Developer
  • Lives here!
  • *****
  • Posts: 587
Re: After Upgrade to Ubuntu 9.10 Code::Blocks will not start
« Reply #1 on: January 09, 2010, 11:10:42 pm »
Hi donnyb,

I had a similar problem after upgrading to 9.10. If you start codeblocks from a terminal do you get
Yesterday I updated my system to kramic and had problem starting C::B

Code: [Select]
version WXU_2.8.2 not defined in file libwx_baseu-2.8.so.0

If this is the case add

Code: [Select]
deb http://apt.wxwidgets.org/ lenny-wx main

to my sources.list and go to Synaptic and chose libwxbase2.8-0. Then select the menu Package->Force version and switch to lenny-wx version and apply the changes. After this C::B works again.