Author Topic: Code Blocks Search Directories only show up after a build?  (Read 3680 times)

Offline jiapei100

  • Multiple posting newcomer
  • *
  • Posts: 20
    • Vision Open
Code Blocks Search Directories only show up after a build?
« on: January 07, 2010, 02:58:49 pm »

Hi,

Whenever I clicked project's name and then
build options->Compiler->Search directories

Nothing displayed.

I've got to "build" this project once again,
even thought nothing is actually "built" in this round,
(Namely:  In build log, it will show

Target is up to date.
Nothing to be done. )


I don't know whether this is a bug of Code Blocks.
But, in my personal opinion, it's better to show up Search directories
whenever I clicked on the project build options.
Building it once again to show up "search directories" is not the right way out.


Best Regards
JIA



Welcome to Vision Open
http://www.visionopen.com

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Code Blocks Search Directories only show up after a build?
« Reply #1 on: January 07, 2010, 03:04:02 pm »
It's the first time I heard of such an issue.

Can you provide a simple test-project where this happens ?

Which version of C::B and which OS (version) and wxWidgets (version) do you use ?

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5219
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: Code Blocks Search Directories only show up after a build?
« Reply #2 on: January 07, 2010, 03:06:30 pm »
It woks fine here when I right click on the "codeblocks.cbp" context menu.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline jiapei100

  • Multiple posting newcomer
  • *
  • Posts: 20
    • Vision Open
Re: Code Blocks Search Directories only show up after a build?
« Reply #3 on: January 07, 2010, 03:20:59 pm »

I'm using
Ubuntu 9.10 + C::B 8.0.2 + wxWidgets 2.8.10.1-0ubuntu1






It's the first time I heard of such an issue.

Can you provide a simple test-project where this happens ?

Which version of C::B and which OS (version) and wxWidgets (version) do you use ?
Welcome to Vision Open
http://www.visionopen.com

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6534
    • My Best Post
Re: Code Blocks Search Directories only show up after a build?
« Reply #4 on: January 07, 2010, 07:41:25 pm »
Is this just the normal operation of "Build Options" not working while the user is building the project?

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline jiapei100

  • Multiple posting newcomer
  • *
  • Posts: 20
    • Vision Open
Re: Code Blocks Search Directories only show up after a build?
« Reply #5 on: January 07, 2010, 11:58:33 pm »

I've got no idea what you are referring to.
But, I uploaded a video in .ogv format at
http://www.visionopen.com/rec.ogv

please find suitable codec to broadcast it.

Then, you will see what's happening in my C::B ...


Cheers
JIA Pei


Is this just the normal operation of "Build Options" not working while the user is building the project?

Tim S.
Welcome to Vision Open
http://www.visionopen.com

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Code Blocks Search Directories only show up after a build?
« Reply #6 on: January 08, 2010, 06:57:17 am »
You can have build options for the whole project and for the targets.

If you open the build options the first time, the project is selected, which has no seacrh-directories set.
After first building the actual target is selected, which has search directories.

EDIT:
What I forgot to write:

The cause for that behaviour is, that the project is not active at the moment you open the build options the first time, so the projects build options are selected.
After a build the project is selected and you get the active targets build options shown as default (the same would happen if you activate the project before).

Offline jiapei100

  • Multiple posting newcomer
  • *
  • Posts: 20
    • Vision Open
Re: Code Blocks Search Directories only show up after a build?
« Reply #7 on: January 08, 2010, 07:26:40 am »


Thanks, Jens:

That's the reason. Thanks very much.
Problem solved.

Cheers
JIA
Welcome to Vision Open
http://www.visionopen.com