Author Topic: I'm too dumb to install Code::Blocks under GNU/Linux  (Read 7404 times)

Offline Bloop

  • Multiple posting newcomer
  • *
  • Posts: 16
I'm too dumb to install Code::Blocks under GNU/Linux
« on: October 25, 2005, 10:41:32 pm »
Good evening

Well guys, you have a great IDE, but either your documentation skills are low or my ability to read is lost in the woods.

Ok I am using Gentoo here, and I don't think I'm that newbish but your package is not at all fool proof.
What I did:

Installed wxWidgets with Gentoo's allmighty "emerge wxGTK" with the following attributes: no_wxgtk1 gtk2 -unicode . I have RTFM which took me 2 seconds and then I went over to the Wiki.

Next downloaded the Source Tarball, not the CVS.
Extracted the with "tar -xzf codeblocks***RC2", got a : lone 0 at block 21234, entered the codeblocks dir, and .. saw nothing.

Which means I no Makefile or script or anything. I went to src, found the same unusable Makefile.am . "cat bootstrap" looked promising, but after some reading the look vanished. Wiki told me to "make -f Makefile.unix" but no go.

I'm blind. I will at once kill Tux and die with WinXP.

Please enlighten me!

Best regards Bloop

Offline David Perfors

  • Developer
  • Lives here!
  • *****
  • Posts: 560
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #1 on: October 25, 2005, 10:54:34 pm »
looks like there is a problem with the tar package I can't tets it right now, but perhaps you use the following command to extract the package and tell is how much you see:
Code: [Select]
tar -xvzf codeblocks1.0rc2.tgzthe option v gives you all the files that where extracted.

hmm. I see that there is a md5 hash created. you can also do "md5sum codblocks1.0rc2.tgz" (I am not sure about the correct for of this, anyone?) and compare it with the md5sum on the downloadpage.
« Last Edit: October 25, 2005, 10:56:19 pm by mispunt »
OS: winXP
Compiler: mingw
IDE: Code::Blocks SVN WX: 2.8.4 Wish list: faster code completion, easier debugging, refactoring

Offline Bloop

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #2 on: October 25, 2005, 11:10:49 pm »
Hey there

The TAR seems to be in order! MD5 is exactly as stated on the download page. Somewhere I saw a statement regarding this lone 0. It said not to worry about this message.

Well my question is: HOW exactly, in simple words do I compile Code::Blocks for GNU/Linux ?

Regards bloop

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #3 on: October 25, 2005, 11:18:55 pm »
Quote
Ok I am using Gentoo here, and I don't think I'm that newbish but your package is not at all fool proof.

Code: [Select]
./bootstrap (only needed once)
./configure
make
make install (as root)
Be patient!
This bug will be fixed soon...

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #4 on: October 25, 2005, 11:24:05 pm »
Also, someone mentioned he had problems because of the line endings.
Although it's not happening for me, here's the proposed solution (use it if you get weird errors in bootstrap):

Code: [Select]
find . -type f -and -not -name "*.png" -and -not -name "*.bmp" | sed "s/.*/\"\\0\"/" | xargs dos2unix
Be patient!
This bug will be fixed soon...

Offline Bloop

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #5 on: October 25, 2005, 11:42:02 pm »
Been there done that. Isn't that the CVS way? Now look:

Your bootstrap in the root of your tar is not executable! When made executable or executed with "sh bootstrap" I get:

$ sh bootstrap
: command not found
: command not found
: command not found
: command not found
bootstrap: line 41: syntax error: unexpected end of file

Am I really the only one with this kind of problem?

Note:
I took the tarbal from here: http://www.codeblocks.org/downloads.shtml
I selected :
Code::Blocks sources

.tgz format
Filesize: 2,742,954 Bytes | Version: 1.0rc2
MD5 Hash: 425c700feb77d22b1b85b1061d2504d9

I do have the right file, do I?Or Am I trying to install the windows version?

Anyway thank you for your quick answer.

Regards Bloop

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #6 on: October 26, 2005, 12:09:05 am »
You need to have autotools (autoconf/automake) installed and the correct versions (be sure to check it).

There was some ebuild in the forums also, you may want to look at it.

Offline Bloop

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #7 on: October 26, 2005, 12:31:00 am »
Already done that after reading through the bootstrap script.

Code: [Select]
# Deal with some gentoo-specific issues
export WANT_AUTOMAKE='1.7'
export WANT_AUTOCONF='2.5'

## Using prereq in autoconf rather than here, mostly for the debian systems at
## this point
if test -z "`autoconf --version 2>&1|head -n 1|egrep '2.5'`"; then
        echo "Autoconf 2.50 or above is required. Aborting build...";
    exit 1;
fi

if test -z "`automake --version 2>&1|head -n 1|egrep '1.[7-9]'`"; then
        echo "Automake 1.7 or above is required. Aborting build...";
        exit 1;
fi


So bootstrap should tell me if automake and autoconf are missing. This is not the case, neither does bootstrap tell me, nor do I lack the right scripts:

autoconf     
autoconf-2.13       
autoconf-2.59   

automake   
automake-1.4
automake-1.5   
automake-1.6 
automake-1.7
automake-1.8
automake-1.9     

Could someone just download the tar an take a look at it? I have the feeling noone understands me.

I am checking the ebuild option right now! Thanks for that idea!

Regards Bloop

Offline gfgfd

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #8 on: October 26, 2005, 12:44:14 am »
I updated wiki entry for compiling Code::Blocks in Gentoo. See if that helps.. And someone could spell check my engrish :D

Offline gfgfd

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #9 on: October 26, 2005, 01:29:34 am »
Also, someone mentioned he had problems because of the line endings.
Although it's not happening for me, here's the proposed solution (use it if you get weird errors in bootstrap):

Code: [Select]
find . -type f -and -not -name "*.png" -and -not -name "*.bmp" | sed "s/.*/\"\\0\"/" | xargs dos2unix

This messed up some source files :( So instead use:
Code: [Select]
find . -type f -and -not -name "*.cpp" -and -not -name "*.h" -and -not -name "*.png" -and -not -name "*.bmp" | sed "s/.*/\"\\0\"/" | xargs dos2unix
After this it builds just fine.

Offline Bloop

  • Multiple posting newcomer
  • *
  • Posts: 16
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #10 on: October 26, 2005, 03:00:33 pm »
You are the man!

That did it. You should never work on linux when you are to tired to think.  :lol:

Thanks

Regards Bloop

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #11 on: October 26, 2005, 04:20:55 pm »
I think we should also exlude the *.c, *.cxx and *.ico .

Code: [Select]
find . -type f -and -not -name "*.cpp" -and -not -name "*.h" -and -not -name "*.png" -and -not -name "*.bmp" -and -not -name "*.c" -and -not -name "*.cxx" -and -not -name "*.ico"  | sed "s/.*/\"\\0\"/" | xargs dos2unixThese should be all files which shouldn't be converted. The rest should be XML or autotools files.

Or are there any additional files which should be excluded ?

Thanks for this great line of commands (this is why I like Linux, one line and done)

Daniel
Nightly builds for openSUSE

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #12 on: October 26, 2005, 05:05:37 pm »
Shouldn't it be easier JUST to modify the makefiles with dos2unix? why having to exlclude ALL extensions from aaa to zzz? (Just a thought, I'm a n00b in this linux area).

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: I'm too dumb to install Code::Blocks under GNU/Linux
« Reply #13 on: October 26, 2005, 07:00:35 pm »
Shouldn't it be easier JUST to modify the makefiles with dos2unix? why having to exlclude ALL extensions from aaa to zzz? (Just a thought, I'm a n00b in this linux area).

You have to convert the makefiles, bootstrap, the *.in's, src/update and the *.m4's , that are five.
The command would be a bit shorter but I think it's both ways nearly the same "effort".
Nightly builds for openSUSE