Author Topic: fatal error LNK1181: cannot open input file 'OgreMain.lib'  (Read 4891 times)

Offline sp_1d4r

  • Single posting newcomer
  • *
  • Posts: 8
  • reality bites
fatal error LNK1181: cannot open input file 'OgreMain.lib'
« on: October 25, 2005, 03:35:16 pm »
im using windows 2000 pro,
Microsoft Visual C++ Toolkit 2003 and compiler,
Microsoft Platform SDK, (including the 64 bit tools)
.NET Framework SDK Version 1.1,

and a default OGRE Application loaded(I love the ogre engine and hace made 200+ worspaces in MSCV 6 just fine)

and code::blocks was able to auto detect the Visual C++ Toolkit 2003 compiler.

Ive tried to add the directory reference in both Compile\Compiler Options\Directory Tab\ Compiler
and Project\Build Options\Directory Tab\ Compiler

and ive tried setting non-reletive paths as well.

and always the compiler displays:
fatal error LNK1181: cannot open input file 'OgreMain.lib'


so I think I set up the base compiler components well enough since it tries to compile, I just need to get past the mania of getting the directory paths right.

i re write my posts on average about 5 times, so if i just wrote this, hit the refresh button for more info

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: fatal error LNK1181: cannot open input file 'OgreMain.lib'
« Reply #1 on: October 25, 2005, 03:49:32 pm »
... always the compiler displays:
fatal error LNK1181: cannot open input file 'OgreMain.lib'

i don't use ogre, but from the error message you have posted, i can see, that you need to correct the path to the library file 'OgreMain.lib'
put the correct path to this file under Project\Build Options\Directories\Linker

Offline sp_1d4r

  • Single posting newcomer
  • *
  • Posts: 8
  • reality bites
Re: fatal error LNK1181: cannot open input file 'OgreMain.lib'
« Reply #2 on: October 25, 2005, 03:53:37 pm »
i just did that,

again

its not working.

and i set the environment variable that the default ogre workspace looks for and restarted my computer,
and that doesnt work either.

Since theres a OGRE workspace option, the environment variable is supposed to take care of most of the pathing itself, and it isnt workin'
« Last Edit: October 25, 2005, 03:56:58 pm by sp_1d4r »
i re write my posts on average about 5 times, so if i just wrote this, hit the refresh button for more info