Author Topic: Building Code::Blocks: error: ambiguous overload for 'operator[]'  (Read 11190 times)

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Building Code::Blocks: error: ambiguous overload for 'operator[]'
« Reply #15 on: December 09, 2009, 12:54:14 am »
--enable-contrib-plugins=all should lead to an "unrecognized option"-warning, --with-contrib-plugins=all is correct.

Offline KirkD

  • Multiple posting newcomer
  • *
  • Posts: 77
Re: Building Code::Blocks: error: ambiguous overload for 'operator[]'
« Reply #16 on: December 09, 2009, 12:58:08 am »
--enable-contrib-plugins=all should lead to an "unrecognized option"-warning, --with-contrib-plugins=all is correct.


You are correct.  I corrected the original message.  Thank you.

Offline KirkD

  • Multiple posting newcomer
  • *
  • Posts: 77
Re: Building Code::Blocks: error: ambiguous overload for 'operator[]'
« Reply #17 on: December 09, 2009, 01:37:56 am »
Done.

It seemed to work just fine following that web page.  It wasn't able to find the wx libraries and gave a shared object not found (file not found) error at first, which seemed to correct itself.  Regardless, it works fine now.

Oddly, the downloaded version was 5964 and the splash screen says 5961.  Not that it matters.

-Kirk


Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Building Code::Blocks: error: ambiguous overload for 'operator[]'
« Reply #18 on: December 09, 2009, 08:25:05 am »
Oddly, the downloaded version was 5964 and the splash screen says 5961.  Not that it matters.
That's because the revision 5962 to 5964 are commits to other (test-branches), not to trunk.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Building Code::Blocks: error: ambiguous overload for 'operator[]'
« Reply #19 on: December 10, 2009, 11:48:00 am »
I just finished an install of centos 5.4 64-bit.

I did not install anything non-standard except for wxWidgets from rpmforge, using this instructions: http://wiki.centos.org/AdditionalResources/Repositories/RPMForge.

No wxWidgets 2.8.9 on my system, also no wxbase (not even available).
After installing automake, libtool, gcc,  g++ (both 4.1) and bzip2-devel (the automake-system should look for it if needed [help-plugin as far as I know needs it], but I will fix this [most likely this weekend]), everything compiles without error and runs flawlessly.

So I think something on your system is terribly messed up.

Offline KirkD

  • Multiple posting newcomer
  • *
  • Posts: 77
Re: Building Code::Blocks: error: ambiguous overload for 'operator[]'
« Reply #20 on: December 10, 2009, 05:37:06 pm »
Well, "terribly messed up" seems a bit of an extreme assessment.

What do you get from

yum list wx*

and

yum deplist wxGTK*


?
« Last Edit: December 10, 2009, 05:47:37 pm by KirkD »

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Building Code::Blocks: error: ambiguous overload for 'operator[]'
« Reply #21 on: December 10, 2009, 06:29:44 pm »
Code: [Select]
[jens@localhost ~]$ yum list wx*
Loaded plugins: fastestmirror, priorities
443 packages excluded due to repository priority protections
Installed Packages
wxGTK.x86_64                         2.8.10-1.el5.rf                   installed
wxGTK-devel.x86_64                   2.8.10-1.el5.rf                   installed
Available Packages
wxGTK-gl.x86_64                      2.4.2-5.el5.rf                    rpmforge
wxGTK-stc.x86_64                     2.4.2-5.el5.rf                    rpmforge
wxGTK-xrc.x86_64                     2.4.2-5.el5.rf                    rpmforge
wxPython.x86_64                      2.8.9.1-1.el5.rf                  rpmforge
wxPython-devel.x86_64                2.8.9.1-1.el5.rf                  rpmforge
wxsvg.x86_64                         1.0-0.2.b7.el5.rf                 rpmforge
wxsvg-devel.x86_64                   1.0-0.2.b7.el5.rf                 rpmforge

Offline KirkD

  • Multiple posting newcomer
  • *
  • Posts: 77
Re: Building Code::Blocks: error: ambiguous overload for 'operator[]'
« Reply #22 on: December 10, 2009, 07:22:06 pm »
And yum deplist wxGTK*?

or better yet:

yum deplist wxGTK* | grep wxBase



Offline KirkD

  • Multiple posting newcomer
  • *
  • Posts: 77
Re: Building Code::Blocks: error: ambiguous overload for 'operator[]'
« Reply #24 on: December 10, 2009, 08:15:44 pm »
Interesting.  Even on a Fedora 10 install I see references to wxBase 2.8.9.  A fresh F12 install refers to wxBase 2.8.10, but there's still wxBase there.  Not that it matters too much as I have CodeBlocks installed on all these systems.  The Fedora installs went flawlessly, as you mentioned. 

As if the case with LINUX, it is always an adventure.

Code: [Select]
yum deplist wxGTK* | grep wxBase > out.txt

   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
  dependency: wxBase = 2.8.10-5.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
  dependency: wxBase = 2.8.9-1.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
  dependency: wxBase = 2.8.9-1.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
  dependency: wxBase = 2.8.10-5.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10
   provider: wxBase.i386 2.8.9-1.fc10
   provider: wxBase.i386 2.8.10-5.fc10