Author Topic: Visual C++ 2008 ?  (Read 8313 times)

Offline johne53

  • Regular
  • ***
  • Posts: 253
Re: Visual C++ 2008 ?
« Reply #15 on: October 26, 2009, 07:32:21 pm »
P.S. - Jens, while you're thinking about that, maybe you could let me know if this makes any sense.....

Now that my C::B update is mostly working I've tried to rebuild a project that was previously building fine with Cygwin-gcc. It still builds fine but I've noticed a subtle change with the latest C::B. The project happens to be sigc++2 and I'm building it as a DLL. With my previous version of C::B I used to get 3 x outputted target files, namely:- libsigc++2.dll, libsigc++2.a and libsigc++2.def

With the upgraded C::B those last two files are now called libsigc++2.dll.a and libsigc++2.dll.def respectively. Is there any way I can put them back to their old style? I tried tweaking the settings for automatic prefix and extension generation but that didn't seem to make any difference.

Offline koso

  • Multiple posting newcomer
  • *
  • Posts: 58
Re: Visual C++ 2008 ?
« Reply #16 on: October 26, 2009, 07:39:41 pm »
Here you can find little "hack" to that: http://forums.codeblocks.org/index.php/topic,10882.0.html

Offline johne53

  • Regular
  • ***
  • Posts: 253
Re: Visual C++ 2008 ?
« Reply #17 on: October 26, 2009, 09:10:35 pm »
Thanks koso. Unfortunately, the poster didn't say which compiler he was referring to but I'm guessing it might have been mingw. I just tried his suggestion with Cygwin gcc but it didn't work....  :(

[Edit...] Oops, I told a lie! It does actually work with Cygwin but you need to specify the full path to the required output files - otherwise the files do get created, but in the wrong folder.
« Last Edit: October 27, 2009, 09:53:24 am by johne53 »

Offline johne53

  • Regular
  • ***
  • Posts: 253
Re: Visual C++ 2008 ?
« Reply #18 on: October 28, 2009, 05:01:45 pm »
I am using nightly build 5859 with Visual C++ 2008 Express.

Just out of interest cacb, - are you seeing the same problem as me (the one where Ctrl+Shift+F9 is no longer working?)