Author Topic: Can't build anything? Just installed.  (Read 2454 times)

Arsenal94

  • Guest
Can't build anything? Just installed.
« on: October 14, 2009, 08:42:37 am »
I just installed Code::Blocks and used the standard package. When I went to test it with a basic Hello World file I click on the "Build an Run" tab, it then says "This file has not yet been built, do you want to do so now?" I click Yes, and the window will pop up numerous amount of times until it finally stops.

I then get this in the Compile log.
Code: [Select]
Compiling: C:\Program Files\CodeBlocks\Projects\Hello World.c
mingw32-g++.exe: installation problem, cannot exec `cc1plus': No such file or directory
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings

It goes for everything. I just switched from Dev-C++ because it got corrupted and I couldn't be bothered to re-install it.

Some help for this would be very much appreciated.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6666
    • My Best Post
Re: Can't build anything? Just installed.
« Reply #1 on: October 14, 2009, 02:57:47 pm »
1. Verify you installed all the MinGW G++/C++ files
2. If Windows Vista, upgrade to at least the newest 3.4.5 GCC from the MinGW Website.
(The one packaged with Code::Blocks 8.02 is NOT Vista Compatible.)

3. Turn on Full compiler Logging to help provide data to diagnose cause.
http://wiki.codeblocks.org/index.php?title=FAQ#Q:_How_do_I_troubleshoot_an_compiler_problem.3F

Note: 2 is the likely cause of issue; followed by 1.

Tim S.

FYI: This is NOT a beginner Web site; if you start to ask newbie c/c++ questions the thread will be locked.


« Last Edit: October 14, 2009, 03:00:44 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org