Author Topic: Errors with code::blocks+wxWidgets  (Read 3530 times)

Offline wild_wolf

  • Single posting newcomer
  • *
  • Posts: 4
Errors with code::blocks+wxWidgets
« on: May 01, 2014, 02:14:40 pm »
Code::blocks (svn 9744 )+wxWidgets 3.0
I created a new wxWidgets project by the wizard. Compiled it with no modify.But i got this error:
"
D:\wxWidgets3\lib\gcc_lib\libwxmsw30u.a(monolib_window.o):window.cpp|| undefined reference to `_time32'|
                                                                                                                                                    "
What can i do? >:( >:( >:(
I just want to use code::blocks+wxWidgets Instead of vc.
My desktop system is win8.1 x64.
« Last Edit: May 02, 2014, 03:38:59 am by wild_wolf »

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Errors with code::blocks+wxWidgets
« Reply #1 on: May 01, 2014, 02:19:43 pm »
That's an example for a post with nearly no information.

Please write what you want to do, what you have tried and when the error occurs (exact steps to reproduce).

Offline thor36

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: Errors with code::blocks+wxWidgets
« Reply #2 on: May 02, 2014, 02:17:38 am »
I am currently facing nearly the same problem.

I am using CodeBlocks 13.12 with default settings on Win7 x64 ( on laptop & desktop ). I installed wxWidgets 3.0 by help of wxPack 3.0 . I have a test project that worked well on my desktop, and now I tried to run it on laptop with copying the linker settings.   

I get the "build failed" with this error :

c:\program files (x86)\codeblocks\mingw\bin\..\lib\gcc\mingw32\4.8.1\..\..\..\libwxmsw30u.a(monolib_strconv.o):strconv.cpp
undefined reference to ' _time32 '


Offline thor36

  • Multiple posting newcomer
  • *
  • Posts: 32
Re: Errors with code::blocks+wxWidgets
« Reply #4 on: May 02, 2014, 12:57:57 pm »
http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28errors%29#Q:_How_do_I_troubleshoot_a_compiler_problem.3F

BlueHazzard , by your reply, are you trying to tell us to solve the problem using these instructions, or that our compilation problem report is not well structured for getting further help ?

I wrote the question here because I failed to find the issue myself ( I am a beginner ). I had luck before with solving this kind of errors if they referred to a function ( it was sometimes obvious to me which library was missing ). But this time I have no clue what is going on. Any help will be much appreciated. Thank you.

« Last Edit: May 02, 2014, 02:32:02 pm by thor36 »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6674
    • My Best Post
Re: Errors with code::blocks+wxWidgets
« Reply #5 on: May 02, 2014, 02:35:40 pm »
http://wiki.codeblocks.org/index.php?title=FAQ-Compiling_%28errors%29#Q:_How_do_I_troubleshoot_a_compiler_problem.3F

BlueHazzard , by your reply, are you trying to tell us to solve the problem using these instructions, or that our compilation problem report is not well structured for getting further help ?

I wrote the question here because I failed to find the issue myself ( I am a beginner ). I had luck before with solving this kind of errors if they referred to a function ( it was sometimes obvious to me which library was missing ). But this time I have no clue what is going on. Any help will be much appreciated. Thank you.



Without a build log there is NOT enough info to say what the cause is of the problem.
Even with it, it will likely take a wxWidget 3.0 build expert.
If you really think it is a CB problem, an exact list of steps to duplicate the problem will likely be needed.
(Needs at least the exact steps and options picked during the wxWidgets Wizard; remember to do the advanced config; state all the options set/checked on each wiz page.)
And, it might need the compiler version used in Code::Blocks; and the build options (or source of) wxWidget 3.0.

Right now I would guess a link library order caused error.
Edit 4: Or it is a 64/32 bit issue.
Or, a wxWidgets library issue.

Tim S.
« Last Edit: May 02, 2014, 02:58:49 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org