Author Topic: Code::Blocks and wxWidgets  (Read 8297 times)

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6671
    • My Best Post
Re: Code::Blocks and wxWidgets
« Reply #15 on: August 24, 2009, 05:24:44 am »
Found cause of the error.

wxPack_v2.8.8.04 is an DW2 (Dwarf2) build.

You can not mix SJLJ and Dwarf2 code without extra work; I do not know how to do it. But, others do it with C only programs.

From
http://wxpack.sourceforge.net/Main/ReleaseNotes

Quote
01/25/2009 Version 2.8.9.01 - Beta
    * ^ wxWidgets v2.8.9
    * ^ wxFormBuilder v3.0.58-beta
    * ^ wxAdditions v2.8.9.01 (Built against wxWidget v2.8.9)
    * ^ wxVC v2.8.9.01. (Built against wxWidget v2.8.9)
    * + Added Gcc4.3.2-sjlj compiled libraries.
    * - Removed Gcc 4.2.1-dw2 compiled libraries

Edit: I suggest trying wxPack v2.8.9.02  or building wxWidgets yourself.

Tim S.
« Last Edit: August 24, 2009, 05:26:17 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline f4Gg0t_43

  • Single posting newcomer
  • *
  • Posts: 8
Re: Code::Blocks and wxWidgets
« Reply #16 on: August 24, 2009, 05:30:18 am »
Okay thank you very much guys! Installing wxPack 2.8.9.02 right now. Will let you know if it works, if it doesn't I will try to build it myself. Thanks again.

Offline f4Gg0t_43

  • Single posting newcomer
  • *
  • Posts: 8
Re: Code::Blocks and wxWidgets
« Reply #17 on: August 24, 2009, 05:44:41 am »
It works!! Thank you guys so much!! I will look into SJLJ and DW2 differences later.