Author Topic: C::B for PowerPC  (Read 3943 times)

grass

  • Guest
C::B for PowerPC
« on: July 12, 2009, 10:25:42 am »
Hi All,
I have a powerPC (MPC5121) based board running Linux. I configured tools paths to point to my cross compile tools folder and also specified the path to the cross gdb.
A hello.cpp program compiles but the debugger fails, here is how the output looks

Building to ensure sources are up-to-date
Build succeeded
Selecting target:
Debug
Adding source dir: /home/stas/Work/HelloCB/
Adding source dir: /home/stas/Work/HelloCB/
Adding file: bin/Debug/HelloCB
Starting debugger:
done
Registered new type: wxString
Registered new type: STL String
Registered new type: STL Vector
Setting breakpoints
Debugger name and version: GNU gdb Fedora (6.8-23.fc9)
Program exited with code 01.
Debugger finished with status 0


What else do I need to configure to make the remote debugging work?

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: C::B for PowerPC
« Reply #1 on: July 12, 2009, 10:46:48 am »
There are two things you can do:

  • I suggest to turn on the Debugger's debug log with checking "Settings -> Compiler and debugger... -> Debugger settings -> Display debugger's debug log" to see the whole conversation with gdb,
  • you can try to uncheck "Catch C++ exceptions" at the same pane, if checked it can lead to a crash, if no c++ exceptions are used (most likely a gdb bug, because it seems to be gone here after debian has updated gdb to 6.8.50.20090628-cvs)