Author Topic: Iostream not found  (Read 10958 times)

psilobe

  • Guest
Iostream not found
« on: June 30, 2009, 10:13:23 am »
Tried a search on the subject but none of the results managed to fix my problem.

Yesterday everything was working fine, using gnu gcc compiler.
Created a new project this morning and got the following:

vningar\main.c|2|iostream: No such file or directory|

I opened another project with the exact configurations as this one and that compiles fine, there is nothing in the projects options that differs.
I tried linking iostream which produced the error inside the iostream that c++config.h couldnt be found in /bits. Now i'm at my wits end trying to solve a problem that wasnt there yesterday!

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 11932
    • Travis build status
Re: Iostream not found
« Reply #1 on: June 30, 2009, 10:22:00 am »
How do you expect to have iostream in pure C?
File extensions are important for c/c++ compilers.
Also what type of project have you created C or C++?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

psilobe

  • Guest
Re: Iostream not found
« Reply #2 on: June 30, 2009, 12:46:43 pm »
I created a blank project but added a .c file instead of a .cpp and that seemed to have coused the problem.Thanks, your comment fixed it for me. :)