Author Topic: missing -lglibc  (Read 2171 times)

Offline zorglub!

  • Multiple posting newcomer
  • *
  • Posts: 11
missing -lglibc
« on: June 16, 2009, 11:07:31 am »
Hi
Just Dl'd codeblocks-8.02mingw-setup on my XP PC...
ran the installer...so far so good

Tried to compile a piece of C code...

got a compile failed error message .
D:\CodeBlocks\MinGW\bin\ld.exe: cannot find -lglibc

Any idea ?

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
Re: missing -lglibc
« Reply #1 on: June 16, 2009, 12:13:41 pm »
Tried to compile a piece of C code...
got a compile failed error message .
D:\CodeBlocks\MinGW\bin\ld.exe: cannot find -lglibc
Just a guess: Do you try to compile a Linux program on Windows?
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline zorglub!

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: missing -lglibc
« Reply #2 on: June 16, 2009, 08:13:00 pm »
NO....

I have used the very same installer on another W2K PC...
install went fine, compile, debug and execute my C code no problem!!!

Only on this PC ( XP SP3...) I have this lib apparently not installed...and I really don't know why and how it went smoothly on one PC and crashed on the other...

But I  have another CodeBlock problem ...same PC but booted on Linux Mandriva... and I'll come back with this issue later on...i'd like to solve this one not to mix things up !!!

rgds