Author Topic: how to set enum =int?  (Read 5185 times)

Offline jeorama

  • Multiple posting newcomer
  • *
  • Posts: 12
how to set enum =int?
« on: June 05, 2009, 04:40:57 pm »
I use --enum_is_int  in other options but the log is "cc1.exe: error: unrecognized command line option "-fenum_is_int" "
I add -fshort_enums directly in .cbp file, and it doesn't works too.

my compiler is codesourcery g++(arm-2009q1-161-arm-none-eabi.exe) and in its datasheet, -fshort_enums is supported, I'm confused that which caused this issue, compiler or the CB?

ps: my platform: xp sp3+CB svn5602

and I use keil for arm with the same compiler, use --enum_is_int, although there is a mistake "cc1.exe: error: unrecognized command line option "-fenums_is_int"  ", but it generate the target file.
« Last Edit: June 05, 2009, 05:53:43 pm by jeorama »

Offline jeorama

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: how to set enum =int?
« Reply #1 on: June 06, 2009, 07:06:01 am »
oh,I got that --enum_is_int is only available for realview, so it is not a issue caused by CB, thanks all