Author Topic: Having Problem With configuring QT in VC++  (Read 8024 times)

saurabh_saini

  • Guest
Having Problem With configuring QT in VC++
« on: May 23, 2009, 12:40:19 am »
hi,
i have configured QT for my VC++ using this PDF " http://www.telldus.se/qt/tutorial.pdf " and it provides me a simple example to run but i m getting error messages:-

1>------ Build started: Project: qttest2, Configuration: Debug Win32 ------
1>Performing Makefile project actions
1>mingw32-make -f Makefile.Debug
1>mingw32-make[1]: Entering directory `f:/CRAP/qttest2/qttest2'
1>mingw32-make[1]: Leaving directory `f:/CRAP/qttest2/qttest2'
1>Makefile.Debug:58: *** missing separator. Stop.
1>mingw32-make: *** [debug] Error 2
1>Project : error PRJ0002 : Error result 2 returned from 'C:\WINDOWS\system32\cmd.exe'.
1>Build log was saved at "file://f:\CRAP\qttest2\qttest2\Debug\BuildLog.htm"
1>qttest2 - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

plz any one can help me
- saurabh

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6613
    • My Best Post
Re: Having Problem With configuring QT in VC++
« Reply #1 on: May 23, 2009, 03:18:15 am »
You log shows that you are using MinGW Make instead of MSVC++ NMAKE.
Are you sure this is what you are supposed to be doing?

Suggest: Trying to use MSVC++ (Visual 2005/2008) as your project Compiler.

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline davemaster

  • Single posting newcomer
  • *
  • Posts: 4
    • TeleTracking SAC
Re: Having Problem With configuring QT in VC++
« Reply #2 on: June 03, 2009, 07:19:38 am »
hi,
i have configured QT for my VC++ using this PDF " http://www.telldus.se/qt/tutorial.pdf " and it provides me a simple example to run but i m getting error messages:-

1>------ Build started: Project: qttest2, Configuration: Debug Win32 ------
1>Performing Makefile project actions
1>mingw32-make -f Makefile.Debug
1>mingw32-make[1]: Entering directory `f:/CRAP/qttest2/qttest2'
1>mingw32-make[1]: Leaving directory `f:/CRAP/qttest2/qttest2'
1>Makefile.Debug:58: *** missing separator. Stop.
1>mingw32-make: *** [debug] Error 2
1>Project : error PRJ0002 : Error result 2 returned from 'C:\WINDOWS\system32\cmd.exe'.
1>Build log was saved at "file://f:\CRAP\qttest2\qttest2\Debug\BuildLog.htm"
1>qttest2 - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

plz any one can help me
- saurabh


Greetings,

That errors seems like you're using the MingGW Compiler, not the VC++. Check the QT version: there's one for mingw, another for VC++, etc.

In your PATH environment variables, had you add the c:\Program Files\[whatever dir]\bin (where the compiler and linker are) so the cmd can find them in compiling time.

Best regards
David Elias Flores Escalante