Author Topic: CodeBlocks freezes during startup.  (Read 15198 times)

Offline adorlith

  • Multiple posting newcomer
  • *
  • Posts: 22
Re: CodeBlocks freezes during startup.
« Reply #15 on: October 11, 2005, 04:30:49 pm »
 Step by step debug:

CodeBlocks compiled with wxWidgets 2.6.2
...........................................................
(gdb) step                                                                     
59      in ../../runtime/gccmain.c                                             
(gdb)                                                                           
_GLOBAL__I__ZN12wxExSplitter12ms_classInfoE ()                                 
    at src/wxDockit/src/generic/exsplitter.cpp:107                             
107                 if ((pos.x < boundary[0].x) ||                             
Current language:  auto; currently c++                                         
(gdb) step                                                                     
__static_initialization_and_destruction_0(int, int) (__initialize_p=1,         
    __priority=65535) at src/wxDockit/src/generic/exsplitter.cpp:22             
22      IMPLEMENT_CLASS( wxExSplitter, wxWindow )                               
(gdb) step                                                                     
wxClassInfo::wxClassInfo(char const*, wxClassInfo const*, wxClassInfo const*, in
t, wxObject* (*)()) (this=0x4937c0, className=0x489011 "wxExSplitter",         
    baseInfo1=0x10550f90, baseInfo2=0x0, size=496, ctor=0)                     
    at D:/Work/wxWidgets-2.6.2/include/wx/object.h:74                           
74              {                                                               
(gdb)                                                                           
75                  sm_first = this;                                           
(gdb)                                                                           
76                  Register();                                                 
(gdb)                                                                           
                                                                               
Program received signal SIGILL, Illegal instruction.                           
0x100594f5 in wxClassInfo::Register() ()                                       
    at sdk/wxscintilla/src/scintilla/src/LexPerl.cxx:464                       
464                                                     while (bk > 0 && styler.
StyleAt(bk) == SCE_PL_IDENTIFIER) {                                             
(gdb) where                                                                     
#0  0x100594f5 in wxClassInfo::Register() ()                                   
    at sdk/wxscintilla/src/scintilla/src/LexPerl.cxx:464                       
#1  0xffffffff in ?? ()                                                         
#2  0x0044b123 in wxClassInfo::wxClassInfo(char const*, wxClassInfo const*, wxCl
assInfo const*, int, wxObject* (*)()) (this=0x4937c0,                           
    className=0x489011 "wxExSplitter", baseInfo1=0x10550f90, baseInfo2=0x0,     
    size=496, ctor=0) at D:/Work/wxWidgets-2.6.2/include/wx/object.h:76         
#3  0x004372d7 in __static_initialization_and_destruction_0(int, int) (         
    __initialize_p=1, __priority=65535)                                         
    at src/wxDockit/src/generic/exsplitter.cpp:22                               
#4  0x0043751a in _GLOBAL__I__ZN12wxExSplitter12ms_classInfoE ()               
    at src/wxDockit/src/generic/exsplitter.cpp:107                             
#5  0x004465f7 in __do_global_ctors () at ../../runtime/gccmain.c:59           
#6  0x00446459 in main (argc=1, argv=0x156bcf8, __p__environ=0x3e2a08)         
    at ../../runtime/main.c:24                                                 
(gdb)         
............................................................

CodeBlocks compiled with wxWidgets 2.6.1

............................................................
(gdb)                                                                   
Single stepping until exit from function _Z7wxEntryP11HINSTANCE__S0_Pci,
which has no line number information.                                   
                                                                         
Program received signal SIGSEGV, Segmentation fault.                     
0x10060575 in wxArrayString::Init(bool) ()                               
    at sdk/wxscintilla/src/scintilla/src/LexSmalltalk.cxx:222           
222             ident[il++] = static_cast<char>(sc.chNext);             
(gdb) where                                                             
#0  0x10060575 in wxArrayString::Init(bool) ()                           
    at sdk/wxscintilla/src/scintilla/src/LexSmalltalk.cxx:222           
#1  0x0022fed8 in ?? ()                                                 
#2  0x100b07c0 in wxEntry(HINSTANCE__*, HINSTANCE__*, char*, int) ()     
#3  0x004013da in WinMain (hInstance=0x400000, hPrevInstance=0x0,       
    lpCmdLine=0x251f10 "", nCmdShow=10) at src/app.cpp:297               
#4  0x00446538 in main (argc=1, argv=0x14db6a0, __p__environ=0x3e2a08)   
    at ../../runtime/main.c:73                                           
(gdb)                                                                   
................................................................................................................

There  are different lines where it crashes, but both are from wxscintilla module.
         

Offline adorlith

  • Multiple posting newcomer
  • *
  • Posts: 22
Re: CodeBlocks freezes during startup.
« Reply #16 on: October 11, 2005, 04:33:59 pm »
 I tried once again to debug and now I get a different file where it crashes:

Program received signal SIGSEGV, Segmentation fault.                           
0x10041e32 in wxHashTable::MakeKey(char const*) const ()                       
    at sdk/wxscintilla/src/scintilla/src/LexForth.cxx:136                       
136                 styler.ColourTo(pos1,SCE_FORTH_COMMENT);                   
(gdb) where                                                                     
#0  0x10041e32 in wxHashTable::MakeKey(char const*) const ()                   
    at sdk/wxscintilla/src/scintilla/src/LexForth.cxx:136                       
#1  0xb8fd2200 in ?? ()                                                         
#2  0x10041ea0 in wxHashTable::Put(char const*, wxObject*) ()                   
    at sdk/wxscintilla/src/scintilla/src/LexForth.cxx:139                       
#3  0x10058fb9 in wxClassInfo::Register() ()                                   
    at sdk/wxscintilla/src/scintilla/src/LexPerl.cxx:353                       
#4  0x0044b113 in wxClassInfo::wxClassInfo(char const*, wxClassInfo const*, wxCl
assInfo const*, int, wxObject* (*)()) (this=0x4937c0,                           
    className=0x489011 "wxExSplitter", baseInfo1=0x10541f40, baseInfo2=0x0,     
    size=496, ctor=0) at D:/Work/wxWidgets-2.6.1/include/wx/object.h:76         
#5  0x004372d7 in __static_initialization_and_destruction_0(int, int) (         
    __initialize_p=1, __priority=65535)                                         
    at src/wxDockit/src/generic/exsplitter.cpp:22                               
#6  0x0043751a in _GLOBAL__I__ZN12wxExSplitter12ms_classInfoE ()               
    at src/wxDockit/src/generic/exsplitter.cpp:107                             
#7  0x004465e7 in __do_global_ctors () at ../../runtime/gccmain.c:59           
#8  0x00446449 in main (argc=1, argv=0x14db6a0, __p__environ=0x3e2a08)         
    at ../../runtime/main.c:24                                                 
(gdb)                                                                           

Very strange !

Offline adorlith

  • Multiple posting newcomer
  • *
  • Posts: 22
Re: CodeBlocks freezes during startup.
« Reply #17 on: October 13, 2005, 11:08:52 am »
  I created a new user on my XP machine and run the CB under the new user. It works ! :?:
  I'm a unix programmer, so maybe the windows guy have any hints about this.  Thanks.

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: CodeBlocks freezes during startup.
« Reply #18 on: October 13, 2005, 02:13:21 pm »
Just to be sure, did you memtested recently your ram?

I often had very strange random problems, and it was a DDR module failure, those hardware problems are the worst.

Offline adorlith

  • Multiple posting newcomer
  • *
  • Posts: 22
Re: CodeBlocks freezes during startup.
« Reply #19 on: October 13, 2005, 03:02:29 pm »
  I'm using a Dell Inspiron 510 laptop, I never had any problem other than this. Which is not a problem by itself, but due to OS, I presume.

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: CodeBlocks freezes during startup.
« Reply #20 on: October 13, 2005, 03:09:21 pm »
I recall that in my pc that had defective ram, on windows behave strangely, hanging some apps, corrupting some data, but on slackware, for some reason, none of that ocurred.

But anyways, it's very strange the fact that the problem wasn't gone away with --clear-configuration, but with creating another user :shock:

Offline TDragon

  • Lives here!
  • ****
  • Posts: 936
    • Twilight Dragon Media
Re: CodeBlocks freezes during startup.
« Reply #21 on: October 13, 2005, 08:58:33 pm »
In case anyone's interested, I've been debugging on my spare time (not much the past couple of days), and have so far traced a freeze point to within ShowTips(). (I had to leave my home PC for work just now or I'd have taken it further, sorry.)
http://tdm-gcc.tdragon.net/ - TDM-GCC compiler suite for Windows (GCC 5.1.0 2015-06-28, 32/64-bit, no extra DLLs)

Offline adorlith

  • Multiple posting newcomer
  • *
  • Posts: 22
Re: CodeBlocks freezes during startup.
« Reply #22 on: October 13, 2005, 11:52:08 pm »
 Yes, it's working  :D !!! I've regedit-ed the show_tips value to 0, and it doesn't freeze anymore. I stil don't understand what happens  :?.

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: CodeBlocks freezes during startup.
« Reply #23 on: October 14, 2005, 05:19:09 am »
Lately I've been experiencing a weird behavior. Sometimes the screen freezes using 0% CPU on exit.

I have to right click on the taskbar several times until i get a dialog that says: "Workspace has been modified. Save?" Then I choose no. Anyway it hasn't appeared anymore since i fixed a last line related to the 99%-CPU freeze i mentioned earlier.

Anyway, try doing the right-click trick if you have the showtips enabled. Oh, yeah. Download from CVS first :-P parser.cpp, nativeparser.cpp and cbthreadpool.cpp have changed. If your CVS doesn't update them, you might have to wait until the anonymous CVS is refreshed. It may take a few hours.

Offline adorlith

  • Multiple posting newcomer
  • *
  • Posts: 22
Re: CodeBlocks freezes during startup.
« Reply #24 on: October 17, 2005, 01:35:59 pm »
 I've downloaded the HEAD and it works. But now it works also the version that didn't work before.