Author Topic: Segmentation fault after installation  (Read 8493 times)

Offline knackeback

  • Multiple posting newcomer
  • *
  • Posts: 13
Segmentation fault after installation
« on: October 10, 2005, 01:25:35 pm »
Hi,
I installed codeblocks-1.0-RC1-1 with wx2.6 under SuSE-Linux 9.3.
After installation I get a segmentation fault:
./run.sh: line 5: 13928 Segmentation fault      $APP_DIR/codeblocks.exe [email protected]

independent from call location (output or devel).

IIRC I saw a posting at this board that the CVS release is more robust.
However I'm behind a firewall, does C::B provide nightly tarballs
to try the CVS version ?

Offline David Perfors

  • Developer
  • Lives here!
  • *****
  • Posts: 560
Re: Segmentation fault after installation
« Reply #1 on: October 10, 2005, 01:30:34 pm »
No there is no nightly tarball...
but you can take the backup file of the cvs and check out the version from you're own computer... :?
OS: winXP
Compiler: mingw
IDE: Code::Blocks SVN WX: 2.8.4 Wish list: faster code completion, easier debugging, refactoring

Offline knackeback

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: Segmentation fault after installation
« Reply #2 on: October 10, 2005, 01:43:27 pm »
No there is no nightly tarball...
but you can take the backup file of the cvs and check out the version from you're own computer... :?
I'm not sure if I understand you right. I have no CVS access from my computer here.
But I can browse the content of the SF CVS repository with my webbrowser.
I did not found any backup file there.

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: Segmentation fault after installation
« Reply #3 on: October 10, 2005, 01:51:38 pm »
here
http://gda.utp.edu.co/~ceniza/CodeBlocks/
you can download binary snapshots of CodeBlocks

it's not daily updated but every few weeks, when a reasonably stable version of CodeBlocks was developed.

Thanks goes to Ceniza
http://forums.codeblocks.org/index.php?action=profile;u=307

Offline knackeback

  • Multiple posting newcomer
  • *
  • Posts: 13
Re: Segmentation fault after installation
« Reply #4 on: October 10, 2005, 02:04:49 pm »
here
http://gda.utp.edu.co/~ceniza/CodeBlocks/
you can download binary snapshots of CodeBlocks

it's not daily updated but every few weeks, when a reasonably stable version of CodeBlocks was developed.

Thanks goes to Ceniza
http://forums.codeblocks.org/index.php?action=profile;u=307


I'm unable to unzip the *.7z files with 'gzip' or 'zip' command.
Are these files linux-binaries ?

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: Segmentation fault after installation
« Reply #5 on: October 10, 2005, 02:09:35 pm »
no, its a windows binary snapshot, .7z is a relatively new compression format,
you can DL a client here
http://www.7-zip.org/

in future please try also using
http://google.com

;-)


edit
i've read JUST NOW, that you are looking for the linux binaries !
i'm sorry
« Last Edit: October 10, 2005, 02:17:16 pm by tiwag »

Offline David Perfors

  • Developer
  • Lives here!
  • *****
  • Posts: 560
Re: Segmentation fault after installation
« Reply #6 on: October 10, 2005, 03:34:37 pm »
No there is no nightly tarball...
but you can take the backup file of the cvs and check out the version from you're own computer... :?
I'm not sure if I understand you right. I have no CVS access from my computer here.
But I can browse the content of the SF CVS repository with my webbrowser.
I did not found any backup file there.
Sourceforge is backingup every repository and make the backup files available for download. (I don't know where they put them and don't have the time to search now sorry) when you find that tar.gz package you can unpack it somewhere. This is an exact copy of the repository, so you have to checkout from that local copy. it is just an alternative way which is far from perfect.

Another option is to wait for RC2 which should come very very soon...
« Last Edit: October 10, 2005, 03:36:18 pm by mispunt »
OS: winXP
Compiler: mingw
IDE: Code::Blocks SVN WX: 2.8.4 Wish list: faster code completion, easier debugging, refactoring

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Nightly builds for openSUSE

Offline zieQ

  • Almost regular
  • **
  • Posts: 155
Re: Segmentation fault after installation
« Reply #8 on: October 16, 2005, 02:53:25 pm »
would be cool if there was a link to the tarballs on C::B webpage ;)

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Segmentation fault after installation
« Reply #9 on: October 16, 2005, 04:41:29 pm »
would be cool if there was a link to the tarballs on C::B webpage ;)

Rick, are you reading this? ;)
Be patient!
This bug will be fixed soon...

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: Segmentation fault after installation
« Reply #10 on: October 16, 2005, 04:44:44 pm »
would be cool if there was a link to the tarballs on C::B webpage ;)
I've discovered that this sourceforge backup is only usable with a CVS server. So it's worthless for normal developers  :(

EDIT:  @zieQ: :idea: You meant tiwag's tarballs!  I thought you meant my link.
« Last Edit: October 16, 2005, 04:54:23 pm by daniel2000 »
Nightly builds for openSUSE

Offline Urxae

  • Regular
  • ***
  • Posts: 376
Re: Segmentation fault after installation
« Reply #11 on: October 16, 2005, 06:56:23 pm »
I've discovered that this sourceforge backup is only usable with a CVS server. So it's worthless for normal developers  :(

No, a CVS client should suffice. Normal developers are supposed to have those, so that shouldn't be a problem. Just extract the tarball somewhere and do a checkout from that location as a local repository.

EDIT: Oh, it looks like TortoiseCVS/CvsNt just started a (lock) server when I tried that out. So maybe a server is needed, but it seems to be included with my client. Whatever.
« Last Edit: October 16, 2005, 07:06:40 pm by Urxae »

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Segmentation fault after installation
« Reply #12 on: October 17, 2005, 01:13:38 am »
TortoiseCVS includes a minimalist version of CVSNT server. I use it at the job for local repositories. I back up the repository daily.

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Segmentation fault after installation
« Reply #13 on: October 19, 2005, 05:41:45 am »
Alright can anybody point me to the tarballs in question so I can add them to the page?

Thanks.

Offline Urxae

  • Regular
  • ***
  • Posts: 376
Re: Segmentation fault after installation
« Reply #14 on: October 19, 2005, 08:56:47 am »
Alright can anybody point me to the tarballs in question so I can add them to the page?

Sourceforge backups are here: http://cvs.sourceforge.net/cvstarballs/codeblocks-cvsroot.tar.bz2

(Note: direct link, will start download)

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: Segmentation fault after installation
« Reply #15 on: October 19, 2005, 10:13:29 am »
Hmm... doesn't sourceforge allow cron jobs, and don't they provide webspace, too?

Some people will possibly not think of using cvs from a local directory at all (I would not have thought of it, for example). They would unpack the .tar.gz  and get angry because it is all rubbish.

So, one could run a cron job every night that creates a folder, does a cvs checkout, and then tar/bzips that folder. That way people can just download and decompress that archive, and there they go, nothing to worry about, nothing that could go wrong.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."