Author Topic: Cannot start code::blocks 8.02 correctly  (Read 2794 times)

Offline xxx456

  • Single posting newcomer
  • *
  • Posts: 3
Cannot start code::blocks 8.02 correctly
« on: March 28, 2009, 06:00:10 pm »
I do not why.

When I try to start code::blocks 8.02 in XP home, code::blocks always show the logo figure and then STOP.

After I stop mingw32-gcc.exe,  code::blocks can work well.

I have re-install the code::blocks.

I also tried to update mingw.

Can anybody teach me to fix the problem?

Is it a correct action to start mingw32-gcc.exe when the code::blocks 8.02 is started?

« Last Edit: March 28, 2009, 06:06:50 pm by xxx456 »

Offline Ganbito

  • Multiple posting newcomer
  • *
  • Posts: 79
Re: Cannot start code::blocks 8.02 correctly
« Reply #1 on: March 28, 2009, 10:17:14 pm »
Let's see... are you starting mingw32-gcc.exe manually?

mingw32-gcc.exe it's a compiler, not a service that have to run on backwards, so it has to be called only to compile and codeblocks do that automatically when you build your projects.

Offline xxx456

  • Single posting newcomer
  • *
  • Posts: 3
Re: Cannot start code::blocks 8.02 correctly
« Reply #2 on: March 29, 2009, 04:20:55 am »
No. I don't start mingw32-gcc.exe manually.

Mingw32-gcc.exe don't start automatically until code::blocks starts and show its logo. Can you believe it?

On the other hand, I might not uninstall code::blocks correctly before I install a new one. The new code::blcoks always remembers the projects created by the old
 code::blcoks. I have no idea where the information is stored.

Offline xxx456

  • Single posting newcomer
  • *
  • Posts: 3
Re: Cannot start code::blocks 8.02 correctly
« Reply #3 on: March 29, 2009, 05:22:53 am »
I fix the problem now. :D
I installed Comodo Internet Security in my computer.
After removing comodo, I can use code::blocks happily.